Can't install search engines (Tramples over window.external)

Bug #1069793 reported by Chris Coulson on 2012-10-22
290
This bug affects 68 people
Affects Status Importance Assigned to Milestone
unity-firefox-extension (Ubuntu)
High
Unassigned

Bug Description

The addon "Unity Desktop Integration" replaces windows.external with its own object, breaking the ability to install Opensearch plugins from JS ( window.external.AddSearchProvider() )

TESTCASE:
1) Go to http://mycroftproject.com/dlstats.html
2) Choose any of the OpenSearch plugins and click on the name

EXPECTED BEHAVIOUR:
A modal window should pop up asking if the chosen plugin really should be installed

ACTUAL BEHAVIOUR:
A modal window pops up stating that the browser does not support OpenSearch plugins

Changed in unity-firefox-extension (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-firefox-extension (Ubuntu):
status: New → Confirmed
Changed in unity-firefox-extension (Ubuntu):
importance: Medium → High
Charlie Callow (wollac11) wrote :

This was reported quite some time ago but still effects the latest stable version of Ubuntu (12.10) with all the latest updates applied as of today. It would be good to see a swift fix for this as it effects any user who wishes to install a firefox search plugin.

I'm not even clear what the Ubuntu NS plugin actually does, if anything. I think this can be removed without losing anything important.

Seb Bonnard (sebma) wrote :

Hi, does anyone know a workaround for this bug ?

Seb: See comment #3. Remove the package.

tArKi (djtarki) wrote :

Keeps happening in Ubuntu 13.04

Best regards.

nicolas kleinklaus (nknico) wrote :

Same problem here with 13.04.

Imposible to add search engines from https://addons.mozilla.org or from http://mycroftproject.com/

pasimako (pasimako) wrote :

The add-on is called "Unity Desktop Integration" on 13.04 and has to be disabled before installing opensearch plugins using the AddSearchProvider method.

Benjamin Drung (bdrung) on 2013-07-11
description: updated
Andrew Davis (spinup) wrote :

To add a search engine to Firefox from mycroft:

Click Tools > Add-ons
Find "Unity Desktop Integration" > Click Disable
Add the extension from the Mycroft site
Back to Add-ons: "Unity Desktop Integration" > Click Enable

Markus Lutz (markus-gmlutz) wrote :

Same problem here with ubuntu 13.10
I was unable to install searchplugins without disabling "Unity Desktop Integration" ...

Na advance in 14.04.
BB

summary: - Tramples over window.external (breaks ability to install opensearch
- plugins)
+ Can't install search engines (Tramples over window.external)
Bryan Quigley (bryanquigley) wrote :

I can't reproduce this on Ubuntu 14.10. Can anyone still reproduce this on a fully up-to-date Ubuntu 14.04?

el_gallo_azul (el-gallo-azul) wrote :

I have a fully up-to-date Ubuntu 14.04. I used exactly the same process that I used before creating Bug #1248971, and exactly the same thing happened. ie. I was unable to install a new search engine.

I just noticed Message #8 so I will now go and try that...

...Yep that worked. I've now added that "Search Engine" that I was unable to install on 2013-11-07.

Matthäus Brandl (matthaeus) wrote :

I can confirm that this remains broken, the page from the bug description actually works, but not the plugins on Mycroft Project:
http://mycroftproject.com/dlstats.html
DIsabling the plugin "Unity Desktop Integration 3.0.2" and restarting Firefox still fixes this.

I'll change the bug description accordingly.

description: updated
description: updated
Tom Gelinas (tomgelinas) wrote :

This bug still exists in Ubuntu 15.04 .

Nathan Dorfman (ndorf) wrote :

Bug also exists in fresh installation of 14.04.3.

Nathan Dorfman (ndorf) wrote :

I ended up removing all four addons from my system (since they seem to be unmaintained and/or deprecated); here are the package names:

xul-ext-ubufox - Ubuntu modifications for Firefox
xul-ext-unity - Firefox extension: Unity Integration
xul-ext-webaccounts - Ubuntu Online Accounts extension for firefox
xul-ext-websites-integration - Firefox extension: Website Integration

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-firefox-extension - 3.0.0+14.04.20140416-0ubuntu1.15.04.1

---------------
unity-firefox-extension (3.0.0+14.04.20140416-0ubuntu1.15.04.1) vivid-security; urgency=medium

  * Ship empty packages - this addon will stop working soon due to Firefox's
    addon signing requirements anyway
    - update debian/rules
    - fixes LP: #1069793 - Can't install searchplugins from addons.mozilla.org

 -- Chris Coulson <email address hidden> Tue, 22 Sep 2015 17:34:40 +0100

Changed in unity-firefox-extension (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-firefox-extension - 3.0.0+14.04.20140416-0ubuntu1.14.04.1

---------------
unity-firefox-extension (3.0.0+14.04.20140416-0ubuntu1.14.04.1) trusty-security; urgency=medium

  * Ship empty packages - this addon will stop working soon due to Firefox's
    addon signing requirements anyway
    - update debian/rules
    - fixes LP: #1069793 - Can't install searchplugins from addons.mozilla.org

 -- Chris Coulson <email address hidden> Tue, 22 Sep 2015 17:34:40 +0100

Changed in unity-firefox-extension (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions