Counters and progress bars on the launcher are blurred if the launcher icon size is set to an odd number of pixels

Bug #991310 reported by coversnail
130
This bug affects 25 people
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
Low
Unassigned

Bug Description

Using Ubuntu 12.04
Unity version: 5.10.0-0ubuntu6

Many apologies if this is in the wrong place.

Steps to reproduce this bug:
Change the size of icons in the Unity launcher through the appearance settings. If the size is set to an ODD number of pixels then the counters and progress bars that are used by some applications in the launcher are blurred. When the size is set to an EVEN number then there is no problem.

See attached screenshots

Obviously its not really much of an issue as what's one pixel between friends, you can just pick an even value, but perhaps it would look better to just restrict the values to even numbers? Or perhaps its just my system, if so sorry for wasting anyones time. I'll include some screenshots for reference.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.10.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Sun Apr 29 17:40:17 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
coversnail (coversnail) wrote :
Revision history for this message
coversnail (coversnail) wrote :
Revision history for this message
coversnail (coversnail) wrote :
Revision history for this message
coversnail (coversnail) wrote :
Revision history for this message
Nekhelesh Ramananthan (nik90) wrote :

Thank you for taking your time to report this bug to make Ubuntu better. I can confirm this bug on my system as well. Hence marking this bug confirmed.

Side Note: If you report a bug against an incorrect package, do not worry, we will automatically transfer it to the right package. But thanks again to take your time to report this. The screenshots help a lot in identifying the issue as wel..

Changed in unity (Ubuntu):
status: New → Confirmed
description: updated
no longer affects: unity
Revision history for this message
Santiago Marín (stgo-marin) wrote :

I'm still having this issue with Ubuntu 13.04...

Adolfo Jayme (fitojb)
Changed in unity (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
tags: added: quantal raring
Stephen M. Webb (bregma)
Changed in unity:
status: New → Triaged
Revision history for this message
Sam HH (samhh-signups) wrote :

Still affects 13.10. Odd number of pixels = blurred, even number of pixels = as it should be.

Revision history for this message
Hernawan Fa'iz Abdillah (abdillah) wrote :

Affect 13.10 near fresh installation. Yes, it happened the same as the description.

Adolfo Jayme (fitojb)
tags: added: ubuntu-desktop-trusty
Adolfo Jayme (fitojb)
Changed in unity-control-center (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → George Karavasilev (kokoto-java)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 14.04.3+14.04.20140317-0ubuntu1

---------------
unity-control-center (14.04.3+14.04.20140317-0ubuntu1) trusty; urgency=low

  [ Robert Ancell ]
  * Only allow icons sizes to be even numbers because odd sizes look
    blurry. (LP: #991310)

  [ Sebastien Bacher ]
  * Backport some leak fixes from upstream, those were leading to
    dialogs not closing when they should (e.g when exiting the panel
    they belong to), hitting a segfault when used then. (LP: #1292038)
  * Use the correct naming for the "Text Entry" settings
  * handle pa_stream_peek returning null (LP: #1197029)
 -- Ubuntu daily release <email address hidden> Mon, 17 Mar 2014 13:46:59 +0000

Changed in unity-control-center (Ubuntu):
status: In Progress → Fix Released
Adolfo Jayme (fitojb)
Changed in unity-control-center (Ubuntu):
assignee: George Karavasilev (kokoto-java) → nobody
no longer affects: unity
no longer affects: unity (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers