unnecessary separation of keyboard and keyboard layout

Bug #883256 reported by Robert Roth on 2011-10-28
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
Wishlist
Unassigned

Bug Description

The new system settings tool for gnome 3 has replaced the old one, because that had lots of issues, and had too many items. But at least it did have filtering. Now the new one is starting to have the same problem:
1. Open system settings
Observe the two different keyboard-related items: Keyboard and keyboard layout
These two have similar icons, and I think the best would be to have them merged, as the only reason to keep them separated seems to be to differentiate between the category (Hardware and Personal) seems kindof strange, as people are used to have them in the same panel, and it would be nice to have keyboard-related settings in one place. So i suggest adding the keyboard layout panel back as a tab of the keyboard settings panel, as this way that panel would have three separate tabs.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
CheckboxSubmission: 358fa14de53c8e5a7761d072c2a2e99d
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Fri Oct 28 23:04:22 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110727)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to oneiric on 2011-10-26 (2 days ago)
usr_lib_gnome-control-center:
 deja-dup 20.0-0ubuntu3
 gnome-bluetooth 3.2.0-0ubuntu2
 indicator-datetime 0.3.1-0ubuntu1

Robert Roth (evfool) wrote :
Matthew Libersky (liberskym) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

I think this is improved in Ubuntu 13.10. Although there are still two separate panels, the Keyboard one is for keyboard settings and shortcuts. The Region & Language panel manages all the language-related settings. They use different icons.

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Confirmed
affects: gnome-control-center (Ubuntu) → unity-control-center (Ubuntu)
Changed in unity-control-center (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
Robert Ancell (robert-ancell) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers