No easy way to turn the Bluetooth menu on/off

Bug #829690 reported by Matthew Paul Thomas on 2011-08-19
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu network, Bluetooth, keyboard menus
Confirmed
Undecided
Unassigned
unity-control-center (Ubuntu)
Low
Charles Kerr

Bug Description

Problem occurs with: gnome-bluetooth 3.1.4-0ubuntu1, Ubuntu Ocelot
Does not occur with: Ubuntu 11.04

1. Try to work out how to hide the Bluetooth menu. (For example, your computer has a Bluetooth card but you never use it.)

What happens: There's no obvious way to do it.

What should happen: "At the bottom of the “Bluetooth” panel in System Settings should be a checkbox, “Show Bluetooth status in the menu bar”. It should be checked by default for a new user account, but should be sensitive only when there is a powered Bluetooth card or dongle. Whenever the checkbox is sensitive and checked, a Bluetooth menu should appear in the menu bar." <https://wiki.ubuntu.com/Bluetooth#specification>

This is an example of the general pattern described in <https://design.canonical.com/2012/04/status-menus/>: "If you never use a Bluetooth device, you shouldn’t need to see the Bluetooth menu. And so on."

Ubuntu 11.04 has an equivalent checkbox, so this is a regression.

[Originally reported by "Eustace" in <http://www.omgubuntu.co.uk/2011/08/power-cog-icon-oneiric/#comment-291049247>.]

Related branches

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Changed in ubuntu-indicator-mods:
importance: Undecided → High
description: updated
Changed in ubuntu-indicator-mods:
status: New → Triaged
Charles Kerr (charlesk) on 2012-01-30
Changed in gnome-bluetooth (Ubuntu):
assignee: nobody → charles (charlesk)
Charles Kerr (charlesk) on 2012-01-31
Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → In Progress
Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 3.2.1-1ubuntu5

---------------
gnome-bluetooth (3.2.1-1ubuntu5) precise; urgency=low

  * debian/patches/01_use_app_indicator.patch:
    - new "Show Bluetooth status in the menu bar" control center option,
      thanks charles (lp: #829690)
  * debian/patches/03_text_changes.patch:
    - updated the wording of some of the menu entries,
      thanks charles (lp: #906042)
  * debian/patches/start_in_classic_session.patch:
    - start the applet in the GNOME classic session (lp: #924098)

  [ Jeremy Bicha ]
  * debian/patches/01_use_app_indicator.patch:
    - Rename Preferences menu item to "Bluetooth Settings…" (lp: #906042)
 -- Sebastien Bacher <email address hidden> Fri, 03 Feb 2012 11:47:29 +0100

Changed in gnome-bluetooth (Ubuntu):
status: In Progress → Fix Released
Ted Gould (ted) on 2012-02-17
Changed in ubuntu-indicator-mods:
status: Triaged → Fix Released
Matthew Paul Thomas (mpt) wrote :

Still a problem with gnome-bluetooth 3.2.2-0ubuntu3.

Changed in gnome-bluetooth (Ubuntu):
status: Fix Released → Confirmed
Changed in ubuntu-indicator-mods:
status: Fix Released → Confirmed
importance: High → Undecided
Lars Karlitski (larsu) wrote :

The checkbox was definitely there at some point in the cycle. I disabled it some time ago and now have no way of bringing it back (except for setting the dconf key manually).

Sebastien Bacher (seb128) wrote :

those options got dropped from the control center by design decision from John, agreed by Olli

description: updated
Jeremy Bicha (jbicha) on 2012-08-27
affects: gnome-bluetooth (Ubuntu) → gnome-control-center (Ubuntu)
affects: gnome-control-center (Ubuntu) → unity-control-center (Ubuntu)
Changed in unity-control-center (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 14.04.3+14.04.20140224-0ubuntu1

---------------
unity-control-center (14.04.3+14.04.20140224-0ubuntu1) trusty; urgency=low

  [ Sebastien Bacher ]
  * Use new sound key, avoid depending on indicator-sound
 -- Ubuntu daily release <email address hidden> Mon, 24 Feb 2014 14:36:20 +0000

Changed in unity-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints