Ubuntu

Redesign display settings panel under unity

Reported by Pierre-Olivier Megret on 2011-06-21
80
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
gnome-control-center
Fix Released
Wishlist
unity-control-center (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gnome-control-center

in the display manager gnome-control-center, it has a thumbnail image displays. of these miniatures, we have a mini panel. Can we choose the primary display with drag and drop this mini panel ... The Bug Is That Is The mini panel gnome-shell one ... Would it be nice and more clear If You Can replace it with a little Unity or Something Like That. I joined capture;)

[Next Action]
* [Design] feedback about help label
* [andyrock] Link to branch/patch/code
* Code review of andyrock's proposed changes

--------------------------------------------------------
Desired Solution:

- Implement the new design for 'Display settings' as detailed in section 2.4 of the 'Gnome 3 System Settings changes' specification https://docs.google.com/a/canonical.com/document/d/1ILTJDiDCd25Npt2AmgzF8aOnZZECxTfM0hvsbWT2BxA/edit?hl=en_GB

- Note the concept of primary monitor is now removed, and that with a Launcher on every monitor there is no need to select on which monitor the Launcher should be displayed. See http://design.canonical.com/the-toolkit/unity-multi-monitor-interactions/

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Setting to triaged/wishlist

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Sebastien Bacher (seb128) wrote :

Thanks, that's really a bar, it could be as well the unity one out of the clock position, maybe we should just drop the label from it, it seems overwork to have to detect what environment is running to tweak the bar rendering

Thanks .. I think it's maybe miscellaneous but i discover this way to change the order of my screens to have Unity on the good one ... I spend e lot of time to discover it and to understand i can drag and drop the little panel ..finally I discovered the date in the middle and understood that's a copy of gnome-shell panel . if i could see a minimized Unity , I think I would have understood immediately .. More usable isn't it ?

PS : my english is very very poor ..I hope you will excuse it :-/

tags: added: desktop-oneiric
tags: removed: desktop-oneiric
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

This does not really break the functionality of this applet. Untargetting from oneiric, and dropping assignment.

Changed in gnome-control-center (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
status: Triaged → Won't Fix
Changed in gnome-control-center (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
importance: Wishlist → Low
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Sebastien Bacher (seb128) wrote :

So from bug #875644 Andrea seem interested to work on that:

"JohnLea mockup: https://launchpadlibrarian.net/82534397/system_settings_10_08_11_03.png

I propos to add an help label too: https://launchpadlibrarian.net/82857928/Selection_006.png"

Changed in gnome-control-center (Ubuntu):
assignee: Rodrigo Moya (rodrigo-moya) → Andrea Azzarone (andyrock)
summary: - Minimized panel in thumbnail screen is a gnome-shell panel
+ Redesign display settings panel under unity
Andrea Azzarone (andyrock) wrote :

@Sebastien

Thanks, i've already the code but i need design feedback about help label ;)

Changed in ayatana-design:
status: New → Confirmed
status: Confirmed → New
Changed in gnome-control-center (Ubuntu):
status: Triaged → In Progress
Bryce Harrington (bryce) wrote :

[The Design Team has identified this as a blocker issue for precise, so setting the Importance to Critical. This may be adjusted down once the bug has received further design and engineering analysis, if appropriate.]

Changed in gnome-control-center (Ubuntu):
importance: Low → Critical
Bryce Harrington (bryce) wrote :

@Andrea, thanks for your work on this! Could you post a link to the code you've done, that can be reviewed?

I've added tasks to the Next Actions section of the description.

description: updated
Andrea Azzarone (andyrock) wrote :

@Bryce I'm not able to find the code right now but I can redo it easily in few hours.

Bryce Harrington (bryce) wrote :

It would be great if you could; otherwise please outline what you did to solve it and one of us can try our hand at it.

Daniel van Vugt (vanvugt) wrote :

BTW, the required changes to Unity related to this bug are proposed in bug 742544.

Bryce Harrington (bryce) on 2011-12-20
description: updated
Changed in gnome-control-center:
importance: Unknown → Wishlist
status: Unknown → Confirmed
John Lea (johnlea) wrote :

Description updated with link to new design

description: updated
description: updated
Changed in gnome-control-center (Ubuntu):
assignee: Andrea Azzarone (andyrock) → nobody
status: In Progress → Confirmed
James Grace (jamesgrace) wrote :

Yes you are right, it is directly relate-able to bug 742544.

Dmitry Shachnev (mitya57) wrote :

I think the attached document has all the design information needed, so marking as Fix Committed.

Changed in ayatana-design:
status: New → Fix Committed
John Lea (johnlea) on 2012-02-09
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
tags: added: udp
Changed in ayatana-design:
status: Fix Committed → Triaged
Bryce Harrington (bryce) wrote :

Confirmed still affecting precise with unity 5.2.

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

good part of this work got done this cycle, lowering the importance

Changed in gnome-control-center (Ubuntu):
importance: Critical → Low
John Lea (johnlea) wrote :

@seb128; bumping the importance of this bug back up a bit because there is still a lot of important functionality missing from the current implementation ( only about 40% of the spec'ed changes to this panel were completed in the 12.04 cycle )

Changed in gnome-control-center (Ubuntu):
importance: Low → High
Changed in ayatana-design:
importance: Medium → High
John Lea (johnlea) on 2012-10-12
no longer affects: gnome-control-center (Ubuntu Oneiric)
John Lea (johnlea) on 2012-10-15
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in gnome-control-center:
status: Confirmed → Fix Released
affects: gnome-control-center (Ubuntu) → unity-control-center (Ubuntu)
Adolfo Jayme (fitoschido) wrote :

This has been fixed for a while already.

Changed in unity-control-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.