unity-control-center crashed with SIGSEGV in free()

Bug #1819368 reported by Doug McMahon on 2019-03-10
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
Medium
Unassigned

Bug Description

Happens when trying to open the info (details) panel

ProblemType: Crash
DistroRelease: Ubuntu 19.04
Package: unity-control-center 15.04.0+19.04.20190209-0ubuntu2
ProcVersionSignature: Ubuntu 4.19.0-13.14-generic 4.19.20
Uname: Linux 4.19.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
Date: Sun Mar 10 15:09:20 2019
ExecutablePath: /usr/bin/unity-control-center
ExecutableTimestamp: 1551456572
InstallationDate: Installed on 2019-03-09 (1 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190305.1)
ProcCmdline: unity-control-center info --verbose
ProcCwd: /home/doug
SegvAnalysis:
 Segfault happened at: 0x7f17f1c1f25d <__GI___libc_free+29>: mov -0x8(%rdi),%rax
 PC (0x7f17f1c1f25d) ok
 source "-0x8(%rdi)" (0xfffffff8) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity-control-center
StacktraceTop:
 __GI___libc_free (mem=0x100000000) at malloc.c:3109
 g_unix_mount_free () at /lib/x86_64-linux-gnu/libgio-2.0.so.0
 () at /usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libinfo.so
 () at /usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libinfo.so
 g_type_create_instance () at /lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-control-center crashed with SIGSEGV in __GI___libc_free()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
separator:

Related branches

Doug McMahon (mc3man) wrote :

StacktraceTop:
 free () from /tmp/apport_sandbox_1jm5qajc/lib/x86_64-linux-gnu/libc.so.6
 ?? ()
 ?? ()
 get_primary_disc_info_start (self=0x55feb7feec20) at cc-info-panel.c:569
 get_primary_disc_info (self=0x55feb7ac6400) at cc-info-panel.c:609

Changed in unity-control-center (Ubuntu):
importance: Undecided → Medium
summary: - unity-control-center crashed with SIGSEGV in __GI___libc_free()
+ unity-control-center crashed with SIGSEGV in free()
tags: removed: need-amd64-retrace
Doug McMahon (mc3man) on 2019-03-10
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Changed in unity-control-center (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+19.04.20190209-0ubuntu3

---------------
unity-control-center (15.04.0+19.04.20190209-0ubuntu3) disco; urgency=medium

  [ Khurshid Alam ]
  * panels/info/cc-info-panel.c:
    info: Fix crashes when retrieving disk size (lp: #1819368)

 -- Sebastien Bacher <email address hidden> Mon, 01 Apr 2019 18:03:01 +0200

Changed in unity-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers