Unplugging headset with audio panel open mutes internal mic

Bug #1716359 reported by Will Cooke on 2017-09-11
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Unassigned
unity-control-center (Ubuntu)
Low
Andrea Azzarone
Xenial
Undecided
Unassigned

Bug Description

Impact
======
This is required by OEM team.

Test Case
=========
1. Open System Settings -> Sound -> select the input tab
2. Plug headset and select Headset on Unknown Audio Device dialog.
3. Check external mic is working
4. Adjust the internal microphone volume.(Just change the volume value.)
5. Adjust headset input volume around 100% in Input tab from Sound settings
6. Unplug headset
7. Check internet mic status

Make sure the internal mic is not muted.

Regression Potential
===================
- Make sure that plugging/unplugging headphones does the correct thing.
- Make sure that manually selecting an headphone actually switch mic.
- Please also check that output sound works too.

Original Bug Report
===================
This bug was reported by our OEM team, I'm opening this public bug.

The internal microphone is muted after he headset is unplugged when the System Settings is running.
We can not reproduce this bug when closed the System Settings window before unplugged the headset.

Reproduce steps:
1. Open System Settings -> Sound -> select the input tab
2. Plug headset and select Headset on Unknown Audio Device dialog.
3. Check external mic is working
4. Adjust the internal microphone volume.(Just change the volume value.)
5. Adjust headset input volume around 100% in Input tab from Sound settings
6. Unplug headset
7. Check internet mic status

Related branches

Will Cooke (willcooke) wrote :

I've tried to reproduce this bug on a couple of machines.

On Xenial, on a Thinkpad X270 - I don't have access to the "Internal Mic" when a headset is attached. Only a single mic is shown, and when I unplug a headset the volumes are correct.

On an Artful running GNOME Shell on a Dell Inspiron 11 - I do have access to the internal mic while a headset is attached, but adjusting the volumes as described does not recreate this bug.

Seems that it might be hardware dependent as well as a potential u-c-c issue?

Will Cooke (willcooke) wrote :

Patch from the OEM team to address this issue.

Hui Wang (hui.wang) wrote :

This bug will not happen on Lenovo machines, since the headset-mic on Thinkpad is called Microphone instead of headset-mic.

This bug only happens on Dell machines which can't detect headset microphone from HW perspective, so when a headset is plugged in, a headset-mic and a headphone-mic will be showed in the sound-setting, and the problem only happens under this situation.

Hui Wang (hui.wang) wrote :

BTW, If you plug a headset into a Dell laptop, and a "Unknown Audio Device" dialog (unity-settings-daemon/plugins/media-keys/what-did-you-plug-in) pops up immediately, this means there are headset-mic and headphone-mic on this machine, then you can reproduce this problem on this machine.

Sebastien Bacher (seb128) wrote :

I can't reproduce the issue on a dell latitude e6410, is it supposed to happen with any headset?

@Daniel, did you see reports about similar issues while triaging? Do you have hardware that would expose the issue in which case could you maybe have a look?

The attachment "ucc.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Daniel van Vugt (vanvugt) wrote :

I've tried three different Dells today and can't reproduce any such problem. The internal mic always restores correctly and working.

Tried both 17.10 and 16.04 but it sounds like you mean Unity where the dialog is "Unknown Audio Device". So that's either 16.04 or 17.04.

And no I don't recall related bug reports.

Changed in unity-control-center (Ubuntu):
importance: Undecided → Low
Hui Wang (hui.wang) wrote :

Ethan.hsieh installed Ubuntu 17.10 (Artful Aardvark) daily build (Sep. 13) on steamboat mlk.
This bug can not be reproduced on Ubuntu 17.10.
The settings is gnome-settings-dameon 3.25.92-0ubuntu1.

Daniel van Vugt (vanvugt) wrote :

If it's not reproducible in 17.10 (using Gnome) then at best that's "Fix Released" or "Invalid" for gnome-control-center.

Buf if someone can still reproduce it in 16.04/17.04's unity-control-center then this bug would remain open.

Hui Wang (hui.wang) wrote :

I can reproduce this problem in 16.04 with unity-control-center.

tags: added: xenial
Sebastien Bacher (seb128) wrote :

Hui, could you try if that's still an issue on 17.10? (under GNOME and Unity)
Also do you know what hardware is required to trigger the issue?

Yuan-Chen Cheng (ycheng-twn) wrote :

@Seb, per #8, it can't be reproduced on 17.10. Not sure why we need to test again.

Also, for machine, does the information on #3 and #4 not enough for you ?

Changed in oem-priority:
status: New → Confirmed
importance: Undecided → Critical
Will Cooke (willcooke) on 2017-10-26
Changed in unity-control-center (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) wrote :

Looks like there is some a race issue involving unity-control-center (and maybe caused by pulseaudio too). I suspect that gnome-control-center is affected by the problem too but its just harder to reproduce. I'm stating this because even with the provided hardware, enabling the debug logs in pulseaudio, the problem is hard to reproduce. I'm going to tweet a little bit the proposed patch and SRU it.

The sound panel needs some love I guess. E.g. why is g-c-c deciding which port the system should use after the user unplugs the headset? In my opinion this should be PA's job. g-c-c should react to changes notified by PA and "update PA status" just if there is an user interaction with the GUI.

Andrea Azzarone (azzar1) wrote :

Basically something like that: http://paste.ubuntu.com/25824913/. This makes more sense to me. I cannot see any regression. @Seb, @Will, @Yuan-Chen what do you think?

Hui Wang (hui.wang) wrote :

Tested the patch in #14, it works.

Andrea Azzarone (azzar1) on 2017-10-27
Changed in unity-control-center (Ubuntu):
status: New → In Progress
Andrea Azzarone (azzar1) on 2017-10-27
description: updated
Sebastien Bacher (seb128) wrote :

Thanks Andrea, the changes looks good and I'm preparing the SRU upload

Hello Will, or anyone else affected,

Accepted unity-control-center into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-control-center/15.04.0+16.04.20170214-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-control-center (Ubuntu):
status: In Progress → Invalid
Changed in unity-control-center (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Leon Liao (lihow731) wrote :

I can not reproduce this bug with the unity-control-center 15.04.0+16.04.20170214-0ubuntu2 on DELL Latitude 7490.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Changed in oem-priority:
status: Confirmed → Fix Committed
Brian Murray (brian-murray) wrote :

Were these tests, from the bug description, also performed with the new version of unity-control-center?

Regression Potential
===================
- Make sure that plugging/unplugging headphones does the correct thing.
- Make sure that manually selecting an headphone actually switch mic.
- Please also check that output sound works too.

Changed in unity-control-center (Ubuntu Xenial):
status: Fix Committed → Incomplete
Leon Liao (lihow731) wrote :

@Brian,

This is from OEM team.
We had verified the unity-control-center 15.04.0+16.04.20170214-0ubuntu2.
This bug can not be reproduced with the unity-control-center on -proposed.

Chris Halse Rogers (raof) wrote :

I'm sorry, we seem to be miscommunicating.

It's great that you verified that the bug is fixed. That is, that the internal mic is muted if you unplug the headphones while the control centre is open.

There were other concerns about the SRU though - specifically, that the following items *also* be tested:
- Verifying that plugging/unplugging headphones does the correct thing.
- Verifying that manually selecting a headphone actually switches the mic.
- Checking that output sound works too.

Were those verifications done, in addition to verifying that the bug cannot be reproduced?

Changed in unity-control-center (Ubuntu Xenial):
status: Incomplete → New
status: New → Incomplete
Leon Liao (lihow731) wrote :

@Chris,

I verified below check items on DELL Latitude 7490:

- Verifying that plugging/unplugging headphones does the correct thing: Pass
 When plugging a headphone, the Unknow Audio Device dialog will pop up. And, the headphone works fine. When unplugging the headphone, the device will be remove from the Settings list.
 When plugging a headset, Unknow Audio Device dialog will pop up. And, Both input and output function works fine. When unplugging the headset, the device will be remove from the Settings list.
  When plugging a microphone, Unknow Audio Device dialog will pop up. And, the microphone works fine. When unplugging the microphone, the device will be remove from the Settings list.

- Verifying that manually selecting a headphone actually switches the mic: Pass
 When plugging a headphone and switching the input device manually, only Internal Microphone works. The "Headset Microphone" and "Microphone" do not work.
 When plugging a headset and switching the input device manually, the "Internal Microphone" and "Headset Microphone" work. The "Microphone" does not work.
 When plugging a microphone and switching the input device manually, the "Internal Microphone" and "Microphone" work. The "Headset Microphone" does not work.

- Checking that output sound works too: Pass
 When plugging a headphone and switching the output device manually, both the "Speakers" and "Headphones" work.
 When plugging a headset and switching the output device manually, both the "Speakers" and "Headphones" work.
 When plugging a microphone and switching the output device manually, only the "Speakers" works. The "Headphones" does not work.

Leon Liao (lihow731) wrote :

@Brian and @Chris,

The "Regression Potential" items have been verified.
Could this unity-control-center in -proposed be SRU?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+16.04.20170214-0ubuntu2

---------------
unity-control-center (15.04.0+16.04.20170214-0ubuntu2) xenial; urgency=medium

  [ Andrea Azzarone ]
  * sound: Discard selection-changed events that are not triggered
    by the user (lp: #1716359)

 -- Sebastien Bacher <email address hidden> Tue, 31 Oct 2017 16:50:03 +0100

Changed in unity-control-center (Ubuntu Xenial):
status: Incomplete → Fix Released

The verification of the Stable Release Update for unity-control-center has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in oem-priority:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+17.10.20171225-0ubuntu1

---------------
unity-control-center (15.04.0+17.10.20171225-0ubuntu1) bionic; urgency=medium

  [ Andrea Azzarone ]
  * sound: Discard selection-changed events that are not triggered
    by the user (lp: #1716359)

  [ Dale Beaudoin ]
  * version change 17.10 to 18.04 LTS

  [ Khurshid Alam ]
  * Merge Robert Ancell's Desktop Sharing panel since Vino
    no longer provides its own settings app (LP: #1271358)

 -- Jeremy Bicha <email address hidden> Mon, 25 Dec 2017 14:10:10 -0500

Changed in unity-control-center (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers