unity-control-center in installed software is listed with wrong icon and title

Bug #1639507 reported by Vaidotas on 2016-11-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned
Zesty
Medium
Unassigned

Bug Description

[Impact]
In Ubuntu Software under Installed programs the listing for gnome-control-center package has title "Wacom Tablet" and tablet icon.
This is dangerously confusing, as average user can easily remove control center without knowing it.
I propose disabling gnome-control-center removal from Ubuntu Software by moving it to "System Applications" section.

[Test Case]
1. From a terminal run:
$ gnome-software --details-pkg unity-control-center

Observed result:
The title/description is from one of the panels inside u-c-c, e.g. "Wacom Tablet" or "Universal Access".

Expected result:
The title and description should be for unity-control-center.
NOTE: This requires the appdata to be updated and re-downloaded before this can occur.

[Regression Potential]
Low, we now just distribute appdata information.

Related branches

Vaidotas (joshas) wrote :
Robert Ancell (robert-ancell) wrote :

The package is unity-control-center not gnome-control-center and seems to be due to missing appstream data.

Changed in gnome-software (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Yakkety):
status: New → Triaged
Changed in gnome-software (Ubuntu Xenial):
status: New → Triaged
Changed in gnome-software (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → Medium
affects: gnome-software (Ubuntu Xenial) → unity-control-center (Ubuntu Xenial)
summary: - gnome-control-center in installed software is listed with wrong icon and
+ unity-control-center in installed software is listed with wrong icon and
title
Amr Ibrahim (amribrahim1987) wrote :

Ping!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+17.04.20170213-0ubuntu1

---------------
unity-control-center (15.04.0+17.04.20170213-0ubuntu1) zesty; urgency=medium

  [ Iain Lane ]
  * user-accounts: Reset the AccountsService password mode when setting
    the password. There's a codepath for directly setting the password
    when the user is setting their own, but this doesn't set the AS mode
    back to ACT_USER_PASSWORD_MODE_REGULAR. If you don't change this and
    you're in ACT_USER_PASSWORD_MODE_NONE, then you end up staying in
    the nopasswdlogin group. (LP: #1630156)

  [ Robert Ancell ]
  * Add AppData (LP: #1639507)

 -- <email address hidden> (<email address hidden>) Mon, 13 Feb 2017 10:04:53 +0000

Changed in unity-control-center (Ubuntu Zesty):
status: Triaged → Fix Released
description: updated
description: updated
Mathew Hodson (mathew-hodson) wrote :

Accepted unity-control-center into -proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-control-center/15.04.0+16.10.20170214-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-control-center (Ubuntu Yakkety):
status: Triaged → Fix Committed
Changed in unity-control-center (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

I tested this on Ubuntu 16.04 LTS with gnome-software 3.20.1+git20170208.0.a34b091-0ubuntu1~xenial1 (still in xenial-proposed today). I enabled -proposed updates. unity-control-center shows in gnome-software as "Text Entry" on my computer. Ok, maybe I should install the updated unity-control-center (I think if this bug were fixed, that wouldn't actually be necessary).

I installed the updated unity-control-center, ran 'pkill gnome-software' and tried again. Same result.

I ran 'sudo rm -rf /var/cache/app-info; sudo rm -rf /var/lib/app-info; sudo appstreamcli refresh'. After killing gnome-software, I got the same result.

See also https://bugzilla.gnome.org/779379

tags: added: verification-failed
removed: verification-needed
Robert Ancell (robert-ancell) wrote :

Does appstreamcli generate local appstream data or just pull it from the server again? I'm not sure if this change requires a server-side refresh of the appstream data.

Iain Lane (laney) wrote :

That's automatic and you can check it by just looking at the archive. I did not look in this case to see if it is right, but it was in the previous case (wine?).

I think someone should see my comment #4 on https://bugzilla.gnome.org/show_bug.cgi?id=779379

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.