Network applet fails to apply proxy settings system wide, giving IsADirectoryError message

Bug #1608543 reported by Jorge Morais on 2016-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

Background:
In Emacs, I had customized backup-directory-alist to (("." . ".~"))
Then, when I edited /etc/apt/apt.conf.d/10periodic, it created a backup file named /etc/apt/apt.conf.d/.~/10periodic~

The problem: today when I changed proxy settings in the network applet and tried to apply them system wide, it failed silently. Eventually I had the idea of starting unity-control-center in a terminal to see its error messages. I got multiple error messages. The message for http was:
(unity-control-center:5448): network-cc-panel-WARNING **: Error while calling set_proxy for http protocol: GDBus.Error:org.freedesktop.DBus.Python.IsADirectoryError: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python3/dist-packages/UbuntuSystemService/backend.py", line 232, in set_proxy
    res = self._write_apt_proxy(proxy_type, new_proxy)
  File "/usr/lib/python3/dist-packages/UbuntuSystemService/backend.py", line 149, in _write_apt_proxy
    open(f,"w").write("".join(new_content))
IsADirectoryError: [Errno 21] Is a directory: '/etc/apt/apt.conf.d/.~'

I saved the messages to a file and attached it.

I temporarily worked around the problem by moving /etc/apt/apt.conf.d/.~/ elsewhere. Later I may decide to reconfigure Emacs.

---
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
DistroRelease: Ubuntu 16.04
InstallationDate: Installed on 2016-07-12 (20 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
Package: unity-control-center 15.04.0+16.04.20160705-0ubuntu1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Tags: xenial gnome3-ppa third-party-packages
Uname: Linux 4.4.0-31-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

apport information

tags: added: apport-collected gnome3-ppa third-party-packages xenial
description: updated

apport information

apport information

Jorge Morais (jorgemorais) wrote :

Now I got apport-collect to work (the problem were incorrect proxy settings). Please ignore comment #2. I deleted that attachment and hid the comment.

description: updated
description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers