Bluetooth Browse Files... not working

Bug #1562822 reported by Huck-bernhard on 2016-03-28
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Unassigned
indicator-bluetooth (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
unity-control-center (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned

Bug Description

indicator

* Impact
The bluetooth indicator includes a non working "browse files..." items

* Test case
connect/pair a phone which does obex, open the bluetooth indicator and select the device, the only action listed should be "send"

* Regression potential
none, it's removing a widget which was doing nothing

----------
ucc

* Impact
The bluetooth settings include a non working "browse files..." items

* Test case
connect/pair a phone which does obex, open settings->bluetooth, the only action listed should be "send"

* Regression potential
none, it's removing a widget which was doing nothing

----------

Mobile phone: LG L40 Android 4.4.2

1. Connecting to Phone is successful shown.
2. Click on Button "Browse Files... " nothing happen.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity-control-center 15.04.0+16.04.20160315-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Mar 28 13:31:39 2016
ExecutablePath: /usr/bin/unity-control-center
InstallationDate: Installed on 2016-02-04 (52 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160204)
SourcePackage: unity-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Huck-bernhard (huck-bernhard) wrote :
Huck-bernhard (huck-bernhard) wrote :

Play Audio files from Phone is working, really cool features.
But "Send Files..." and "Browse Files..." is not working.
With Ubuntu 14.04 "Browse Files..." did work sometimes but connection was not really stabel.

Jeremy (wa113y3s) wrote :

You are likely missing a couple packages

sudo apt-get install obexfs obexftp

Then connect to the device and see if send files works

To receive files over bluetooth you will need to enable the option in Personal File Sharing, search dash for the program

Huck-bernhard (huck-bernhard) wrote :

i have installed obexfs and obexftp now.
But it is still the same send files is not working.

With Ubuntu 14.04 is it working.

Chih-Hsyuan Ho (chih) on 2016-04-06
Changed in oem-priority:
importance: Undecided → Critical
Franz Hsieh (franz-hsieh) wrote :

I have some problem on my platform.
I can connect to another PC without problems, however when I press the 'Browse file' it has no response.

By the away. I can get file list by using obexftp -b <DEVICE_ID> -c / -l, and download file with obexftp option.

Ara Pulido (ara) on 2016-04-22
Changed in oem-priority:
status: New → Won't Fix
Sebastien Bacher (seb128) wrote :

The obexftp backend (which wa got removed from

no longer affects: unity-control-center
Sebastien Bacher (seb128) wrote :

The obexftp backend (which was used to browse from nautilus) got removed from gvfs upstream because it was unmaintainer/buggy/not compatible with the new bluez, there is a bug to work on it and add it back
https://bugzilla.gnome.org/show_bug.cgi?id=757901

nobody seems to be active on that though and it's probably non trivial so I wouldn't count on it to be done this cycle without investing dev work on the topic

that said if we have "browse" buttons in u-c-c/indicator that are not functional we should remove those, that's probably easier to fix, I'm going to have a look to that

Changed in unity-control-center (Ubuntu):
importance: Undecided → High
status: New → In Progress
Changed in indicator-bluetooth (Ubuntu):
importance: Undecided → High
status: New → In Progress
description: updated
tags: added: desktop-trello-import
Kent Lin (kent-jclin) on 2016-05-16
Changed in oem-priority:
status: Won't Fix → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+16.10.20160512-0ubuntu1

---------------
unity-control-center (15.04.0+16.10.20160512-0ubuntu1) yakkety; urgency=medium

  * bluetooh: remove leftover "browse" button, the backend used was
    removed during the bluez5 update and the panel callbacks were
    cleaned out, the button is doing nothing else than confusing users
    (LP: #1562822)
  * update Ubuntu version for the new 16.10 serie

 -- Sebastien Bacher <email address hidden> Thu, 12 May 2016 14:12:08 +0000

Changed in unity-control-center (Ubuntu):
status: In Progress → Fix Released

Hello Huck-bernhard, or anyone else affected,

Accepted unity-control-center into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-control-center/15.04.0+16.04.20160413-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-control-center (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Huck-bernhard (huck-bernhard) wrote :

I have install the fix and make a Test

1. Button "Browse File.." is removed in unity-control-center. But in Top Right Menu is it still visible. See on Image.
2. Send File is working now with LG L40

Sebastien Bacher (seb128) wrote :

@Huck, that SRU is only about unity-control-center, the indicator part don't land yet

Sebastien Bacher (seb128) wrote :

the setting part works, the indicator is going to be next

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+16.04.20160413-0ubuntu2

---------------
unity-control-center (15.04.0+16.04.20160413-0ubuntu2) xenial; urgency=medium

  * bluetooh: remove leftover "browse" button, the backend used was
    removed during the bluez5 update and the panel callbacks were
    cleaned out, the button is doing nothing else than confusing users
    (LP: #1562822)

 -- Sebastien Bacher <email address hidden> Thu, 12 May 2016 17:48:47 +0200

Changed in unity-control-center (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity-control-center has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

description: updated
Changed in indicator-bluetooth (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-bluetooth - 0.0.6+16.10.20160526-0ubuntu1

---------------
indicator-bluetooth (0.0.6+16.10.20160526-0ubuntu1) yakkety; urgency=medium

  * Remove the "browse" action since there is no working backend (LP:
    #1562822)

 -- Sebastien Bacher <email address hidden> Thu, 26 May 2016 13:34:48 +0000

Changed in indicator-bluetooth (Ubuntu):
status: In Progress → Fix Released

Hello Huck-bernhard, or anyone else affected,

Accepted indicator-bluetooth into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/indicator-bluetooth/0.0.6+16.04.20160526-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-bluetooth (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Ara Pulido (ara) on 2016-05-30
Changed in oem-priority:
status: New → Fix Committed
Kristin Chuang (hyac109) wrote :

Hi,

I have installed the following 2 packages on my Xenial:
* unity-control-center (version 15.04.0+16.04.20160413-0ubuntu3)
* indicator-bluetooth (version 0.0.6+16.04.20160526-0ubuntu1)

Then I paired my Xenial to another bluetooth device (which is running Precise).

Results:
(1) Bluetooth indicator:
"browse files" function removed, "send file" function works correctly. [Verification Passed]

(2) Bluetooth settings:
"browse files" function removed, "send file" function works correctly. [Verification Passed]

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-bluetooth - 0.0.6+16.04.20160526-0ubuntu1

---------------
indicator-bluetooth (0.0.6+16.04.20160526-0ubuntu1) xenial; urgency=medium

  * src/desktop.vala:
    - remove the "browse" action since there is no working backend
      (LP: #1562822)

 -- Sebastien Bacher <email address hidden> Thu, 26 May 2016 13:34:48 +0000

Changed in indicator-bluetooth (Ubuntu Xenial):
status: Fix Committed → Fix Released
Ara Pulido (ara) on 2016-06-30
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.