unity-control-center crashed with SIGSEGV in FcitxConfigFree()

Bug #1431811 reported by Chris Glass on 2015-03-13
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
High
William Hua

Bug Description

Crashed when switching my input keyboard from English US to English UK.

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: unity-control-center 15.04.0+15.04.20150310-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.16.2-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Mar 13 11:50:15 2015
ExecutablePath: /usr/bin/unity-control-center
InstallationDate: Installed on 2015-03-12 (0 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150306)
ProcCmdline: unity-control-center keyboard
SegvAnalysis:
 Segfault happened at: 0x7fa5a4708767 <FcitxConfigFree+39>: mov (%rax),%rax
 PC (0x7fa5a4708767) ok
 source "(%rax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-control-center
StacktraceTop:
 FcitxConfigFree () from /usr/lib/x86_64-linux-gnu/libfcitx-config.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libregion.so
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libregion.so
Title: unity-control-center crashed with SIGSEGV in FcitxConfigFree()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
usr_lib_unity-control-center: deja-dup 32.0-0ubuntu5

Related branches

Chris Glass (tribaal) wrote :

StacktraceTop:
 FcitxConfigFree (config=config@entry=0x7fa5a4faacc0 <fcitx_config>) at /build/buildd/fcitx-4.2.8.5/src/lib/fcitx-config/fcitx-config.c:1030
 clear_fcitx () at gnome-region-panel-input.c:1612
 builder_finalized (data=<optimized out>, where_the_object_was=<optimized out>) at gnome-region-panel-input.c:1639
 weak_refs_notify (data=0x28545e0) at /build/buildd/glib2.0-2.43.91/./gobject/gobject.c:2630
 g_object_unref (_object=0x2873eb0) at /build/buildd/glib2.0-2.43.91/./gobject/gobject.c:3133

Changed in unity-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in unity-control-center (Ubuntu):
assignee: nobody → William Hua (attente)
importance: Medium → High
Changed in unity-control-center (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+15.04.20150408-0ubuntu1

---------------
unity-control-center (15.04.0+15.04.20150408-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ William Hua ]
  * Don't free the Fcitx config proxy if we haven't ever initialized it.
    (LP: #1431811)
  * Fix deprecation warnings in region panel.
 -- CI Train Bot <email address hidden> Wed, 08 Apr 2015 15:13:52 +0000

Changed in unity-control-center (Ubuntu):
status: In Progress → Fix Released
qiuxiao (muqiuxiao) wrote :

This bug is not fixed as far as I can see in

unity-control-center (15.04.0+15.04.20150410-0ubuntu1) vivid;

2 updates after the aforementioned 0408 update.

was asking me to update libcups2 however no luck after update it.

the same exact error appeared; also, it seems causing network icon disappeared as well even in IBUS mode.

Please investigate.

William Hua (attente) wrote :

Hi qiuxiao, do you know exactly what you did to produce the error?

Sebastien Bacher (seb128) wrote :
Changed in unity-control-center (Ubuntu):
status: Fix Released → Triaged
tags: added: xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers