Unmet dependencies for libcheese-gtk23 and libcheese7 on 14.04.2

Bug #1428972 reported by Po-Hsu Lin on 2015-03-06
100
This bug affects 21 people
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

I bumped into this issue while trying to install canonical-certification-client from our PPA [1]

ubuntu@201307-13942:~$ sudo apt-get install canonical-certification-client
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

However, the version number for these two packages are bigger than the required version number:

ubuntu@201307-13942:~$ dpkg -l | grep libcheese-gtk23
ii libcheese-gtk23:amd64 3.10.2-0ubuntu2 amd64 tool to take pictures and videos from your webcam - widgets
ubuntu@201307-13942:~$ dpkg -l | grep libcheese7
ii libcheese7:amd64 3.10.2-0ubuntu2 amd64 tool to take pictures and videos from your webcam - base library
ubuntu@201307-13942:~$

I have no clue for how this happens. I thought it was a problem to our PPA (bug 1427524), but I think we're not alone [2]

[1] http://ppa.launchpad.net/checkbox-dev/ppa/ubuntu/
[2] http://askubuntu.com/questions/593369/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Joel Allen (joelallen720) wrote :

Same error when attempting to install freeglut3-dev or libglfw-dev on 14.04.2

Matt (meh106) wrote :

Am seeing the same inability to install freeglut3-dev on a fresh ubuntu 14.04.2 amd64 installation.

Matt (meh106) wrote :

On 14.04.2 amd64, I've just been able to work around by installing specific variants of the dependencies for freeglut3-dev before installing freeglut3-dev itself:

    sudo aptitude install libxt-dev libgl1-mesa-dev-lts-utopic libglu1-mesa-dev
    sudo aptitude install freeglut3-dev

Nikhil (nikkr007) wrote :

Same error when attemoting to install libsdl1.2-dev on 14.04.2 version.

http://askubuntu.com/questions/593810/installing-libsdl1-20dev-on-ubuntu-14-04

HaiyanZhou (545164786-o) wrote :

Similar error when install qt-sdk or qtcreator on 14.04.2
zhy@zhy-ubuntu:~$ sudo apt-get install qtcreator
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 unity-control-center : 依赖: libcheese-gtk23 (>= 3.4.0) 但是它将不会被安装
                        依赖: libcheese7 (>= 3.0.1) 但是它将不会被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。

Yung Shen (kaxing) wrote :

by manually (re)install the packages mention by the unity-control-center then libcheese-gtk23 and libcheese7 themselves.

following command can bypass the dependency issue:

sudo apt-get install canonical-certification-client libcheese-gtk23 libcheese7 libclutter-1.0-0 libclutter-gtk-1.0-0 libcogl15 libclutter-gst-2.0-0 gstreamer1.0-clutter

Gabriel Zhi Chen (gabrielzchen) wrote :

Follow comment#7, after install the packages, checkbox could be installed successfully. @kaxing, Thank you.

Wagner (wag-p11-o) wrote :

I installed the nvidia-driver-346.47 after adding xorg-edgers ppa (using sudo add-apt-repository ppa:xorg-edgers/ppa ) to my system.

Wanted to setup packages for openGL development. While trying to install freeglut3-dev I get the following message:
//======================== Terminal Output =======================================
The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
//======================== Terminal Output =======================================

Giving: "sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade" outputs:
======================== Terminal Output =======================================
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) libgl1-mesa-dri-lts-utopic [ amd64 ] < 10.3.2-0ubuntu1~trusty2 > ( libs )
Broken libgl1-mesa-dri-lts-utopic:amd64 Conflicts on libgl1-mesa-dri [ amd64 ] < none -> 10.6.0~git20150318.27bf37ba-0ubuntu0ricotz~trusty > ( libs )
  Considering libgl1-mesa-dri:amd64 6 as a solution to libgl1-mesa-dri-lts-utopic:amd64 13
  Added libgl1-mesa-dri:amd64 to the remove list
  Conflicts//Breaks against version 10.1.3-0ubuntu0.3 for libgl1-mesa-dri but that is not InstVer, ignoring
  Conflicts//Breaks against version 10.1.0-4ubuntu5 for libgl1-mesa-dri but that is not InstVer, ignoring
  Fixing libgl1-mesa-dri-lts-utopic:amd64 via keep of libgl1-mesa-dri:amd64
Investigating (0) libgbm1 [ amd64 ] < 10.1.3-0ubuntu0.3 -> 10.6.0~git20150318.27bf37ba-0ubuntu0ricotz~trusty > ( libs )
Broken libgbm1:amd64 Depends on libgl1-mesa-dri [ amd64 ] < none -> 10.6.0~git20150318.27bf37ba-0ubuntu0ricotz~trusty > ( libs ) (= 10.6.0~git20150318.27bf37ba-0ubuntu0ricotz~trusty)
  Considering libgl1-mesa-dri:amd64 6 as a solution to libgbm1:amd64 0
  Holding Back libgbm1:amd64 rather than change libgl1-mesa-dri:amd64
 Try to Re-Instate (1) libgbm1:amd64
Done
Done
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following packages have been kept back:
  libgbm1
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

======================== Terminal Output =======================================

Trying to install freeglut3-dev through synaptic package manager suggest I should delete the following packages:

account-plugin-aim
account-plugin-jabber
account-plugin-salut
account-plugin-yahoo
cheese
empathy
gir1.2-totem-1.0
gnome-contacts
gstreamer1.0-clutter
indicator-bluetooth
libcheese-gtk23
libcheese7
libclutter-1.0-0
libclutter-gst-2.0-0
libclutter-gtk-1.0-0
libcogl-pango15
...and many more

Trying to install cuda sdk 7 also ouputs the same message at the beginning of this comment.

Tony (fennytansy) wrote :

For Comment #9, I had the same issue when trying to install cuda 7, and doing
sudo apt-get install libglew-dev libcheese7 libcheese-gtk23 libclutter-gst-2.0-0 libcogl15 libclutter-gtk-1.0-0 libclutter-1.0-0
fixed it for me.

OXullo Intersecans (oxullo) wrote :

I had the very same issue with libsdl1.2-dev under 14.04.2, but since yesterday I can't reproduce it anymore on a clean setup. Fixed?

Alexander Skiba (ghostlyrics) wrote :

This does not happen if you upgrade vom 14.04.0 or 14.04.1. I think it might have to do something with the hwe-lts kernel packages.

Liviu (euliviuonline) wrote :

Same error when trying to install libqt4-dev

Vikram Pawar (junoon-53) wrote :

I got the same error today when trying to install libglut3-dev

Guru (guruhb) wrote :

Same error
sudo ubuntu-drivers autoinstall
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Occelot (uturnweb) wrote :

I was able to resolved this error by issuing

`sudo aptitude full-upgrade`
&
`sudo apt-get install unity-desktop`

Graphics card: GeForce GTX 750
Driver: Nouveau

Karthik Radhakrishna (kartz89) wrote :

I tried installing CUDA but ended with below error

sudo apt-get install nvidia-cuda-toolkit
--------------------------------------- Terminal Output ---------------------------------------
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

--------------------------------------- Terminal Output ---------------------------------------

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers