Sound panel's "input" selection resets the default on every invocation

Bug #1376776 reported by Steve Langasek on 2014-10-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
High
Sebastien Bacher

Bug Description

Every time I open gnome-control-center, it resets my default audio source in pulseaudio.

$ pacmd info | grep Default.source
Default source name: alsa_input.usb-046d_081b_4D515DC0-02-U0x46d0x81b.analog-mono
$ gnome-control-center sound&
[1] 30266
$ pacmd info | grep Default.source
Default source name: alsa_input.pci-0000_00_1b.0.analog-stereo
$

The bugginess should be self-evident. Opening the control app should not change the configuration.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: gnome-control-center 1:3.12.1-5ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-16.22-generic 3.16.2
Uname: Linux 3.16.0-16-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Oct 2 07:43:20 2014
InstallationDate: Installed on 2010-09-24 (1469 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to utopic on 2014-05-23 (132 days ago)
usr_lib_gnome-control-center: deja-dup 32.0-0ubuntu1

Related branches

Steve Langasek (vorlon) wrote :
Sebastien Bacher (seb128) wrote :

" CurrentDesktop: Unity", you are probably using unity-control-center and not gnome-control-center? (it would be interesting to test if g-c-c has the same issue though)

On Thu, Oct 02, 2014 at 03:08:22PM -0000, Sebastien Bacher wrote:
> " CurrentDesktop: Unity", you are probably using unity-control-center
> and not gnome-control-center? (it would be interesting to test if g-c-c
> has the same issue though)

Ah, couldn't remember the name of this package and didn't notice that
/usr/bin/gnome-control-center was done as a wrapper script. Yes, this is
unity-control-center, not gnome-control-center; gnome-control-center does
not exhibit the problem.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Sebastien Bacher (seb128) wrote :

David, is there any chance you could look at this one?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
affects: gnome-control-center (Ubuntu) → unity-control-center (Ubuntu)
David Henningsson (diwic) wrote :

Hi Steve, could you please attach the output of pactl list, when the usb interface is plugged in?

Changed in unity-control-center (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) wrote :

Attached.

Changed in unity-control-center (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Michael MacEachern (maceach-b) wrote :

I've been having this problem for so long, that I am basically ready to ditch Ubuntu over it. Gnome control center does not have the issue for me, only ubuntu control center.

Michael MacEachern (maceach-b) wrote :

My bug report is here: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1334329

Every computer I have now has this bug since 14.10.

David Henningsson (diwic) wrote :

So this is a regression between 14.04 and 14.10? That's interesting.

David Henningsson (diwic) wrote :

Sorry for the slow reply. Since I can't reproduce it here, I'll need to ask for more logs, I'm afraid...

Please start unity-control-center like this:

G_MESSAGES_DEBUG=sound-cc-panel unity-control-center --verbose

And attach the log here. Thanks.

Michael MacEachern (maceach-b) wrote :

Here's mine, it's a huge log.

David Henningsson (diwic) wrote :

Thanks, I'm trying to analyze it.

One clue could be, that if this started happening recently, it could be related to the fix for https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1367693 - in which case one could try moving back to the previous version to see if it's fixed.

(Although I rather suspect that fixing that bug caused another bug to surface, rather than that the fix was wrong...)

Another interesting thing to notice is the difference between on_output_selection_changed and on_input_selection_changed in gvc-mixer-dialog.c, as the output selection has this line:

        g_debug ("\n\n on_output_selection_changed - active %i \n\n", active);
        if (active){
                return;
        }

...and input has not. I could try adding that line to the input path too, to see if that resolves the problem...

Michael MacEachern (maceach-b) wrote :

I'll try checking the fix when I get back home from work. If I leave Ubuntu control center open, it does actually change the inputs just fine, and apps get the change, I found that interesting because it is controlling Pulse. On my desktop closing the window seems to stay, but reopening sound preferences looses it. On my laptop, of which this bug report is from, sometimes closing the window looses the preferences also. I've been tackling this since 14.04 came out so I'm glad someones helping right now, and from what I see, definitely on the right track. Thanks.

Michael MacEachern (maceach-b) wrote :

Also, as for my laptop, this was happening far before then, and was happening for about 3/4 of the past year.. My desktop however, only just happened now since upgrading to 14.10. So for the laptop, I don't think it's related to the fix, but for the desktop, possibly.

David Henningsson (diwic) wrote :

Hi Brandon,

I uploaded what might be a fix to my ppa: https://launchpad.net/~diwic/+archive/ubuntu/temp - could you install unity-control-center from there and see if it fixes your bug? It's for 14.04.

If it does not fix it, could you redo the logging with the ppa version, i e,

G_MESSAGES_DEBUG=sound-cc-panel unity-control-center --verbose

...and attach the log here? Thanks.

Michael MacEachern (maceach-b) wrote :

It won't install because it keeps insisting a newer version is already installed.

David Henningsson (diwic) wrote :

> It won't install because it keeps insisting a newer version is already installed.

Hmm, it sure installs fine here. Here's my output of "apt-cache policy unity-control-center"
unity-control-center:
  Installed: 14.04.3+14.04.20140922-0ubuntu2
  Candidate: 14.04.3+14.04.20140922-0ubuntu2
  Version table:
 *** 14.04.3+14.04.20140922-0ubuntu2 0
        500 http://ppa.launchpad.net/diwic/temp/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     14.04.3+14.04.20140922-0ubuntu1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     14.04.3+14.04.20140410-0ubuntu1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Michael MacEachern (maceach-b) wrote :

You said it's for 14.04, I'm on 14.10. Oddly enough though, your PPA did not get listed, despite me putting it in the software sources and updating apt-get. :/

unity-control-center:
  Installed: 14.10.0+14.10.20140922-0ubuntu2
  Candidate: 14.10.0+14.10.20140922-0ubuntu2
  Version table:
 *** 14.10.0+14.10.20140922-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages
        100 /var/lib/dpkg/status

Michael MacEachern (maceach-b) wrote :

I was SSH-ed into my other computer, woops. Here's the true output from the one I am on right now that has your PPA. Still refuses to install, same error, claims the latest is already installed.

brandon@BrandonsLinuxLaptop:~$ apt-cache policy unity-control-centerunity-control-center:
  Installed: 14.10.0+14.10.20140922-0ubuntu2
  Candidate: 14.10.0+14.10.20140922-0ubuntu2
  Version table:
 *** 14.10.0+14.10.20140922-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages
        100 /var/lib/dpkg/status
     14.04.3+14.04.20140922-0ubuntu2 0
        500 http://ppa.launchpad.net/diwic/temp/ubuntu/ trusty/main amd64 Packages

David Henningsson (diwic) wrote :

Ok, I pushed a utopic version of it too. It's currently building, once it has finished building you shouldn't get the "latest is already installed" message anymore (after a sudo apt-get update).

David Henningsson (diwic) wrote :

Set to incomplete while waiting for either Steve or Brandon to test the package in the PPA.

Changed in unity-control-center (Ubuntu):
status: Confirmed → Incomplete
Steve Langasek (vorlon) wrote :

confirmed this fix using the ppa version of unity-control-center on utopic.

Changed in unity-control-center (Ubuntu):
status: Incomplete → Triaged
Changed in unity-control-center (Ubuntu):
status: Triaged → In Progress
assignee: nobody → David Henningsson (diwic)
Michael MacEachern (maceach-b) wrote :

Can confirm it works here too.

David Henningsson (diwic) wrote :

Thanks for confirming the fix,
I'm assigning this one back to Seb128 now - could you take it from here, w r t merging the branch you approved, and release new versions as you see necessary?
Thanks!

Changed in unity-control-center (Ubuntu):
assignee: David Henningsson (diwic) → Sebastien Bacher (seb128)
status: In Progress → Triaged
Michael MacEachern (maceach-b) wrote :

Looks like this is still stuck here, almost a month later.

That's ok, I switched to Debian. Sorry, I just can't be waiting like this anymore.

Sebastien Bacher (seb128) wrote :

@Brandon, if you switch distro every time you hit a bug, good luck to you

Sebastien Bacher (seb128) wrote :

(sorry for the delay David, landing should be done today)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+15.04.20141212-0ubuntu1

---------------
unity-control-center (15.04.0+15.04.20141212-0ubuntu1) vivid; urgency=low

  [ David Henningsson ]
  * When the treeview is programmatically updated, the treeview fires a
    signal that the active item has changed. To distinguish this from a
    user click, we check the active flag. This was done for output but
    not for input. (LP: #1376776) (LP: #1376776)

  [ Huan Peng ]
  * show desktop could not restore to default (LP: #1372868)
 -- Ubuntu daily release <email address hidden> Fri, 12 Dec 2014 15:33:22 +0000

Changed in unity-control-center (Ubuntu):
status: Triaged → Fix Released
Michael MacEachern (maceach-b) wrote :

@Sebastien, I only switch distros when a bug takes too long to fix, one shouldn't need to wait so long especially when switching sound outputs and inputs easily system wide must be done for my production.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers