There is no way to change the bluetooth system name from the standard GUI

Bug #1308922 reported by Hristo Erinin on 2014-04-17
254
This bug affects 125 people
Affects Status Importance Assigned to Milestone
Unity Control Center
Invalid
High
unity-control-center (Ubuntu)
Medium
Unassigned

Bug Description

The built-in bluetooth adapter of my laptop (running 14.04 Trusty Tahr, upgraded from 13.10 Saucy Salamander) appears with the default name "ubuntu-0". I could not find a way to change this name through the GUI tools (eg. System Settings->Bluetooth Settings or System Settings->Details->Overview->Device name)). This seems to be related to https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/989817 and probably caused by https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/644198 as my hostname is properly configured.

The explanation of the source of the problem in https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/989817/comments/12 seems to match the situation and so appears to be correct. The "Device name" in System Settings->Details->Overview is the proper hostname, and it is also greyed-out, so I can't make any modifications there. Unfortunately, short of editing manually /var/lib/bluetooth/[$ADDR]/config or creating /etc/machine-info I couldn't find a way to solve the problem. /etc/bluetooth/main.conf contains the default "Name = %h-%d".

I'm not completely sure how this could be solved - either there should be a way to set the name through "System Settings" if it has been stored already in /var/lib/bluetooth/[$ADDR]/config or ubiquity package should replace "ubuntu-0" with the hostname during the post-installation phase, after a proper hostname has been configured.

Please, feel free to reassign this bug to one of the other packages if you think that it should be solved there.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity-control-center 14.04.3+14.04.20140410-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Apr 17 11:23:21 2014
ExecutablePath: /usr/bin/unity-control-center
InstallationDate: Installed on 2013-12-19 (119 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: unity-control-center
UpgradeStatus: Upgraded to trusty on 2014-04-03 (13 days ago)
usr_lib_unity-control-center:
 activity-log-manager 0.9.7-0ubuntu13
 deja-dup 30.0-0ubuntu4
 gnome-control-center 1:3.6.3-0ubuntu56

Hristo Erinin (zorlem) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Changed in unity-control-center (Ubuntu):
importance: Undecided → Low
Bib (bybeu) wrote :

sudo hciconfig hci0 name 'The-Name-I-Choose' works but it resets to ubuntu-0 on reboot

Changed in unity-control-center:
importance: Unknown → High
status: Unknown → Invalid
Hans Deragon (deragon) wrote :

Seriously? Low priority? How are a bunch of Ubuntu users meeting together, manage to transfer files using Bluetooth when there is more than one Ubuntu laptop in the room, all showing up with the name "ubuntu-0"?

Whe are 107 people that confirmed this bug. I have exactly the problem that Hans describes in #4. Please, change this bug to medium or high to priorise the resolution, thanks!

Bib (bybeu) wrote :

How I did in 14.04:
Stopped Bluetooth with the top right applet
sudo service bluetooth stop
removed PRETTY_HOSTNAME from within /etc/machine-info
set the NaMe-I-wAnT both in
/etc/bluetooth/main.conf (replaced %h-%d with NaMe-I-wAnT)
and in /var/lib/bluetooth/[MAC-ADDR]/config (name NaMe-I-wAnT)
sudo service bluetooth start

Yeay
reboot to check persistence
Yeeeaaayyy

(PS : btw I also have
rfkill block bluetooth
just before the ending exit 0 line in /etc/rc.local
 to prevent BT coming UP on boot)

Adolfo Jayme (fitojb) on 2015-01-30
Changed in unity-control-center (Ubuntu):
status: Confirmed → Triaged
importance: Low → Medium
Norbert (nrbrtx) wrote :

Ubuntu 12.04 LTS is affected by this bug too.

tags: added: precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.