unity-control-center crashed with SIGSEGV in g_type_check_instance_cast()

Bug #1292038 reported by Alan Pope 🍺🐧🐱 πŸ¦„
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
unity-control-center (Ubuntu)
Low
Unassigned

Bug Description

Leaving dialog box open then opening another panel causes u-c-c to crash

To reproduce:-

Open u-c-c -> keyboard -> shortcuts -> custom shortcuts -> Add
Get distracted and leave that dialog open.
Later.. Open the date/time indicator and choose Date & Time Settings
U-c-c icon wobbles in the launcher
Switch to u-c-c and notice you still have a dialog open
Close dialog
Crash.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: unity-control-center 14.04.3+14.04.20140310-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Mar 13 14:39:52 2014
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/unity-control-center
InstallationDate: Installed on 2012-06-29 (621 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcCmdline: unity-control-center
SegvAnalysis:
 Segfault happened at: 0x7f138cf7334c <g_type_check_instance_cast+28>: mov (%rax),%rdi
 PC (0x7f138cf7334c) ok
 source "(%rax)" (0x00000005) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-control-center
StacktraceTop:
 g_type_check_instance_cast () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libkeyboard.so
 ?? () from /usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libkeyboard.so
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-control-center crashed with SIGSEGV in g_type_check_instance_cast()
UpgradeStatus: Upgraded to trusty on 2014-01-20 (52 days ago)
UserGroups: adm autopilot cdrom dialout dip libvirtd lpadmin plugdev sambashare sudo
usr_lib_unity-control-center:
 activity-log-manager 0.9.7-0ubuntu10
 deja-dup 29.5-0ubuntu2
 gnome-control-center 1:3.6.3-0ubuntu53
 gnome-control-center-unity 1.3+14.04.20140117-0ubuntu1

Related branches

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 g_type_check_instance_cast (type_instance=0x3e211b0, iface_type=36168880) at /build/buildd/glib2.0-2.39.91/./gobject/gtype.c:4002
 ?? () from /tmp/apport_sandbox_r9Jkug/usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libkeyboard.so
 ?? () from /tmp/apport_sandbox_r9Jkug/usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libkeyboard.so
 _gtk_marshal_BOOLEAN__BOXED (closure=0x3e150e0, return_value=0x7fffa5b57700, n_param_values=<optimized out>, param_values=0x7fffa5b577b0, invocation_hint=<optimized out>, marshal_data=<optimized out>) at /build/buildd/gtk+3.0-3.10.7/./gtk/gtkmarshalers.c:85
 g_closure_invoke (closure=0x3e150e0, return_value=0x7fffa5b57700, n_param_values=2, param_values=0x7fffa5b577b0, invocation_hint=0x7fffa5b57750) at /build/buildd/glib2.0-2.39.91/./gobject/gclosure.c:768

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in unity-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Changed in unity-control-center (Ubuntu):
status: New → Triaged
importance: Medium → Low
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 14.04.3+14.04.20140317-0ubuntu1

---------------
unity-control-center (14.04.3+14.04.20140317-0ubuntu1) trusty; urgency=low

  [ Robert Ancell ]
  * Only allow icons sizes to be even numbers because odd sizes look
    blurry. (LP: #991310)

  [ Sebastien Bacher ]
  * Backport some leak fixes from upstream, those were leading to
    dialogs not closing when they should (e.g when exiting the panel
    they belong to), hitting a segfault when used then. (LP: #1292038)
  * Use the correct naming for the "Text Entry" settings
  * handle pa_stream_peek returning null (LP: #1197029)
 -- Ubuntu daily release <email address hidden> Mon, 17 Mar 2014 13:46:59 +0000

Changed in unity-control-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.