/usr/bin/unity-control-center:6:g_assertion_message:g_assertion_message_expr:ibus_config_get_value:orientation_combo_changed:_g_closure_invoke_va

Bug #1288717 reported by errors.ubuntu.com bug bridge on 2014-03-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
High
William Hua

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding unity-control-center. This problem was most recently seen with version 14.04.3+14.04.20140303-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/6e9d539a36838cd0436c5f6ae6562501af77f13e contains more details.

Related branches

Sebastien Bacher (seb128) wrote :
Changed in unity-control-center (Ubuntu):
assignee: nobody → William Hua (attente)
importance: Undecided → High
status: New → Confirmed
William Hua (attente) wrote :

Problem seems to be that u-c-c can't connect to IBus for some reason.

What do you think about manually writing those settings through dconf/GSettings? It seems like IBus defaults to the dconf backend.

Sebastien Bacher (seb128) wrote :

Direct writting of the gsettings key works for me.

Aron (just added you to the bug cc to get your opinion on that), can we assume ibus is using gsettings under Unity sessions?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 14.04.3+14.04.20140310-0ubuntu1

---------------
unity-control-center (14.04.3+14.04.20140310-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * In the datetime panel's 'Time & Date' tab, update the time spinner
    every second. (LP: #1086486)

  [ Sebastien Bacher ]
  * Tweak some strings to match the design recommendations (LP:
    #1283150)

  [ William Hua ]
  * Write IBus settings directly to dconf. (LP: #1288717)
 -- Ubuntu daily release <email address hidden> Mon, 10 Mar 2014 15:42:21 +0000

Changed in unity-control-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers