symbol conflicts in libtimezonemap1

Bug #1187981 reported by Tim Lunn on 2013-06-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center
Confirmed
High
gnome-control-center (Ubuntu)
Undecided
Unassigned
libtimezonemap (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
unity-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

In gnome-control-center 3.8 all built in panels are statically linked. When the indicator-datetime panel loads it is picking up the symbols from the gnome datetime panel rather than the ones in libtimezonemap1, causing g-c-c to segfault.

All public symbols in libtimezonemap1 need to renamed to avoid conflict. Likewise this might apply to any other g-c-c plugins that have code cut+paste from the built in gnome panels.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: indicator-datetime 12.10.3daily13.05.06.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.9.0-2.7-generic 3.9.3
Uname: Linux 3.9.0-2-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.10.2-0ubuntu1
Architecture: amd64
Date: Thu Jun 6 12:35:40 2013
InstallationDate: Installed on 2012-09-23 (256 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120922)
MarkForUpload: True
SourcePackage: indicator-datetime
UpgradeStatus: No upgrade log present (probably fresh install)

Tim Lunn (darkxst) wrote :
Changed in gnome-control-center:
importance: Unknown → High
status: Unknown → New
Charles Kerr (charlesk) on 2014-03-06
affects: indicator-datetime (Ubuntu) → unity-control-center (Ubuntu)
Changed in gnome-control-center:
status: New → Confirmed
Simon Quigley (tsimonq2) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. If you test it and it is still an issue, kindly upload the updated logs by running only once:
apport-collect https://api.launchpad.net/1.0/bugs/1187981

and any other logs that are relevant for this particular issue.

Changed in gnome-control-center:
status: Confirmed → Incomplete
Changed in gnome-control-center (Ubuntu):
status: New → Incomplete
Changed in libtimezonemap (Ubuntu):
status: New → Incomplete
Changed in ubiquity (Ubuntu):
status: New → Incomplete
Changed in unity-control-center (Ubuntu):
status: New → Incomplete
Changed in gnome-control-center:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

that's not an issue in recent versions

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.