Opening files from the Dash randomly doesn't work

Bug #992717 reported by Péter Trombitás on 2012-05-01
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
unity-2d (Ubuntu)
Undecided
andresimi

Bug Description

My problem is really simple: if I click on a file in the dash (either an exact search result or a recent file), sometimes nothing happens. But in some cases, it works. I can't say that it has a problem with file types - for example, I can open a .jpeg file that's on my desktop, but neither can I open a .JPG that's in my pictures folder, nor one that's on an external HDD, nor one that's _also_ on the desktop.
This problem doesn't come up when using 3D unity.
If needed, I can try a live cd/fresh install, but my network connection is really slow so I would only do that if that's the only solution.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-2d 5.12.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Tue May 1 18:34:14 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120112)
PackageArchitecture: all
SourcePackage: unity-2d
UpgradeStatus: No upgrade log present (probably fresh install)

Péter Trombitás (trombipeti) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
andresimi (andresimi) on 2012-06-13
Changed in unity-2d (Ubuntu):
assignee: nobody → andresimi (andresimi)
Naël (nathanael-naeri) wrote :

This bug might be a duplicate of bug #1002710, if Péter can confirm that the files he can't open from the dash in Unity 2D are in a folder whose name contains Greek or accentuated characters (or perhaps, more generally, non-Latin characters).

That bug is another issue, at least when I try to open a picture in my
Pictures folder (called 'Képek' in Hungarian), I get a warning about the
file ~/K%C3%A9pek/... not being found, so it's not the same that I reported.
I now can't reproduce the bug I reported, but if I remember well in my case
nothing happened at all, no warning, no nothing.
I'm gonna use Unity 2D for a while now in order to try to reproduce the
problem.

2012/11/19 Nathanaël Naeri <email address hidden>

> This bug might be a duplicate of bug #1002710, if Péter can confirm that
> the files he can't open from the dash in Unity 2D are in a folder whose
> name contains Greek or accentuated characters (or perhaps, more
> generally, non-Latin characters).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/992717
>
> Title:
> Opening files from the Dash randomly doesn't work
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/992717/+subscriptions
>

Naël (nathanael-naeri) wrote :

Hi Péter, there is no mention of a warning/error in the bug I linked to (bug #1002710) or in its duplicates (bug #1003820 and bug #1013386). Opening files from the Dash fails silently, so your bug might be the same.

If you sometimes get a warning/error when you try to open files from the Dash, that might indicate another bug, or that the file you're trying to open has been moved/renamed/deleted.

You can try to reproduce your bug in Unity 2D by creating "test/somefile1.txt" and "tést/somefile2.txt" and try to open them from the Dash. You won't be able to use Unity 2D anymore if you've upgraded to Ubuntu 12.10 though.

Péter Trombitás (trombipeti) wrote :

Those files do exist.
I'm on Precise. I can open ~/test.txt but I get the error message when
trying to open ~/Képek/test.jpg.

2012/11/20 Nathanaël Naeri <email address hidden>

> Hi Péter, there is no mention of a warning/error in the bug I linked to
> (bug #1002710) or in its duplicates (bug #1003820 and bug #1013386).
> Opening files from the Dash fails silently, so your bug might be the
> same.
>
> If you sometimes get a warning/error when you try to open files from the
> Dash, that might indicate another bug, or that the file you're trying to
> open has been moved/renamed/deleted.
>
> You can try to reproduce your bug in Unity 2D by creating
> "test/somefile1.txt" and "tést/somefile2.txt" and try to open them from
> the Dash. You won't be able to use Unity 2D anymore if you've upgraded
> to Ubuntu 12.10 though.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/992717
>
> Title:
> Opening files from the Dash randomly doesn't work
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/992717/+subscriptions
>

Naël (nathanael-naeri) wrote :

Does ~ stands for peter or péter? If it stands for peter, then the bug you are reporting is indeed the same as bug #1002710, bug #1003820, bug #1013386: the Dash in Unity 2D fails silently to open files with an accentuated character in its name or path.

As for the warning/error you sometimes get, that would be a completely different bug, imho.

Péter Trombitás (trombipeti) wrote :

So ~ is "/home/trombipeti", no accents.

I always get a warning or the file opens. So I guess that this actual bug
is the duplicate of #1002710 etc, but I can't reproduce it anymore.

2012/11/20 Nathanaël Naeri <email address hidden>

> Does ~ stands for peter or péter? If it stands for peter, then the bug
> you are reporting is indeed the same as bug #1002710, bug #1003820, bug
> #1013386: the Dash in Unity 2D fails silently to open files with an
> accentuated character in its name or path.
>
> As for the warning/error you sometimes get, that would be a completely
> different bug, imho.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/992717
>
> Title:
> Opening files from the Dash randomly doesn't work
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/992717/+subscriptions
>

Naël (nathanael-naeri) wrote :

Sorry, I misread your comment #6. Indeed, it seems that the original bug you reported (silent fail) is the duplicate of bug #1002710, bug #1003820, bug #1013386, so I'm marking it as duplicate. The behavior you report now (error message) is different from the original behavior (silent fail), so that would indicate a different bug, that you could report if you want.

I don't know if the original bug is "gone" in your case, or if it's just "masked" by the new bug.

Naël (nathanael-naeri) on 2017-02-17
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers