Unity launcher does not re-appear when autohide switched on

Bug #989477 reported by Carl Englund on 2012-04-27
62
This bug affects 14 people
Affects Status Importance Assigned to Milestone
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Enable autohide in settings. Launcher does not re-appear when moving cursor to the left.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-2d 5.10.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-powerpc-smp 3.2.14
Uname: Linux 3.2.0-24-powerpc-smp ppc
ApportVersion: 2.0.1-0ubuntu6
Architecture: powerpc
Date: Fri Apr 27 11:20:13 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release powerpc (20120423)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=sv_FI:sv
 PATH=(custom, no user)
 LANG=sv_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: No upgrade log present (probably fresh install)

Carl Englund (englundc) wrote :
Albert Astals Cid (aacid) wrote :

are you pushing the monitor edge? Just moving it to the edge is not enough anymore.

Changed in unity-2d (Ubuntu):
status: New → Incomplete
Carl Englund (englundc) wrote :

Tried pushing as well as clicking, to no avail. Another user had the same problem: http://ubuntuforums.org/showthread.php?t=1965691

Albert Astals Cid (aacid) wrote :

Does Alt+F1 show the launcher?

Gerry Boland (gerboland) wrote :

Hi Carl,
if you press the Super key, does the Launcher appear (the Dash will too)?
Thanks
-G

summary: - Unity panel does not re-appear when autohide switched on
+ Unity launcher does not re-appear when autohide switched on
description: updated
Carl Englund (englundc) wrote :

Alt + F1 works for showing the Launcher, great to have that..I can use autohide now to get a lot more screen real-estate.

Pressing super gives the dash (where you can type commands) but not the Launcher!

Gerry Boland (gerboland) wrote :

How much you need to push the screen edge before the launcher gets the hint to reveal is adjustable in System Settings -> Appearance in the Behaviours tab.
Can you check the value of this, and perhaps set it differently?
-G

Carl Englund (englundc) wrote :

Oops, should have mentioned I already tried that. Had it first at standard and then tried the two extremes. Nothing changed.

Albert Astals Cid (aacid) wrote :

Hmmm, the fact that "Pressing super gives the dash (where you can type commands) but not the Launcher" is quire weird, can you please do this?

* Open a terminal
* write killall unity-2d-shell
* again write killall unity-2d-shell
* write unity-2d-shell
* Press super
* Attach here all the output the unity-2d-shell wrote in the terminal

Carl Englund (englundc) wrote :

Ok. I have to admit I'm a bit confused with the super keys now, because it was actually the ALT key that brings out the dash (but not the Launcher) where you can write keywords. The super (Apple) keys do nothing when I press them.

There were some interesting errors in the terminal output - they appeared when I moved the cursor to the left side of the screen, attempting to un-hide the Launcher:

"unity-2d-shell: [WARNING] PointerBarrierWrapper::smoother: maxVelocityMultiplier, decayRate or breakPressure not set"

Albert Astals Cid (aacid) wrote :

That output is bad and will cause the launcher not to show

Can you please attach a screenshot of the values of opening dconf-editor and navigating to com->unity-2d->launcher ?

Carl Englund (englundc) wrote :

I installed gconf-tools and took the picture. Here it is as an attchment. Hm. Should reveal-mode be set to 1?

JasonSpradlin82 (jaspradlin) wrote :

I have a similar issue with autohiding the launcher... When the launcher autohides, I can frequently go to the left and have it appear right away, but sometimes, I have to try 3 or 4 times quickly in succession for it to work. I know it's not an issue with not waiting long enough, because for the times that it doesn't work, I see the shadow of the launcher appear suddenly, then fade back out. This can happen, as I mentioned, up to 4 times before it will actually expand the menu (instead of just briefly displaying the drop shadow).

Having sensitivity set to default or High doesn't seem to change that. It appears, though, that on high, it might only show up consistently if I go really fast, as if I'm trying to break the mouse through the left side of the monitor and into the real world outside of confines of the desktop.

Jani Uusitalo (uusijani) wrote :

This was working for me during testing, but seems to have cropped up somewhere around release time. If I unmaximize all open windows, the left-side trigger works as intended, but at soon as I maximize one window, the launcher no longer appears no matter how hard I hit the left edge. Also, when this happens, Super just makes everything pale as if dash and launcher were opened on top, but they're not. Doubly also, there is some gesture that makes things work again, but I have yet to pinpoint what exactly it is. (I just had it happen briefly after temporarily disabling autohide, but that alone wasn't yet it.)

Albert Astals Cid (aacid) wrote :

JasonSpradlin82 you are using Unity and not Unity-2d, so open a different issue, totally unrelated to this one.

Albert Astals Cid (aacid) wrote :

Carl do you really get those

"unity-2d-shell: [WARNING] PointerBarrierWrapper::smoother: maxVelocityMultiplier, decayRate or breakPressure not set"

with those dconf-editor values? All seems fine there. Can you please do this in a shell

cd /usr
find -name com.canonical.Unity2d.gschema.xml
* wait a bit*
verify that
./share/glib-2.0/schemas/com.canonical.Unity2d.gschema.xml
is the only output?

Jani Uusitalo (uusijani) wrote :

Ah, scratch me off the list too (or rather, I will), can't believe I didn't realize this was for 2D. For us with 3D exhibiting this, there's at least Bug #990639.

ojordan (ojordan12345) wrote :

I've installed old versions of unity-2d to see when this broke. As far as I can tell, autohide stopped working in 5.7.0-0ubuntu1. That's when the new autohide came in I think?

./share/glib-2.0/schemas/com.canonical.Unity2d.gschema.xml is the only output from your command. I have the same values as Carl Englund in dconf-editor. I also have the same warning error message.

I'm on PowerPC too - does anybody have this problem who is not on PowerPC? Perhaps it is an endian thing?

Changed in unity-2d (Ubuntu):
status: Incomplete → Confirmed
Radoslaw (radw) wrote :

Similiar issue is on x86, but the launcher reveals sometimes when you try to move the mouse after the left edge of the screen. The behaviour seems to be inentional (except it shoud work always), related to this "feature":

http://design.canonical.com/2012/01/launcher-reveal-prototype/

The feature was introduced in the unity-2d 5.7 version as https://launchpad.net/bugs/765819.

Experimenting with dconf-editor shows that setting com.canonical.Unity2d.Launcher edge-reveal-presure to 0 makes the auto hide behavoiur to work more or less similiar as before.

Introducing the new reveal behavoiur without easy way to achieve the old behavoiur makes realy bad experience from users point of view. It looks like something which worked good before is broken after upgrade.

ojordan (ojordan12345) wrote :

Setting the edge-reveal-pressure to 0 doesn't work for me. Setting the hide mode to 2 (intellihide) is a useful setting, but doesn't fix the problem.

misiu_mp (misiu-mp) wrote :

It appears a lot of people are confused about the "pushing-the-edge" thing that you have to do to get the launcher. It is very nice when you know it, but totally impossible to figure out on your own quickly.
May I suggest changing the cursor into something suggestive when pushing the edge, so that the user knows there is something different there and maybe get an idea of what to do?

This issue of having to push against the edge is a real problem running a virtual machine in a window as the mouse simply moves out of the screen. There is no concept of pushing against anything. Please bring back the option to simply hover within a few pixels of the screen edge to active un-hide.

dberry (jk-kniberry) wrote :

After installing updates for 12.04 LTS on Sept. 25th 2012 reveal on pressing the edge seems to have been broken. Settings applied previously with ccsm or "system settings"->"appearance"->"Behavior" are not working correctly. Must either presss "alt+F1" to see the launcher or must turn off autohide.

I can confirm dberrys post (#23). I have the same issue now. Clean install of 12.04 a few hours ago, and after finishing updates the unity reveal no longer works via mouse. Changing compiz settings and resetting unity has no help. alt+f1 works for now.

aleandro (aleandrodasilva) wrote :

Update of Sept. 25th 2012 broke the auto-hide function on a previous system LTS 12.04 updated til 24th Sept.. Bug is quite annoying. Alt-F1 and super key lets the panel appear.

For yet no workarounds. You have to switch the auto-hide on off in order to abtain the fixed panle. No effects by administator panel, myunity and unsettings.

cheers

Omer Akram (om26er) wrote :

if you are seeing this bug with a recent update, that is because you have installed the latest nvidia driver which is causing this bug see bug 1057000

ojordan (ojordan12345) wrote :

I posted a bit of a hacked solution to this here http://ubuntuforums.org/showthread.php?t=2083770

Orangedouble (blahblahstuff) wrote :

I think I'm having the same problem, in 12.10. Here's how I produce the bug:

-Turn on autohide using Settings-->Appearance-->Behavior

At this point the launcher hides and appears as expected

-Run CompizVonfig Settings Manager, go to Window Management and uncheck "Snapping Windows" to turn the feature off.

At this point the launcher will not appear in response to the mouse. Super and Alt+F1 will make the launcher appear.

Resetting compiz and unity with dconf-tools puts things back to default, with the launcher capable of being put into autohide: dconf reset -f /org/compiz/

I also keep getting this error in the terminal window, but may be unrelated:

WARN 2013-01-18 16:44:38 unity <unknown>:0 Unable to fetch children: No such interface `org.ayatana.bamf.view' on object at path /org/ayatana/bamf/application0x1d19ac0

markus (markus-de-sade) on 2016-04-10
Changed in unity-2d (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers