Ubuntu

unity-2d-shell crashes when using with a NX server

Reported by Gendeau on 2012-04-17
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Albert Astals Cid
unity-2d (Ubuntu)
Critical
Albert Astals Cid
Precise
Undecided
Unassigned

Bug Description

Test case:
1. Start Ubuntu 2D on a NX server
2. Log in
   -> unity-2d-shell should not crash

===

just updated machine running over nx

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-2d-shell 5.10.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Tue Apr 17 13:55:37 2012
ExecutablePath: /usr/bin/unity-2d-shell
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: unity-2d-shell
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: unity-2d
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/libunity-2d-private.so.0
 qt_message_output(QtMsgType, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
Title: unity-2d-shell crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2012-04-01 (16 days ago)
UserGroups: adm admin cdrom dialout lpadmin mythtv plugdev sambashare video

Gendeau (gendeau) wrote :
visibility: private → public

StacktraceTop:
 Unity2dDebug::unity2dQtHandler (type=QtFatalMsg, message=0x10b81b8 "ASSERT: \"m_barrier != 0\" in file /build/buildd/unity-2d-5.10.0/libunity-2d-private/src/pointerbarrier.cpp, line 188") at /build/buildd/unity-2d-5.10.0/libunity-2d-private/src/unity2ddebug.cpp:89
 qt_message_output (msgType=QtFatalMsg, buf=0x10b81b8 "ASSERT: \"m_barrier != 0\" in file /build/buildd/unity-2d-5.10.0/libunity-2d-private/src/pointerbarrier.cpp, line 188") at global/qglobal.cpp:2203
 qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7f48823d1ae8 "ASSERT: \"%s\" in file %s, line %d", ap=0x7fffb94f8458) at global/qglobal.cpp:2322
 qFatal (msg=<optimized out>) at global/qglobal.cpp:2505
 PointerBarrierWrapper::setThreshold (this=0xf44bc0, threshold=6500) at /build/buildd/unity-2d-5.10.0/libunity-2d-private/src/pointerbarrier.cpp:230

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
summary: - unity-2d-shell crashed with SIGABRT in raise()
+ unity-2d-shell crashed with SIGABRT in Unity2dDebug::unity2dQtHandler()
tags: removed: need-amd64-retrace
summary: - unity-2d-shell crashed with SIGABRT in Unity2dDebug::unity2dQtHandler()
+ unity-2d-shell crashes when using with a NX server
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Albert Astals Cid (aacid) wrote :

Christopher James Halse Rogers suggested using XFixesQueryVersion to check for XFIXES version 6.0

Changed in unity-2d (Ubuntu):
assignee: nobody → Albert Astals Cid (aacid)
Changed in unity-2d:
milestone: none → 5.12
status: New → Confirmed
assignee: nobody → Albert Astals Cid (aacid)
importance: Undecided → Medium
Gerry Boland (gerboland) on 2012-04-26
Changed in unity-2d:
importance: Medium → Critical
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
James (morris-570) wrote :

I don't suppose there's a workaround for those of us who are having this problem?

Albert Astals Cid (aacid) wrote :

You can wait for 5.12 to be released really soon, alternatively you can change the configuration options of unity-2d not to use sticky edges (you can change this from the control panel but since you probably can get there look for it in dconf-editor com.canonical.unity2d) nor autohiding launcher (you can change this from the control panel but since you probably can get there look for it in dconf-editor com.canonical.unity2d.launcher), that should make pointer barriers not needed and workaround the crash.

description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu Precise):
status: New → Confirmed

Hello Gendeau, or anyone else affected,

Accepted unity-2d into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-2d (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Lois (loislegido) wrote :

Hi there,

Yes, having the same problem Unity 2D crashes and I'am unable to manage the desktop. Any news on this?

Thanks,

Luis

I am having the same problem. I was running 11.10 via NX. I upgraded to 12.04 and now unity crashes. I installed unity-2d from the precise-proposed archive but when I run /usr/bin/unity-2d-shell, I get unity-2d-shell: [FATAL] ASSERT: "m_barrier != 0" in file /build/buildd/unity-2d-5.10.0/libunity-2d-private/src/pointerbarrier.cpp, line 188
Aborted (core dumped).

Has anyone else had success?

James (morris-570) wrote :

many nx bugs have seemed to be fixed if you install the --proposed version. Personally all my problems have been resolved.

Lois - maybe your problems are due to a different issue (not this bug)?

Michael - afaik you should be running unity from the login screen or gnome-session --session=ubuntu-2d, not by running unity from the command line.

James, the reason I was running the unity-2d-shell from the command line is because the unity bar did not reappear after I installed the --proposed version. I did reboot after install. Where do you specify the gnome-session in the NX login?

Diego Luna (diegorluna) on 2012-04-28
Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu Precise):
status: Fix Released → Fix Committed
Albert Astals Cid (aacid) wrote :

Michael, in proposed you should see unity-2d 5.12 not 5.10, if you are using 5.20 it doesn't contain the fix for this

Albert Astals Cid (aacid) wrote :

obviously my last 5.20 is 5.10, sorry for the typo

Aaron Sowry (fq-airin-x0) wrote :

Martin - installing unity-2d-shell from pangolin-proposed fixes the crash for me. Thanks.

Martin Pitt (pitti) on 2012-05-02
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.12.0-0ubuntu1

---------------
unity-2d (5.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in ref() (LP: #968046)
    - [hud] First entry always activated with keyboard navigation
      (LP: #980899)
    - unity-2d-shell crashes on autoscrolling on launcher tile removal
      (LP: #988239)
    - unity-2d-shell crashes when using with a NX server (LP: #983942)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - [spread] When multiple windows of an app are open, clicking on one
      doesn't bring it to the foreground (LP: #917334)
    - [HUD][multi-monitor] HUD should be expanded to the left if used on a
      screen without launcher (LP: #979927)
    - unity-2d scope un-url-escapes values from its model (LP: #986175)
    - [places] tab key does nothing (LP: #891565)
    - HUD is silent to screen readers (LP: #949445)
    - launcher background coloring does not get reset when using enter to
      activate/start a program (LP: #965079)
    - [multi-monitor] [launcher] Drag & drop application to launcher on
      primary screen, other launchers not updated (LP: #966239)
    - HUD gets activated by Thinkpad USB Keyboard's back and forward buttons
      (LP: #968840)
    - Unity 2D doesn't load 24 bit icons (LP: #977262)
    - Four finger tap does not open the Dash (LP: #978659)
    - No icon in launcher entry, after installing software (LP: #980640)
    - Menu items displayed incorrectly when window streched over multiples
      monitors (LP: #987215)
    - [unity-2d-panel] The close button (potentially the others too) can
      toggled even when they are not visible anymore (LP: #924264)
    - When closing the Dash with the [x] panel button the last windows is not
      focused and doesn't allow to use window controls. (LP: #945459)
    - [launcher] item hint flickers when hovering between launcher edge and
      item (LP: #948383)
    - Missaligned progress bar (LP: #980609)
    - Launcher tile tooltip appears in wrong screen in RTL multimonitor setups
      (LP: #984080)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 09:32:40 +0200

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers