No icon in launcher entry, after installing software

Bug #980640 reported by RobinJ on 2012-04-13
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Albert Astals Cid
unity-2d (Ubuntu)
Undecided
Albert Astals Cid
Precise
Medium
Bartosz Kosiorek

Bug Description

Test case:
1. Install any application with a custom icon using the Software Center on Unity 2D
   -> The application should be added to the Launcher with its respective icon visible (not a ? question mark)

===

Ubuntu 12.04 Beta 2 AMD64, running Unity 2D
--

When I install an application using the software center, the entry automatically gets added to the Unity 2D Launcher. Only the icon in the launcher entry only displays a question mark, which I'm guessing means that it doesn't know which icon it should display. If I click the icon, the correct application opens. If I open the dash, and open the application from there, the application opens, and yet another entry gets added to the launcher for the running application, even though it was already pinned to the launcher. This suggests that the launcher doesn't recognise it as being the same application. Note that for the application instance I opened using the dash, the correct icon is displayed.

Video of what happens: http://youtu.be/euGHLk2oxDE

--
Sidenote: Also, note that when I clicked the install button in the software center, the policykit dialog didn't get focus. A bit annoying, but not a large concern. A bug nonetheless.

Related branches

Gary Lasker (gary-lasker) wrote :

Hi RobinJ, and thank you for this bug. This has been a late-landing feature in Ubuntu, and also in Unity 2D, so it seems there are still some kinks to be worked out. I believe the fix for this will actually be needed in Unity 2D itself, so I have updated the target package accordingly.

To the Unity 2D folks, If I can do anything to help, please let me know! Also, Bilal Ahktar is the implementer of this feature in Unity 3D, and I'm sure he would be happy to help out as needed as well.

Thanks very much!
Gary

affects: software-center (Ubuntu) → unity-2d (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu):
assignee: nobody → Albert Astals Cid (aacid)
Changed in unity-2d (Ubuntu):
status: In Progress → Fix Committed
Changed in unity-2d:
status: New → Fix Committed
milestone: none → 5.12
assignee: nobody → Albert Astals Cid (aacid)
Changed in unity-2d:
importance: Undecided → Medium
RobinJ (robinj) wrote :

The status has been "Fix committed" for a while now... but when is it going to be *released*?

description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
status: Fix Committed → Fix Released

Hello RobinJ, or anyone else affected,

Accepted unity-2d into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-2d (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Bartosz Kosiorek (gang65) wrote :

After install new unity-2d, no more question mark.

Changed in unity-2d (Ubuntu Precise):
importance: Undecided → Medium
assignee: nobody → Bartosz Kosiorek (gang65)
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.12.0-0ubuntu1

---------------
unity-2d (5.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in ref() (LP: #968046)
    - [hud] First entry always activated with keyboard navigation
      (LP: #980899)
    - unity-2d-shell crashes on autoscrolling on launcher tile removal
      (LP: #988239)
    - unity-2d-shell crashes when using with a NX server (LP: #983942)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - [spread] When multiple windows of an app are open, clicking on one
      doesn't bring it to the foreground (LP: #917334)
    - [HUD][multi-monitor] HUD should be expanded to the left if used on a
      screen without launcher (LP: #979927)
    - unity-2d scope un-url-escapes values from its model (LP: #986175)
    - [places] tab key does nothing (LP: #891565)
    - HUD is silent to screen readers (LP: #949445)
    - launcher background coloring does not get reset when using enter to
      activate/start a program (LP: #965079)
    - [multi-monitor] [launcher] Drag & drop application to launcher on
      primary screen, other launchers not updated (LP: #966239)
    - HUD gets activated by Thinkpad USB Keyboard's back and forward buttons
      (LP: #968840)
    - Unity 2D doesn't load 24 bit icons (LP: #977262)
    - Four finger tap does not open the Dash (LP: #978659)
    - No icon in launcher entry, after installing software (LP: #980640)
    - Menu items displayed incorrectly when window streched over multiples
      monitors (LP: #987215)
    - [unity-2d-panel] The close button (potentially the others too) can
      toggled even when they are not visible anymore (LP: #924264)
    - When closing the Dash with the [x] panel button the last windows is not
      focused and doesn't allow to use window controls. (LP: #945459)
    - [launcher] item hint flickers when hovering between launcher edge and
      item (LP: #948383)
    - Missaligned progress bar (LP: #980609)
    - Launcher tile tooltip appears in wrong screen in RTL multimonitor setups
      (LP: #984080)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 09:32:40 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers