Ubuntu

[HUD][multi-monitor] HUD should be expanded to the left if used on a screen without launcher

Reported by Péter Trombitás on 2012-04-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
High
Albert Astals Cid
unity-2d (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Test case:
1. Ensure you have a multi-monitor environment with launcher on only one screen
2. Start an application on the screen where there is no launcher
3. Start the HUD (tap Alt)
   -> The HUD should not leave any place for the launcher on the screen, just occupy all free space to its left

==

Maybe this affects unity as well, but I can't test it.
HUD leaves the launcher's space free, even if there's no launcher on that screen. I think it should display an icon there.
My unity-2d version is 5.8.0, I know that there's 5.10 coming out, though it's not in the ppa or something.
Sorry for not reporting this issue with apport, but it didn't let me do so because it says that I shouldn't use any third-party repos (I use unity-tema/ppa, ubuntu-desktop/ppa and unity-team/lenses-testing).

Gerry Boland (gerboland) on 2012-04-12
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Albert Astals Cid (aacid)
milestone: none → 5.12
Gerry Boland (gerboland) on 2012-04-12
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
status: Fix Committed → Fix Released

Hello Péter, or anyone else affected,

Accepted unity-2d into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-2d (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed

It works for me in unity-2d. Thanks for the fix.

2012. április 27. 15:20 Martin Pitt írta, <email address hidden>:

> Hello Péter, or anyone else affected,
>
> Accepted unity-2d into precise-proposed. The package will build now and
> be available in a few hours. Please test and give feedback here. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you in advance!
>
> ** Changed in: unity-2d (Ubuntu Precise)
> Status: New => Fix Committed
>
> ** Tags added: verification-needed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/979927
>
> Title:
> [HUD][multi-monitor] HUD should be expanded to the left if used on a
> screen without launcher
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity-2d/+bug/979927/+subscriptions
>

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.12.0-0ubuntu1

---------------
unity-2d (5.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in ref() (LP: #968046)
    - [hud] First entry always activated with keyboard navigation
      (LP: #980899)
    - unity-2d-shell crashes on autoscrolling on launcher tile removal
      (LP: #988239)
    - unity-2d-shell crashes when using with a NX server (LP: #983942)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - [spread] When multiple windows of an app are open, clicking on one
      doesn't bring it to the foreground (LP: #917334)
    - [HUD][multi-monitor] HUD should be expanded to the left if used on a
      screen without launcher (LP: #979927)
    - unity-2d scope un-url-escapes values from its model (LP: #986175)
    - [places] tab key does nothing (LP: #891565)
    - HUD is silent to screen readers (LP: #949445)
    - launcher background coloring does not get reset when using enter to
      activate/start a program (LP: #965079)
    - [multi-monitor] [launcher] Drag & drop application to launcher on
      primary screen, other launchers not updated (LP: #966239)
    - HUD gets activated by Thinkpad USB Keyboard's back and forward buttons
      (LP: #968840)
    - Unity 2D doesn't load 24 bit icons (LP: #977262)
    - Four finger tap does not open the Dash (LP: #978659)
    - No icon in launcher entry, after installing software (LP: #980640)
    - Menu items displayed incorrectly when window streched over multiples
      monitors (LP: #987215)
    - [unity-2d-panel] The close button (potentially the others too) can
      toggled even when they are not visible anymore (LP: #924264)
    - When closing the Dash with the [x] panel button the last windows is not
      focused and doesn't allow to use window controls. (LP: #945459)
    - [launcher] item hint flickers when hovering between launcher edge and
      item (LP: #948383)
    - Missaligned progress bar (LP: #980609)
    - Launcher tile tooltip appears in wrong screen in RTL multimonitor setups
      (LP: #984080)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 09:32:40 +0200

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers