Ubuntu

unity-2d-shell crashed with SIGSEGV in ref()

Reported by Tuomas Heino on 2012-03-29
178
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Qt bindings for libbamf
Critical
Pawel Stolowski
unity-2d
Critical
Pawel Stolowski
libqtbamf (Ubuntu)
Critical
Unassigned
Precise
Critical
Bartosz Kosiorek
unity-2d (Ubuntu)
Critical
Unassigned
Precise
Critical
Bartosz Kosiorek

Bug Description

1. install libqtbamf from precise-proposed
2. make sure unity-2d does not crash on using HUD

Closed firefox with alt-alt-f q (repeated alt), thus leaving the HUD visible without an application to send the commands to.

-_-

Possibly unrelated to this, when submitting this bug report, also got an "Unable to start web browser" window popping up although browser was started just fine; message was:

Unable to start web browser to open https://bugs.launchpad.net/ubuntu/+source/unity-2d/+filebug/ef8f9132-7974-11e1-b761-68b5996a96c8?field.title=unity-2d-shell+crashed+with+SIGSEGV+in+QDBusError%3A%3Amessage%28%29.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-2d-shell 5.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Thu Mar 29 10:55:46 2012
ExecutablePath: /usr/bin/unity-2d-shell
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120112)
ProcCmdline: unity-2d-shell
ProcEnviron:
 LANGUAGE=en_IE:en
 LANG=en_IE.UTF-8
 SHELL=/bin/bash
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-2d
Title: unity-2d-shell crashed with SIGSEGV in QDBusError::message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

Tuomas Heino (iheino+ub) wrote :
description: updated

This crash has the same stack trace characteristics as bug #947278. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 ref (this=0x0) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:121
 QString (other=..., this=0x7fff7d2911e0) at ../../include/QtCore/../../src/corelib/tools/qstring.h:726
 QDBusError::message (this=0x2977e30) at qdbuserror.cpp:336
 createError (err=...) at ../../include/QtDBus/../../src/dbus/qdbusmessage.h:81
 QDBusPendingCall::fromError (error=...) at qdbuspendingcall.cpp:446

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
summary: - unity-2d-shell crashed with SIGSEGV in QDBusError::message()
+ unity-2d-shell crashed with SIGSEGV in ref()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) on 2012-03-30
visibility: private → public
Gerry Boland (gerboland) on 2012-04-12
Changed in unity-2d:
milestone: none → 5.12
importance: Undecided → Critical
Changed in unity-2d:
assignee: nobody → Pawel Stolowski (stolowski)
Pawel Stolowski (stolowski) wrote :

Steps to reproduce:
1. Open Firefox, but don't make it fullscreen, so that window close button will not be covered by Hud.
2. Hit Alt (opens Hud).
3. Close Firefox window with mouse (Hud remains open).
4. Start typing search query in the Hud (should crash).

Problem caused by BamfView::Closed() signal not being delivered to WindowInfo::onWindowClosed(). I nailed it down to BamfFactory::OnViewClosed(), which just deletes sender object.

Changed in bamf-qt:
assignee: nobody → Pawel Stolowski (stolowski)
status: New → In Progress
importance: Undecided → Critical
Changed in bamf-qt:
status: In Progress → Fix Committed
Gerry Boland (gerboland) on 2012-04-16
Changed in unity-2d:
status: New → Fix Committed
Omer Akram (om26er) on 2012-04-26
affects: unity-2d (Ubuntu) → libqtbamf (Ubuntu)
Changed in libqtbamf (Ubuntu):
importance: Medium → Critical
description: updated
affects: unity-2d → unity
Changed in unity:
milestone: 5.12 → none
milestone: none → 5.12.0
Gerry Boland (gerboland) on 2012-04-26
affects: unity → unity-2d
Changed in unity-2d:
milestone: 5.12.0 → none
milestone: none → 5.12

Hello Tuomas, or anyone else affected,

Accepted libqtbamf into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libqtbamf (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Hello Tuomas, or anyone else affected,

Accepted unity-2d into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-2d (Ubuntu Precise):
status: New → Fix Committed
Tuomas Heino (iheino+ub) wrote :

libqtbamf1 0.2.4-0ubuntu1 fix works for me.

unity-2d-shell 5.12.0-0ubuntu1 has a Depends: ... libqtbamf1 (>= 0.1) though, as does unity-2d-panel; libunity-2d-private0 5.12.0-0ubuntu1 has a slightly more recent dependancy [libqtbamf1 (>= 0.2.1)], but shouldn't that be updated to >= 0.2.4 in whichever packages claim to fix this bug?

P.S. https://wiki.ubuntu.com/Testing/EnableProposed should also be updated for Precise.

tags: added: verification-done
tags: removed: verification-needed
Changed in unity-2d (Ubuntu):
importance: Undecided → Critical
Changed in unity-2d (Ubuntu Precise):
importance: Undecided → Critical
assignee: nobody → Bartosz Kosiorek (gang65)
Changed in libqtbamf (Ubuntu Precise):
assignee: nobody → Bartosz Kosiorek (gang65)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libqtbamf - 0.2.4-0ubuntu1

---------------
libqtbamf (0.2.4-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in ref() (LP: #968046)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 08:37:04 +0200

Changed in libqtbamf (Ubuntu):
status: Confirmed → Fix Released
Changed in libqtbamf (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.12.0-0ubuntu1

---------------
unity-2d (5.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in ref() (LP: #968046)
    - [hud] First entry always activated with keyboard navigation
      (LP: #980899)
    - unity-2d-shell crashes on autoscrolling on launcher tile removal
      (LP: #988239)
    - unity-2d-shell crashes when using with a NX server (LP: #983942)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - [spread] When multiple windows of an app are open, clicking on one
      doesn't bring it to the foreground (LP: #917334)
    - [HUD][multi-monitor] HUD should be expanded to the left if used on a
      screen without launcher (LP: #979927)
    - unity-2d scope un-url-escapes values from its model (LP: #986175)
    - [places] tab key does nothing (LP: #891565)
    - HUD is silent to screen readers (LP: #949445)
    - launcher background coloring does not get reset when using enter to
      activate/start a program (LP: #965079)
    - [multi-monitor] [launcher] Drag & drop application to launcher on
      primary screen, other launchers not updated (LP: #966239)
    - HUD gets activated by Thinkpad USB Keyboard's back and forward buttons
      (LP: #968840)
    - Unity 2D doesn't load 24 bit icons (LP: #977262)
    - Four finger tap does not open the Dash (LP: #978659)
    - No icon in launcher entry, after installing software (LP: #980640)
    - Menu items displayed incorrectly when window streched over multiples
      monitors (LP: #987215)
    - [unity-2d-panel] The close button (potentially the others too) can
      toggled even when they are not visible anymore (LP: #924264)
    - When closing the Dash with the [x] panel button the last windows is not
      focused and doesn't allow to use window controls. (LP: #945459)
    - [launcher] item hint flickers when hovering between launcher edge and
      item (LP: #948383)
    - Missaligned progress bar (LP: #980609)
    - Launcher tile tooltip appears in wrong screen in RTL multimonitor setups
      (LP: #984080)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 09:32:40 +0200

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.