unity-2d-panel crashed with SIGABRT in Unity2dDebug::unity2dQtHandler()

Bug #925457 reported by Guy Stone on 2012-02-02
48
This bug affects 6 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Didier Roche
unity-2d (Ubuntu)
Critical
Unassigned

Bug Description

logging in - only background showing after login box closes

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-2d-panel 5.2.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Thu Feb 2 08:05:17 2012
ExecutablePath: /usr/bin/unity-2d-panel
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111125)
ProcCmdline: unity-2d-panel
Signal: 6
SourcePackage: unity-2d
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /usr/lib/libunity-2d-private.so.0
 qt_message_output(QtMsgType, char const*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
 ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
Title: unity-2d-panel crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Guy Stone (stoneguy3) wrote :
visibility: private → public

StacktraceTop:
 Unity2dDebug::unity2dQtHandler (type=QtFatalMsg, message=0x8552290 "Settings schema 'com.canonical.Unity2d.Panel' is not installed\n") at /build/buildd/unity-2d-5.2.0/libunity-2d-private/src/unity2ddebug.cpp:89
 qt_message_output (msgType=QtFatalMsg, buf=0x8552290 "Settings schema 'com.canonical.Unity2d.Panel' is not installed\n") at global/qglobal.cpp:2203
 qt_message (msgType=QtFatalMsg, msg=0x62c200 "Settings schema '%s' is not installed\n", ap=0xbfc0e954 "\310 U\b\004") at global/qglobal.cpp:2322
 qFatal (msg=0x62c200 "Settings schema '%s' is not installed\n") at global/qglobal.cpp:2505
 QConfSchema::QConfSchema(QString const&) () from /tmp/tmpZsQNam/usr/lib/libdconf-qt.so.0

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
summary: - unity-2d-panel crashed with SIGABRT in raise()
+ unity-2d-panel crashed with SIGABRT in Unity2dDebug::unity2dQtHandler()
tags: removed: need-i386-retrace
Gerry Boland (gerboland) on 2012-02-02
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
Changed in unity-2d:
importance: Undecided → Critical
Guy Stone (stoneguy3) wrote :

Adding lightdm logs - perhaps useful?

Guy Stone (stoneguy3) wrote :

For whatever it's worth, I should point out that this installation has been continuously upgraded from an Alpha1 iso. I did another install beginning from an Alpha2 iso, and it doesn't show this problem.

If there are no additional instances being reported, I'd be quite happy to abandon this report.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) on 2012-03-07
Changed in unity-2d:
milestone: none → 5.8
Changed in unity-2d:
assignee: nobody → Pawel Stolowski (stolowski)
Didier Roche (didrocks) on 2012-03-08
Changed in unity-2d:
assignee: Pawel Stolowski (stolowski) → Didier Roche (didrocks)
Changed in unity-2d:
status: New → Fix Committed
Jan Pleva (jenik-pleva) wrote :

Looks that there is some dependency problem in package or something. After manual reinstallation by:

sudo apt-get purge unity-2d*

sudo apt-get install unity-2d-common unity-2d-shell unity-2d unity-services unity-2d-spread unity-2d-places unity-2d-panel unity-2d-launcher

it start to work properly. There were one package updated also. Maybe apt-get upgrade needed before?

Didier Roche (didrocks) on 2012-03-15
Changed in unity-2d:
milestone: 5.8 → 5.7
Didier Roche (didrocks) on 2012-03-19
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.7.0-0ubuntu1

---------------
unity-2d (5.7.0-0ubuntu1) precise; urgency=low

  * New upstream release:
    - unity-2d-panel crashed with SIGABRT in Unity2dDebug::unity2dQtHandler()
      (LP: #925457)
    - unity-2d-shell crashed with SIGSEGV in ref() (LP: #947278)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - [dash] [launcher] [panel] Tinting based on wallpaper missing
      (LP: #882101)
    - [launcher] In multimonitor setup Unity-2D only shows launcher on one
      monitor (fails MM UX spec #2.8) (LP: #780204)
    - [unity-2d] FF exception to add PointerBarrier to Unity2d (LP: #947976)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - lens switching is not keyboard navigable (LP: #945220)
    - [panel] [multi-monitor] On secondary screen, unable to scrub from
      indicator menu to app menu (LP: #844809)
    - "Workspaces" button displays previous wallpaper (LP: #900019)
    - Dash - cursor should change when pointer is over the search field
      (LP: #849175)
    - Filter checkboxes are without margins in right to left locales
      (LP: #949319)
    - [panel] [multi-monitor] Open indicator menu on one screen causes other
      indicator to look open too (LP: #844798)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - [launcher] Tile Progress bar starting from left of launcher, not
      container (LP: #912777)
    - Dash - dash is not closed with alt+f4 (LP: #891818)
    - [dash] Rating stars in right-to-left locales behave inconsistently.
      (LP: #945719)
    - LensButton.qml:72 warning when running unity-2d (LP: #947276)
    - [dash] Multi-range filters are rendered incorrectly in right-to-left
      locales (LP: #950649)
  * debian/unity-2d.gconf-defaults:
    - removed: not used anymore and causing regression with hide-mode=2
      by default, converted to the gsettings key (LP: #942772)
  * debian/unity-2d.preinst:
    - removed, was a natty -> oneiric transition
  * debian/control, debian/unity-2d-common.install:
    - create unity-2d-common and make some packages depending on it
    - move some files from unity-2d package to unity-2d-common
      (gsettings and apport hook) to have packaging shipping their schema
      (LP: #925457)
  * debian/unity-2d-common.install.in:
    - no more gconf -> gsettings migration shipped
  * debian/unity-2d.postinst, prerm, trigger:
    - moved to unity-2d-common new package, to ensure even people uninstalling
      unity-2d got the right metacity configuration in the session
    - update the trigger to the correct directory
  * debian/control:
    - bump to latest Standards-Version
    - fix some too long description
    - put the transitional packages in the oldlibs/extra section
    - build-dep on libxtst-dev, libxfixes-dev for barrier change
    - need latest metacity for barriers to work
 -- Didier Roche <email address hidden> Mon, 19 Mar 2012 14:07:10 +0100

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers