Useless scroll arrows in Unity 2D global menus

Bug #913237 reported by Ibrahim M. Ghazal on 2012-01-07
110
This bug affects 24 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Gerry Boland
unity-2d (Ubuntu)
High
Canonical Desktop Experience Team
Precise
High
Canonical Desktop Experience Team

Bug Description

Most menus seem to have superfluous scroll arrows on their top and bottom, even if there is plenty of space to show the menu without scrolling. See the attached screenshot for one example. Also, when I "scroll" to the top, the arrows disappear.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 4.24.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-8.14-virtual 3.2.0
Uname: Linux 3.2.0-8-virtual i686
.tmp.unity.support.test.1:

ApportVersion: 1.90-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Sat Jan 7 22:08:26 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 vboxguest, 4.1.8, 3.2.0-8-virtual, i686: installed
 virtualbox-guest, 4.1.6, 3.2.0-8-generic-pae, i686: installed (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)
 virtualbox-guest, 4.1.6, 3.2.0-8-virtual, i686: installed (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120105)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
MachineType: innotek GmbH VirtualBox
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-8-virtual root=UUID=d350ec6e-9316-48d5-93fa-38da98a965b9 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu8
version.libdrm2: libdrm2 2.4.29-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1

Related branches

Ibrahim M. Ghazal (imgx64) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) wrote :

This bug appears to only show up in unity-2d. At least, I can't get it to happen with unity-3d.

affects: unity (Ubuntu) → unity-2d (Ubuntu)
Gerry Boland (gerboland) on 2012-01-09
Changed in unity-2d (Ubuntu):
importance: Undecided → High
Gerry Boland (gerboland) on 2012-01-10
Changed in unity-2d:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Gerry Boland (gerboland)
Changed in unity-2d (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: qa-manual-testing rls-mgr-p-tracking
Gerry Boland (gerboland) on 2012-01-18
Changed in unity-2d:
milestone: none → 5.2.1
Gerry Boland (gerboland) on 2012-02-09
Changed in unity-2d:
status: Confirmed → In Progress
milestone: 5.2.1 → 5.4
David Barth (dbarth) on 2012-02-10
Changed in unity-2d (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
Changed in unity-2d:
importance: High → Critical
Changed in unity-2d:
status: In Progress → Fix Committed
Paul Sladen (sladen) on 2012-02-14
summary: - Useless scroll arrows in menus
+ Useless scroll arrows in Unity 2D global menus
Didier Roche (didrocks) on 2012-02-17
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.4.0-0ubuntu1

---------------
unity-2d (5.4.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - unity-2d-launcher crashed with SIGABRT in qt_message_output()
      (LP: #854634)
    - Useless scroll arrows in Unity 2D global menus (LP: #913237)
    - [workspace switcher] Does not activate since bzr revision 900
      (LP: #928398)
    - On unity 2d when using Hebrew localization launcher won't load if you
      move cursor all the way to the right (LP: #877292)
    - panel 2D uses wrong width on multi monitor setup (LP: #880698)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - [dash] User can move dash around with ALT+LeftClick+Move (LP: #827838)
    - [launcher] UI does not distinguish between windows on this workspace and
      others (LP: #883172)
    - Panel and launcher are blank and non-functional when /usr is a symlink
      (LP: #757288)
    - Launcher - change to 'locked out' by default (LP: #928153)
  * debian/control:
    - Build-dep on latest nux (ABI break)
  * debian/*install, debian/control:
    - transition unity-2d-launcher and unity-2d-places to unity-2d-shell
    - breaks against older gnome-session (as components links changed)
 -- Didier Roche <email address hidden> Fri, 17 Feb 2012 14:21:45 +0100

Changed in unity-2d (Ubuntu Precise):
status: Confirmed → Fix Released
David Leal (dgleal) wrote :

Either I'm doing something wrong or this bug is back. I'm using an up-to-date installation of Precise, and I see the exact same problem described here. I'm using XMonad instead of Metacity, though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers