unity-2d-panel crashed with SIGSEGV in unity::indicator::DBusIndicators::Impl::RequestSyncAll()

Bug #864737 reported by Peter Rhone on 2011-10-02
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Jean-Baptiste Lallement
Oneiric
High
Unassigned
Precise
High
Unassigned
Unity
Fix Released
Critical
Marco Trevisan (Treviño)
unity-2d
Undecided
Marco Trevisan (Treviño)
unity (Ubuntu)
Critical
Marco Trevisan (Treviño)
Nominated for Oneiric by James M. Leddy
unity-2d (Ubuntu)
Critical
Marco Trevisan (Treviño)
Nominated for Oneiric by James M. Leddy

Bug Description

== Oneiric SRU Justification ==

When this hits, it kills the Unity2D session, which can cause not just an annoyance but confusion from new users. Segfaulting is a pretty serious quality problem and can affect a new user's impression of Ubuntu.

== Fix ==
https://code.launchpad.net/~3v1n0/unity/dbus-indicators-proxy

== Impact ==

Anyone using Unity2D, their desktop will crash from time to time. This has a big impact for us on OEM projects, since Unity2D is widely used in liu of qualtiy OpenGL graphics drivers.

== Test Case ==

I just activated a second screen with a different resolution (1280x720, versus 1440x900) via the nvidia-settings tool when the error showed up.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-panel 4.12.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Sun Oct 2 18:52:03 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/unity-2d-panel
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007.1)
ProcCmdline: unity-2d-panel
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f2ad5a13905 <_ZN5unity9indicator14DBusIndicators4Impl14RequestSyncAllEv+117>: mov %rax,0x8(%rsi)
 PC (0x7f2ad5a13905) ok
 source "%rax" ok
 destination "0x8(%rsi)" (0x42442e706f746b7b) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: unity-2d
StacktraceTop:
 unity::indicator::DBusIndicators::Impl::RequestSyncAll() () from /usr/lib/libunity-core-4.0.so.4
 unity::indicator::DBusIndicators::Impl::OnRemoteProxyReady(_GDBusProxy*) () from /usr/lib/libunity-core-4.0.so.4
 ?? () from /usr/lib/libunity-core-4.0.so.4
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
Title: unity-2d-panel crashed with SIGSEGV in unity::indicator::DBusIndicators::Impl::RequestSyncAll()
UpgradeStatus: Upgraded to oneiric on 2011-08-19 (44 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors: (vino-server:3758): EggSMClient-CRITICAL **: egg_sm_client_set_mode: assertion `global_client == NULL || global_client_mode == EGG_SM_CLIENT_MODE_DISABLED' failed

Related branches

Peter Rhone (prhone-gmail) wrote :

StacktraceTop:
 shared_count (r=<optimized out>, this=<optimized out>) at /usr/include/boost/smart_ptr/detail/shared_count.hpp:223
 shared_ptr<unity::indicator::{anonymous}::SyncData> (this=0x42442e706f746b73, r=...) at /usr/include/boost/smart_ptr/shared_ptr.hpp:238
 construct (__val=..., __p=0x42442e706f746b73, this=<optimized out>) at /usr/include/c++/4.6/ext/new_allocator.h:108
 push_back (__x=..., this=0x253db58) at /usr/include/c++/4.6/bits/stl_vector.h:830
 unity::indicator::DBusIndicators::Impl::RequestSyncAll (this=0x253db40) at /build/buildd/unity-4.20.0/UnityCore/DBusIndicators.cpp:200

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
visibility: private → public
Cyrus Lien (cyruslien) on 2011-12-13
Changed in oem-priority:
importance: Undecided → Critical
Changed in oem-priority:
assignee: nobody → Jean-Baptiste Lallement (jibel)
Cyrus Lien (cyruslien) wrote :

In my case it was happened when I press hot key to switch video output very quickly.

James M. Leddy (jm-leddy) wrote :

Hi Jean-Baptiste, is there ay update here?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
tags: added: maverick
Steve Magoun (smagoun) on 2012-02-10
tags: added: beitou
Cyrus Lien (cyruslien) wrote :

Please help to review the patch and check any side effects. Thanks!

Gerry Boland (gerboland) wrote :

This is a bug with Unity-Core, so adding the Unity project.

Cyrus: thanks for the patch! A Unity team member should get to it soon.

Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid

The attachment "10_fixcrash_workaround.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in unity:
assignee: nobody → James M. Leddy (jm-leddy)
assignee: James M. Leddy (jm-leddy) → nobody
Changed in unity (Ubuntu):
assignee: nobody → David Barth (dbarth)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in oem-priority:
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Critical
tags: added: rls-mgr-p-tracking
Gerry Boland (gerboland) on 2012-03-05
Changed in unity-2d:
status: New → Invalid
David Barth (dbarth) on 2012-03-09
Changed in unity:
milestone: none → 5.8.0
importance: Undecided → Critical
status: New → Confirmed
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.04-beta-2
assignee: David Barth (dbarth) → nobody
Didier Roche (didrocks) on 2012-03-14
Changed in unity-2d:
milestone: none → 5.8
milestone: 5.8 → none
tags: added: rls-p-tracking

This should be fixed with branch: lp:~3v1n0/unity/dbus-indicators-proxy
Please check it again.

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
David Barth (dbarth) on 2012-03-21
tags: added: hitlist
Changed in oem-priority:
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity-2d (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Invalid → Fix Released
James M. Leddy (jm-leddy) wrote :

Marking fixed released to reflect the status in Unity.

Changed in oem-priority:
status: Fix Committed → Fix Released
status: Fix Released → In Progress
James M. Leddy (jm-leddy) wrote :

Just noticed this is also present in 11.10. Will discuss if we need SRU in the next meeting.

description: updated
description: updated
James M. Leddy (jm-leddy) wrote :

Hi Ubuntu-SRU,

I'd like to target this bug to a Oneiric SRU. Please accept nomination and backport the patch for an SRU.

tags: added: rls-mgr-o-tracking
James M. Leddy (jm-leddy) wrote :

Hi Marco,

Can we take a newer version of Unity like 5.8 that has the dbus-indicator-proxy patch? Or should we just include the patch that Cyrus wrote?

tags: added: rls-q-incoming
removed: rls-mgr-p-tracking
tags: removed: rls-q-incoming
tags: removed: rls-p-tracking
Changed in oem-priority:
importance: Critical → High
description: updated
Changed in oem-priority:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers