unity-2d-launcher crashed with SIGSEGV in QObject::thread()

Bug #855353 reported by Shadow Panther on 2011-09-21
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Unassigned
unity-2d (Ubuntu)
Critical
Unassigned

Bug Description

Random crash. Not immediately after system start.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-launcher 4.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Wed Sep 21 12:34:12 2011
ExecutablePath: /usr/bin/unity-2d-launcher
ProcCmdline: unity-2d-launcher
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f53cbc34b68 <_ZNK7QObject6threadEv+8>: mov 0x8(%rax),%rax
 PC (0x7f53cbc34b68) ok
 source "0x8(%rax)" (0x7065526f4e2e7277) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity-2d
StacktraceTop:
 QObject::thread() const () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 QObject::QObject(QObjectPrivate&, QObject*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 QDBusServiceWatcher::QDBusServiceWatcher(QObject*) () from /usr/lib/x86_64-linux-gnu/libQtDBus.so.4
 LauncherApplication::setDynamicQuicklistImporter(QString const&) () from /usr/lib/libunity-2d-private.so.0
 LauncherApplication::updateOverlaysState(QString const&, QMap<QString, QVariant>) () from /usr/lib/libunity-2d-private.so.0
Title: unity-2d-launcher crashed with SIGSEGV in QObject::thread()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Shadow Panther (panther-ru) wrote :

StacktraceTop:
 QObject::thread (this=0x2c8c500) at kernel/qobject.cpp:1393
 QObject::QObject (this=0x2652ba0, dd=..., parent=0x2c8c500) at kernel/qobject.cpp:773
 QDBusServiceWatcher::QDBusServiceWatcher (this=0x2652ba0, parent=0x2c8c500) at qdbusservicewatcher.cpp:253
 LauncherApplication::setDynamicQuicklistImporter (this=0x2c8c500, service=...) at /build/buildd/unity-2d-4.8.0/libunity-2d-private/src/launcherapplication.cpp:1038
 LauncherApplication::updateOverlaysState (this=0x2c8c500, sender=..., properties=<optimized out>) at /build/buildd/unity-2d-4.8.0/libunity-2d-private/src/launcherapplication.cpp:1025

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Critical
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
madbiologist (me-again) wrote :

Official support for Ubuntu 11.04 "Natty Narwhal" has ended. If this error is still occurring on Ubuntu 14.10 "Utopic Unicorn" please run ubuntu-bug to file a new bug report so that we can get a fresh set of log files and system information.

Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
madbiologist (me-again) wrote :

Oops. This bug was reported against Ubuntu 11.10 "Oneiric Ocelot". Official support for that version has also ended.

Changed in unity-2d:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers