unity-2d-launcher crashed with SIGABRT in qt_message_output()

Bug #854634 reported by Roman Yepishev on 2011-09-20
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Albert Astals Cid
unity-2d (Ubuntu)
Critical
Unassigned

Bug Description

This happened during (unrelated) package building. At some point unity2d launcher stopped responding and crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-launcher 4.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Tue Sep 20 14:17:32 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/unity-2d-launcher
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: unity-2d-launcher
Signal: 6
SourcePackage: unity-2d
StacktraceTop:
 ?? () from /usr/lib/libunity-2d-private.so.0
 qt_message_output(QtMsgType, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 qFatal(char const*, ...) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 LauncherApplication::windowCountOnCurrentWorkspace() () from /usr/lib/libunity-2d-private.so.0
Title: unity-2d-launcher crashed with SIGABRT in qt_message_output()
UpgradeStatus: Upgraded to oneiric on 2011-08-30 (20 days ago)
UserGroups: adm admin audio cdrom dialout libvirtd lpadmin mythtv plugdev sambashare www-data

Related branches

Roman Yepishev (rye) wrote :

StacktraceTop:
 Unity2dDebug::unity2dQtHandler (type=QtFatalMsg, message=0x16da038 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 456") at /build/buildd/unity-2d-4.8.0/libunity-2d-private/src/unity2ddebug.cpp:89
 qt_message_output (msgType=QtFatalMsg, buf=0x16da038 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 456") at global/qglobal.cpp:2240
 qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7f9b31a09a28 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=0x7ffff2024148) at global/qglobal.cpp:2361
 qFatal (msg=<optimized out>) at global/qglobal.cpp:2544
 at (this=0x16a51a0, i=1) at /usr/include/qt4/QtCore/qlist.h:456

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
Changed in unity-2d:
importance: Undecided → Critical
Florian Boucault (fboucault) wrote :

Interesting clue found in the stack trace:

#3 0x00007f9b318ba34e in qt_message_output (msgType=QtFatalMsg, buf=0x16da038 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 456") at global/qglobal.cpp:2240

Changed in unity-2d:
assignee: nobody → Albert Astals Cid (aacid)
Changed in unity-2d:
status: New → In Progress
Albert Astals Cid (aacid) wrote :

Fix commited in r838

Changed in unity-2d:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
milestone: none → 5.4
Didier Roche (didrocks) on 2012-02-17
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.4.0-0ubuntu1

---------------
unity-2d (5.4.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - unity-2d-launcher crashed with SIGABRT in qt_message_output()
      (LP: #854634)
    - Useless scroll arrows in Unity 2D global menus (LP: #913237)
    - [workspace switcher] Does not activate since bzr revision 900
      (LP: #928398)
    - On unity 2d when using Hebrew localization launcher won't load if you
      move cursor all the way to the right (LP: #877292)
    - panel 2D uses wrong width on multi monitor setup (LP: #880698)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - [dash] User can move dash around with ALT+LeftClick+Move (LP: #827838)
    - [launcher] UI does not distinguish between windows on this workspace and
      others (LP: #883172)
    - Panel and launcher are blank and non-functional when /usr is a symlink
      (LP: #757288)
    - Launcher - change to 'locked out' by default (LP: #928153)
  * debian/control:
    - Build-dep on latest nux (ABI break)
  * debian/*install, debian/control:
    - transition unity-2d-launcher and unity-2d-places to unity-2d-shell
    - breaks against older gnome-session (as components links changed)
 -- Didier Roche <email address hidden> Fri, 17 Feb 2012 14:21:45 +0100

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers