unity-2d-panel assert failure: *** glibc detected *** unity-2d-panel: corrupted double-linked list: 0x094bc9b0 ***

Bug #852012 reported by Dmitry Shachnev on 2011-09-16
228
This bug affects 27 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Alberto Mardegan
unity-2d (Ubuntu)
Critical
Alberto Mardegan
Oneiric
Critical
Alberto Mardegan

Bug Description

Unity 2D Panel crashed on login.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-panel 4.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
AssertionMessage: *** glibc detected *** unity-2d-panel: corrupted double-linked list: 0x094bc9b0 ***
CrashCounter: 1
Date: Thu Sep 15 21:31:01 2011
ExecutablePath: /usr/bin/unity-2d-panel
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
ProcCmdline: unity-2d-panel
ProcEnviron:
 LANGUAGE=ru:en
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 LC_MESSAGES=ru_RU.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: unity-2d
StacktraceTop:
 __libc_message (do_abort=2, fmt=0x344080 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0x94bc9b0) at malloc.c:6283
 malloc_consolidate (av=0x380400) at malloc.c:5161
 malloc_consolidate (av=0x380400) at malloc.c:5089
 _int_free (av=0x380400, p=0x9561638) at malloc.c:5034
Title: unity-2d-panel assert failure: *** glibc detected *** unity-2d-panel: corrupted double-linked list: 0x094bc9b0 ***
UpgradeStatus: Upgraded to oneiric on 2011-09-02 (14 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev nopasswdlogin plugdev sambashare tape video
XsessionErrors: (chromium-browser:2037): GdkPixbuf-CRITICAL **: gdk_pixbuf_new_from_data: assertion `width > 0' failed

Dmitry Shachnev (mitya57) wrote :
visibility: private → public

StacktraceTop:
 __libc_message (do_abort=2, fmt=0x344080 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0x94bc9b0) at malloc.c:6283
 malloc_consolidate (av=0x380400) at malloc.c:5161
 malloc_consolidate (av=0x380400) at malloc.c:5089
 _int_free (av=0x380400, p=0x9561638) at malloc.c:5034

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Changed in unity-2d:
importance: Undecided → Critical
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
milestone: none → 4.10
Florian Boucault (fboucault) wrote :

I believe that commit 727 of lp:unity-2d that fixed bug #850320 might fix this one as well.

Changed in unity-2d:
milestone: 4.10 → 4.12
Changed in unity-2d (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
milestone: none → ubuntu-11.10
tags: added: iso-testing
Changed in unity-2d (Ubuntu Oneiric):
status: Confirmed → Triaged
tags: added: rls-mgr-o-tracking
David Barth (dbarth) on 2011-09-23
Changed in unity-2d:
assignee: nobody → Alberto Mardegan (mardy)
Changed in unity-2d (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) wrote :

The latest duplicates with this bug were reported on unity-2d 4.8. So, Florian is probably correct in saying that the fix for bug 850320 (which was released with 4.10) fixed this as well.

Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity-2d (Ubuntu Oneiric):
status: Triaged → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.