bad memory leak in unity-2d-panel

Bug #850320 reported by Scott Moser on 2011-09-14
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Michał Sawicz
unity-2d (Ubuntu)
Critical
Unassigned
Oneiric
Critical
Unassigned

Bug Description

I came in this morning and found unity-2d-panel with (per top) 1.2G of memory resident.

I killed the process, and let it get restarted. Just now (<8 hours later) it was up to 1.1G.

I killed that process, did a 'quit' on 'system-load-indicator' which i thought might be related, and let it start again.

In just 15 minutes, It has moved from 32M (or around there) to 75M resident.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d-panel 4.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Wed Sep 14 15:38:48 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
SourcePackage: unity-2d
UpgradeStatus: Upgraded to oneiric on 2010-11-15 (302 days ago)

Related branches

Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :

It seems that simply switching back and forth in desktops causes leaks.
I have keybindings to switch desktops, but even using default 'ctrl-alt-arrowkey' going to one desktop and back to another will cause megabytes of leak.

Hernando Torque (htorque) wrote :

Confirming, I'm seeing a raise every time I switch between windows.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Critical
status: New → Confirmed
milestone: none → 4.8
Hernando Torque (htorque) wrote :

Here's a valgrind log of unity-2d-panel when switching between windows a lot of times.

Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Michał Sawicz (saviq) on 2011-09-16
Changed in unity-2d:
assignee: nobody → Michał Sawicz (saviq)
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Hernando Torque (htorque) wrote :

The "bad" part of this leak is definitely fixed now, but there still seems to be a leak when starting applications. I'm attaching a screenshot showing the mem usage of unity-2d-panel over time.

I started applications at various times (indicated by larger jumps), memory is freed when switching between windows, but not when closing the applications (at the end of the plot there's only a gnome-terminal running).

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity-2d (Ubuntu Oneiric):
importance: Undecided → Critical
milestone: none → ubuntu-11.10
tags: added: rls-mgr-o-tracking
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers