unity-2d-panel crashed with SIGSEGV in IndicatorsWidget::onEntryRemoved()

Bug #846836 reported by Bob on 2011-09-11
208
This bug affects 36 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Florian Boucault
unity-2d (Ubuntu)
Critical
Florian Boucault
Oneiric
Critical
Florian Boucault

Bug Description

started update manager and got error and this bug report request window
running Ubuntu 10.10 n)installed gnome (shell? desktop? manager?)
but 2 days ago text garbled (after gnome log0 and program windows slanty and distorted
until i resized them

launcher in gnome also sporadic but i installed Docky (in unity-2d) which works in gnome

I checked the 1 unselected box to receive ALL updates
(I'm a beta junkie and must have it now, heaven help me!)

regular unity was working fine until i installed gnome now only unity-2d works fine
(but i haven't tested in a couple of days, before updates)

Compaq CQ laptop

and off-topic but dual-booting Win7 and ubuntu (installed with wubi) for a long time
wiped ubuntu by 'mistake' could not install Mintlinux nor ubuntu 11.04 both froze same place text on screen
9RIP or RTP and download refernce - even when I did not select download updates on install)
- only the ubuntu 11.10 beta cd would install for me

Thank you

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-panel 4.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Sat Sep 10 20:49:23 2011
ExecutablePath: /usr/bin/unity-2d-panel
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcCmdline: unity-2d-panel
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f283bdc6823 <_ZN16IndicatorsWidget14onEntryRemovedERKSs+131>: mov (%rdx),%rsi
 PC (0x7f283bdc6823) ok
 source "(%rdx)" (0x1dcfa8de8) not located in a known VMA region (needed readable region)!
 destination "%rsi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity-2d
StacktraceTop:
 IndicatorsWidget::onEntryRemoved(std::string const&) () from /usr/lib/libunity-2d-private.so.0
 unity::indicator::Indicator::~Indicator() () from /usr/lib/libunity-core-4.0.so.4
 boost::detail::sp_counted_impl_p<unity::indicator::Indicator>::dispose() () from /usr/lib/libunity-core-4.0.so.4
 QList<boost::shared_ptr<unity::indicator::Indicator> >::~QList() () from /usr/lib/libunity-2d-private.so.0
 IndicatorsWidget::~IndicatorsWidget() () from /usr/lib/libunity-2d-private.so.0
Title: unity-2d-panel crashed with SIGSEGV in IndicatorsWidget::onEntryRemoved()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Bob (bgold2007) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #845773, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-amd64-retrace
Changed in unity-2d:
milestone: none → 4.8
importance: Undecided → Critical
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
assignee: nobody → Florian Boucault (fboucault)
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.8.0-0ubuntu1

---------------
unity-2d (4.8.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - [window management] Alt tab does not switch to the desired application
      but instead set the urgency flag on the window (LP: #735205)
    - [dash] search field default text not cleared immediately when using
      chinese input method (LP: #745246)
    - [dash] Apps lens shows no result by default (LP: #834571)
    - unity-2d-panel crashed with SIGSEGV in
      IndicatorsWidget::onEntryRemoved() (LP: #846836)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Repeated indicators in unity-2d panel when second screen added
      (LP: #846441)
    - [dash] Lens navigation bar (buttons on lower edge of dash window) is
      accessible (LP: #826560)
    - [dash] Category filters is sorted according to their english names, even
      when another language is used (LP: #838023)
 -- Didier Roche <email address hidden> Thu, 15 Sep 2011 11:43:52 +0200

Changed in unity-2d (Ubuntu):
status: In Progress → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

reopening. it still happens in 4.8.0-0ubuntu1

Changed in unity-2d (Ubuntu):
status: Fix Released → Triaged
importance: Undecided → Critical
milestone: none → ubuntu-11.10
status: Triaged → In Progress
Changed in unity-2d (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: rls-mgr-o-tracking
David Barth (dbarth) on 2011-09-23
Changed in unity-2d (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Florian Boucault (fboucault)
Changed in unity-2d (Ubuntu Oneiric):
status: In Progress → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers