alt+f2 - can type, doing nothing

Bug #842413 reported by Michael Krištof on 2011-09-06
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Alberto Mardegan
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

When I press alt+f2 and want to launch application, I can type but it does something really rarely. Maybe only when started for the first time after login, I'm not sure.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d-places 4.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
Date: Tue Sep 6 09:45:16 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/unity-2d-places
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
SourcePackage: unity-2d
UpgradeStatus: Upgraded to oneiric on 2011-09-05 (0 days ago)

Related branches

Michael Krištof (gramblavec) wrote :
Michael Krištof (gramblavec) wrote :

OK it doesn't have anything to do with login, it just works suddenly from time to time.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Chris Gagnon (chris.gagnon) wrote :

I've seen this too, I've noticed if I first click on the empty background (in the area where the icons show up after a successful search) and type in the program I want to open it's not displayed.

Steps to reproduce:

1. press alt+f2
2. Click on the empty background (in the area where the icons show up after a successful search) 3. type in the program I want to open

Expected results:
Program typed in is displayed

Actual results
Nothing is displayed.

Additional info:
If I click on one of the bottom icons, then I can select the program, but only if I select the correct filter.

On the next search (after pressing escape and alt+f2 again) my typed in program will show up without clicking on one of the icons at the bottom. But this only works if one of the bottom icons were clicked previously

Changed in unity-2d:
importance: Undecided → Medium
milestone: none → 4.8
status: New → Confirmed
Changed in unity-2d:
assignee: nobody → Alberto Mardegan (mardy)
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Alberto Mardegan (mardy) on 2011-09-16
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
Scott Moser (smoser) wrote :

for what its worth, I still see this in my unity-2d on precise (and did on oneiric also).
This is a fresh install from maybe 3 weeks ago. current unity-2d is
$ dpkg-query --show unity-2d
unity-2d 4.12.0-0ubuntu1

It seems that once it *starts* working after login i'm good, but getting it to work the first time requires some random clicking around and re-trying.

Shall I open another bug on this? It is very reproducible for me on login.

Gerry Boland (gerboland) wrote :

Hi Scott,
can you please give me a step-by-step of what is wrong? If I understand correctly:

1. Press Alt+F2
2. You get Dash up with "Run a command" text entry box
3. You enter the part or all of an application name, e.g. "gcalct" for "gcaoctool"
4. You press enter
5. gcalctool should appear.

What happens for you? What goes wrong?

Please reopen this bug if you disagree that the fix is committed. If the bug seems different, please open a new one.

Scott Moser (smoser) wrote :

Gerry,
  I just updated and upgraded my precise system. I also then verified that this same behavior occurs as a new 'demo' user that i created, *and* as the system 'Guest' login, as long as you remember to choose 'Ubuntu 2d'.
  To reproduce:
  1. login as newly created user, my existing 'smoser', or the system 'guest' user with Ubuntu 2d as the session type.
  2. wait till crickets are done chirping
  3. press alt-f2
  4. type 'gcalc' . At this point hitting enter does nothing. I am unable to launch a program.
  5. hit 'PrintScreen' and save the screenshot as 'guest login first-alt-f2 press'
  6. press alt-f2. The run dialog generally seems usable now.
  7. type 'gcalc', the attached screenshot in 'guest login alt-f2 after screenshot' is what I see.

Prior to this excercise I didn't have anything that reproducibly "fixed" the problem. Multiple alt-f2, then 'escape' sequences would still result in the issue, eventually some combination of use of the desktop would make it start working again. It seems hitting PrintScreen fixes it reliably.

  I just login, wait till crickets are done, then hit 'alt-f2'.

Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :

I've raised my issues reported in comment as new bug 903279.

Gerry Boland (gerboland) wrote :

Thanks Scott, but this bug already exists (bug 883392) and has a fix ready for review in the merge queue.

The fix should appear in soon.
-Gerry

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers