Ubuntu

[dash] Apps lens shows no result by default

Reported by Moisa Doru on 2011-08-26
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Music Lens
Medium
Neil J. Patel
Unity
High
Neil J. Patel
libunity
Critical
Neil J. Patel
unity-2d
Critical
Florian Boucault
unity-lens-applications
Undecided
Neil J. Patel
unity-lens-files
Undecided
Neil J. Patel
libunity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
High
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned
unity-lens-files (Ubuntu)
Undecided
Unassigned
unity-lens-music (Ubuntu)
Undecided
Unassigned

Bug Description

Click on Dash home, then click on "Media Apps", "Internet Apps" or "More Apps". The apps list is not getting populated (see the attached screenshot).

Unity-2d version: 4.2.0

~$ sudo apt-cache policy unity-2d
unity-2d:
  Installed: 4.2.0-0ubuntu1
  Candidate: 4.2.0-0ubuntu1
  Version table:
 *** 4.2.0-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

Moisa Doru (moisadoru) wrote :
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Critical
summary: - Apps list is not populated
+ [dash] Apps lens shows no result by default
Changed in unity-2d:
milestone: none → 4.4
status: New → Confirmed
Florian Boucault (fboucault) wrote :

The bug is actually in the lenses themselves.

Unity has a hack to workaround the issue (introduced by bzr revision 1405.1.5):

In plugins/unityshell/src/LensView.cpp:

  Categories::Ptr categories = lens_->categories;
  if (category.index + 1 == categories->count())
  {
    lens_->Search("---");
    lens_->Search("");
  }

Changed in unity-2d:
assignee: nobody → Florian Boucault (fboucault)
tags: added: iso-testing
Florian Boucault (fboucault) wrote :

IRC quote: "< njpatel> Kaleo, hey, yes, this used to be an issue with third party lenses too. The code you reference is actually not the useful bit, I didn't realise I left it in so have removed it from trunk. The useful part is LensView::OnActiveChanged and, in the same file, lens_->connected.changed.connect.... between those two, the LensView handles starts and restarts of lenses correctly"

Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Florian Boucault (fboucault) wrote :

In the applications lens, line 100 of utils.vala in the applications lens considers that the old_search (null) is the same as the new_search (""). The same code is duplicated in the files lens.

But the bug also occurs with the music lens and the gwibber lens.
The probable extra cause is that a Scope has a default LensSearch active_search attribute whose search_string is "" by default
hence when getting to line 229 of unity-scope-private.vala the new "" search is discarded.

Changed in libunity:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Neil J. Patel (njpatel)
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Neil J. Patel (njpatel) on 2011-09-05
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
milestone: none → 4.14.0
status: New → Triaged
Neil J. Patel (njpatel) wrote :

I've linked branches for the lenses. I think Gwibber is not displaying initial results for different reasons, will investigate separately.

I do not think anything needs to be fixed in libunity, unity-lens-search makes the initial search_string = NULL from my tests, so I think the main issue was with the daemons ignoring the null search (they were all doing this apart from Gwibber). In my tests (with the workarounds in Unity removed), they all display results initially, so I hope this fixes the issue for 2D too.

Changed in unity:
status: Triaged → In Progress
Changed in libunity:
status: Confirmed → Invalid
Changed in unity-lens-applications:
status: New → In Progress
Changed in unity-lens-music:
status: New → In Progress
Changed in unity-lens-files:
status: New → In Progress
Changed in unity-lens-music:
milestone: none → 0.1.4
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
status: In Progress → Fix Committed
Changed in unity-lens-applications:
milestone: none → 0.4.4
Changed in unity-lens-files:
milestone: none → 0.6.4
Changed in unity-2d (Ubuntu):
importance: Undecided → High
Neil J. Patel (njpatel) on 2011-09-08
Changed in unity:
status: In Progress → Fix Committed
Changed in unity-lens-files:
status: In Progress → Fix Committed
Changed in unity-lens-applications:
status: In Progress → Fix Committed
assignee: nobody → Neil J. Patel (njpatel)
Changed in unity-lens-files:
assignee: nobody → Neil J. Patel (njpatel)
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in libunity:
status: Invalid → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 4.0.2-0ubuntu1

---------------
libunity (4.0.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - [dash] Apps lens shows no result by default (LP: #834571)
    - Quicklist can't be correctly hidden (LP: #843425)
    - Python PyGI support broken (LP: #844779)
  * debian/control,
    debian/libunity5.symbols => debian/libunity6.symbols,
    debian/libunity5.install => debian/libunity6.install:
    - makes the necessary tweak for ABI/API breakage
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 17:01:04 +0200

Changed in libunity (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.6.1-0ubuntu1

---------------
unity-2d (4.6.1-0ubuntu1) oneiric; urgency=low

  * Fix a segfault due to new unity service backend change.

unity-2d (4.6.0-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release
    - [dash] Apps lens shows no result by default (LP: #834571)
    - Metacity needs command line options to activate capture before unmap and
      compositing without effects (LP: #791205)
    - Bold fonts everywhere in the UI (dash, launcher, workspace switcher) but
      in the panel (LP: #808849)
    - the migration script needs to be run in unity-2d as well (LP: #819733)
    - [dash] "View photos" in the dash launches default image viewer instead
      of shotwell (LP: #822605)
    - Launcher tooltips sometimes leave holes in panel and windows
      (LP: #837277)
    - [dash] Search with non ascii characters fails (LP: #840010)
    - add a configuration key (dconf) to enable the opengl backend
      (LP: #809202)
    - [launcher] when pressing super key shortcuts numbering start at 2
      instead of 1 (LP: #830036)
    - [UIFe] Unity 2D should be using the same BFB icon as Unity (LP: #838829)
    - [launcher] trash icon needs to be the same as in Unity 3D (LP: #840025)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - [dash] DropShadow on "See X more results" can cause visual errors on
      scroll (LP: #843820)
    - Dash - In the App lens filters, users should only be able filter by
      'star' rating in one star increments (LP: #839759)
    - Emptying the trash from the unity sidebar should respect nautilus' "Ask
      before emptying" setting (LP: #730003)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
  * debian/control:
    - rebuild against current nux and unity (API change)
 -- Didier Roche <email address hidden> Fri, 09 Sep 2011 13:50:22 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Michael Krištof (gramblavec) wrote :

I've just installed updates, rebooted PC, but I still have the problem. My application menu is totally empty.

Changed in unity-2d:
status: Fix Released → In Progress
milestone: 4.6 → 4.8
Changed in unity-2d:
status: In Progress → Fix Committed
Dan Halbert (dhalbert) wrote :

Re #8: I had the same problem (still empty after update), but somehow managed to get the lenses to populate by searching for "", then hitting return. I cannot remember the exact sequence, but magically it all populated. Perhaps it was actually generating the list in the background while I was fiddling.

I can confirm that the lenses do populate as described in comment #9 by entering "" in the search, waiting a second and then deleting the "". However, the list is only available during the present session. Logging out and then back in shows nothing in the lenses once again and must be repopulated.

Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: Fix Committed → Fix Released
Changed in unity-lens-files:
status: Fix Committed → Fix Released
Changed in unity-lens-music:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-09-15
Changed in unity-lens-applications (Ubuntu):
status: New → Fix Released
Changed in unity-lens-files (Ubuntu):
status: New → Fix Released
Changed in unity-lens-music (Ubuntu):
status: New → Fix Released
Lain_13 (lain-halfbit) wrote :

Hi, I have Unity-2D v4.12 installed in Oneiric and experience similar problem. In default mode app-lens shows no results. If I chose it from list below — it works. But results disappears as soon as I switch back to default or just re-open dash.

#9 and #10 doesn't work for me.

Vadim Peretokin (vperetokin) wrote :

Using 4.24.0-0ubuntu2, I very frequently have all of my Apps lesnes completely blanked out, including no buttons. This even happend to me right away on a restart. Is this related?

Sebastian Schlegel (schlegel) wrote :

I got the same (or a similar?) error with Unity and Unity2D (two different laptops). From dash, I cannot start any apps but the four favorites. If I search for them I only get files and music as results. Even Alt+F2 doesn't work.

I purged and reinstalled unity, the lenses, places and zeitgeist several times to solve the problem. After the reinstalls, dash sometimes worked fine for some ubuntu-restarts, but the error came back every time. Gnome shell doesn't have that error. Both systems was upgraded from natty.

Sebastian Schlegel (schlegel) wrote :

It seems that a "unity --replace" solves the problem for me, but I have to do that every time I start ubuntu. Annoying!

Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
Fabio (fabio-sassi) wrote :

Same Problem with 11.10 - 4.12.0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers