[dash] User can move dash around with ALT+LeftClick+Move

Bug #827838 reported by Jean-Baptiste Lallement on 2011-08-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Tested on Unity 2d

TEST CASE
1. Press SUPER to open the dash
2. Move the mouse over it and press ALT + Hold the left mouse button
3. Keep the key and button pressed and move the mouse

Result:
The dash is moved.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d 4.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
Architecture: i386
Date: Wed Aug 17 09:34:34 2011
EcryptfsInUse: Yes
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: Upgraded to oneiric on 2011-07-12 (35 days ago)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Medium
summary: - User can move dash around with ALT+LeftClick+Move
+ [dash] User can move dash around with ALT+LeftClick+Move
tags: added: testcase
Gerry Boland (gerboland) on 2011-11-19
Changed in unity-2d:
milestone: none → 5.2
Gerry Boland (gerboland) on 2011-11-29
Changed in unity-2d:
milestone: 5.2 → none
Changed in unity-2d:
milestone: none → 5.4
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-02-17
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.4.0-0ubuntu1

---------------
unity-2d (5.4.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - unity-2d-launcher crashed with SIGABRT in qt_message_output()
      (LP: #854634)
    - Useless scroll arrows in Unity 2D global menus (LP: #913237)
    - [workspace switcher] Does not activate since bzr revision 900
      (LP: #928398)
    - On unity 2d when using Hebrew localization launcher won't load if you
      move cursor all the way to the right (LP: #877292)
    - panel 2D uses wrong width on multi monitor setup (LP: #880698)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - [dash] User can move dash around with ALT+LeftClick+Move (LP: #827838)
    - [launcher] UI does not distinguish between windows on this workspace and
      others (LP: #883172)
    - Panel and launcher are blank and non-functional when /usr is a symlink
      (LP: #757288)
    - Launcher - change to 'locked out' by default (LP: #928153)
  * debian/control:
    - Build-dep on latest nux (ABI break)
  * debian/*install, debian/control:
    - transition unity-2d-launcher and unity-2d-places to unity-2d-shell
    - breaks against older gnome-session (as components links changed)
 -- Didier Roche <email address hidden> Fri, 17 Feb 2012 14:21:45 +0100

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers