gnome-shell writes to ~/.gconf/apps/metacity/general & affects Workspaces shown in unity-2d

Bug #826089 reported by Doug McMahon on 2011-08-14
110
This bug affects 23 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Invalid
High
unity-2d
High
Unassigned
gnome-shell (Ubuntu)
Medium
Unassigned
metacity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

I mainly use unity (3d) but have noticed that at some point when trying unity-2d I can only see/access 1 workspace from "Workspaces"
It turns out that if one logs into gnome-shell, when exiting it writes to - ~/.gconf/apps/metacity/general
Typically it would do this, but the value used is based on workspaces open in GS when exiting
<entry name="num_workspaces" mtime="1313702896" type="int" value="1"/>

In the above case when logging into unity-2d only 1 workspace will be shown

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d 4.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat Aug 13 22:32:01 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110731)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

Using a fresh install w/ 06/15 daily -
Workspaces works fine by default, all 4 ws's shown. The gconf dir. tree as mentioned above is in place by default.
All is well until gnome-shell is installed and logged into once, then logging back into unity-2d and only 1 ws is now shown.

The only thing done in gnome-shell was to enable the 'run command' key binding - Alt+F2
Removing GS has no effect
As before removing the empty %gconf.xml in ~/.gconf/apps/metacity then allows the 4 ws's to be seen

summary: Having an empty %gconf.xml in ~/.gconf/apps/metacity will cause only 1
- workspace to be shown in "Workspaces"
+ workspace to be shown in "Workspaces" if gnome-shell has been installed
+ & logged into

Cleaned up bug title

summary: - Having an empty %gconf.xml in ~/.gconf/apps/metacity will cause only 1
- workspace to be shown in "Workspaces" if gnome-shell has been installed
- & logged into
+ If gnome-shell has been installed & logged into then only 1 workspace
+ will be shown in Workspaces
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) on 2011-08-18
summary: - If gnome-shell has been installed & logged into then only 1 workspace
- will be shown in Workspaces
+ gnome-shell writes to ~/.gconf/apps/metacity/general & affects
+ Workspaces shown in unity-2d
description: updated
Doug McMahon (mc3man) wrote :

Finally decided to set up a new user and see what was up. Have adjusted title and descrip. to reflect

This is caused by unity-2d using the value for "num_workspaces" in ~/.gconf/apps/metacity/general which is dynamically set by gnome-shell when exited

Florian Boucault (fboucault) wrote :

Thanks for the detailed analysis Doug!
So, we will have as many workspaces as GNOME Shell setup basically?
Historically I think we setup the code so that we would have as many workspaces as a GNOME 2 use would have.

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Doug McMahon (mc3man) wrote :

I don't know unity-2d that well, just started using but -
It appears that 2d defaults to 4 ws's and doesn't need/create that gconf key but will use it if it happens to be there

On the other hand Gs creates the key and sets the value based on active ws's when logging out, but does not actually use the key/value when logging back in
Ex. if one logs out of Gs with 3 active ws's then the value is set to 3. When logging back into GS only the default 1 ws is available.
Meanwhile 2d will show 3
So the fault seems to lie with Gs for writing a value to a key it doesn't appear to actually use.

Changed in metacity (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Added gnome-shell, remove if invalid. But if gnome-shell would stop writing to this key then there will be no issue.
 Might also affect the gnome-fallback session the same way it affects unity-2d

dino99 (9d9) wrote :

I always log as gnome-classic (no effects) and need to load metacity (metacity --replace &) via a launcher to get:
- movable/resizable windows
- more than 1 workplace

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Reported to GNOME Shell upstream.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in gnome-shell:
importance: Unknown → High
status: Unknown → New
Changed in unity-2d:
importance: Medium → High
Doug McMahon (mc3man) wrote :

It doesn't appear Gnome is going to fix this anytime soon which may be too bad for some unity-2d users
The key is currently a simple way to adjust the number of Ws's unity-2d will use, intended or otherwise

Note on gnome bug report - Gs set the num value to however many workspaces are open in Gs when exiting, typically 1, but not limited to that by any means

I can confirm this is still an issue on Precise Alpha 1. The workaround is to first log into a GNOME Shell session, have 4 workspaces open in the workspace switcher, then log out and select Ubuntu 2D from the LightDM session menu. (Of course, if fewer workspaces are desired, you can also open fewer workspaces in GNOME Shell using this method. I don't know what would happen if 5 or more workspaces were opened since I didn't try that yet.)

Changed in gnome-shell:
status: New → Invalid
Doug McMahon (mc3man) wrote :
komputes (komputes) on 2012-03-20
tags: added: css-sponsored-p
komputes (komputes) on 2012-03-20
tags: added: rls-mgr-p-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.3.92-0ubuntu1

---------------
gnome-shell (3.3.92-0ubuntu1) precise; urgency=low

  * New upstream release.
    - No longer affects the number of workspaces in Unity 2D (LP: #826089)
  * debian/control.in: Bump minimum mutter to 3.3.92

  [ Rico Tzschichholz ]
  * debian/patches/20_revert_gcr_depend.patch:
    - Revert dependency on gcr 3.3 since we're sticking with 3.2 for 12.04
 -- Jeremy Bicha <email address hidden> Thu, 22 Mar 2012 01:47:24 -0400

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) on 2012-03-22
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
Changed in metacity (Ubuntu):
status: Confirmed → Invalid
John D. Nash (promotions) wrote :

Confirmed in LTS 12.04 with "Classic" Gnome. Even if I use (right click / preferences) to set the workspace swticher to 8 workspaces in 2 rows, then next time I log in it is back to 2x2 grid with 1 workspace.

Need to set it every time I log in. Since Unity came out there has been a drive to make it more cell phone like -- harder to use to get work done. There is a cute little workspace switcher in Unity, but switching workspaces requires three clicks each time and it can only accommodate 4 workspaces -- very suboptimal compared with clicking once on the Gnome panel workspace swticher.

I haven't figured out where to set the default values for the Gnome workspace switcher in compiz, and the following code (which was offered in a forum) does not solve the problem either.

gconftool --type Integer --set /apps/compiz-1/general/screen0/options/vsize 8
gconftool --type Integer --set /apps/compiz-1/general/screen0/options/hsize 8

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.