[dash] "View photos" in the dash launches default image viewer instead of shotwell

Bug #822605 reported by SebastienManen on 2011-08-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Invalid
Medium
unity-2d
High
Alberto Mardegan
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

When going in the dash by clicking the logo ubuntu in the top left corner and then clicking on "View photos" (between firefox and thunderbird icons) gwibber is launched instead of Shotwell.
If you need anything feel free to ask !

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d 3.8.14.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
Date: Mon Aug 8 12:32:57 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110717)
PackageArchitecture: all
SourcePackage: unity-2d
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

summary: - "View photos" in the dash launch gwibber instead of shotwell
+ [dash] "View photos" in the dash launches gwibber instead of shotwell
Changed in unity-2d:
importance: Undecided → High
milestone: none → 4.2
Florian Boucault (fboucault) wrote :

There is in fact no way for the user to choose a default 'photo management application' therefore no settings Unity could read it from. I believe we have no choice at this time but to hardcode shotwell.

summary: - [dash] "View photos" in the dash launches gwibber instead of shotwell
+ [dash] "View photos" in the dash launches default image viewer instead
+ of shotwell
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Alberto Mardegan (mardy) on 2011-08-25
Changed in unity-2d:
assignee: nobody → Alberto Mardegan (mardy)
Changed in unity-2d:
milestone: 4.2 → 4.4
Alberto Mardegan (mardy) on 2011-08-26
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Alberto Mardegan (mardy) wrote :

I gave it some of my deepest thoughts ;-), and the more I think of this, the more I dislike the hardcoding - and not only because I'm a happy user of f-spot myself. :-)

There is a way to specify preferred applications: go to the system settings -> system information (I'm translating from Italian, I'm not sure if the labels are like this in English) -> preferred applications

There I can set "shotwell" as my preferred photo viewer and everything works consequently. So I believe there is no bug here.
It's undeniable that the "preferred apps" it's very hard to find, but that's an issue which should be addressed by the system settings application, IMO.

Florian, I'm closing this bug as invalid for unity-2d and to mark it as affecting the system settings (opinion).

Changed in unity-2d:
status: In Progress → Invalid
Changed in unity-2d (Ubuntu):
status: In Progress → Invalid
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Invalid

Thank you Alberto for your help. I've tried to do what you suggest and it effectively correct the "bug". The question now is why gwibber is defined as the default photo browser ?
Anyway that shouldn't be hard to correct this ! :)

Florian Boucault (fboucault) wrote :

The explanation that is not always simple to remember is the following:
- the photo viewer preferred application set in GNOME control center is used right now both by nautilus to open images and by Unity 2D's dash to take the user to his/her photos (launching his/her photo management app)
- shotwell photo viewer automatically imports images that it opens into the user's photo collection therefore it cannot be set as preferred photo viewer application in GNOME control center; instead Eye of GNOME is set.

Re-opening.

Changed in unity-2d:
status: Invalid → Confirmed
Changed in unity-2d (Ubuntu):
status: Invalid → Confirmed
Changed in unity-2d:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.6.1-0ubuntu1

---------------
unity-2d (4.6.1-0ubuntu1) oneiric; urgency=low

  * Fix a segfault due to new unity service backend change.

unity-2d (4.6.0-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release
    - [dash] Apps lens shows no result by default (LP: #834571)
    - Metacity needs command line options to activate capture before unmap and
      compositing without effects (LP: #791205)
    - Bold fonts everywhere in the UI (dash, launcher, workspace switcher) but
      in the panel (LP: #808849)
    - the migration script needs to be run in unity-2d as well (LP: #819733)
    - [dash] "View photos" in the dash launches default image viewer instead
      of shotwell (LP: #822605)
    - Launcher tooltips sometimes leave holes in panel and windows
      (LP: #837277)
    - [dash] Search with non ascii characters fails (LP: #840010)
    - add a configuration key (dconf) to enable the opengl backend
      (LP: #809202)
    - [launcher] when pressing super key shortcuts numbering start at 2
      instead of 1 (LP: #830036)
    - [UIFe] Unity 2D should be using the same BFB icon as Unity (LP: #838829)
    - [launcher] trash icon needs to be the same as in Unity 3D (LP: #840025)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - [dash] DropShadow on "See X more results" can cause visual errors on
      scroll (LP: #843820)
    - Dash - In the App lens filters, users should only be able filter by
      'star' rating in one star increments (LP: #839759)
    - Emptying the trash from the unity sidebar should respect nautilus' "Ask
      before emptying" setting (LP: #730003)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
  * debian/control:
    - rebuild against current nux and unity (API change)
 -- Didier Roche <email address hidden> Fri, 09 Sep 2011 13:50:22 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.