Oneiric (live cd only): Alt+F2 sometimes not working in Unity 2D

Bug #821919 reported by Jan Rathmann on 2011-08-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Unassigned
unity-2d (Ubuntu)
Medium
Canonical Desktop Experience Team

Bug Description

Hello,

the keyboard shortcut Alt+F2, used to enter and run a command/program, is sometimes not working for me in Unity 2D.

When booting into the live CD session, I never saw Alt+F2 working (this report is therefor sent from within a live session), neither did it work on my Virtual Box installation so far. In this case just nothing happens when I press the key combo.

When I installed Oneiric two days ago, at some moment Alt+F2 suddendly started working as exspected! I wondered if it could be related to installing the propritary Nvidia-driver, but after removing the Nvidia driver it continued working.

Below I have attached the output from the xev-command when seeing the problem (means no reaction to Alt+F2), according to https://wiki.ubuntu.com/Hotkeys/Troubleshooting. However, it looks like pressing the keys is detected correctly by xev (correct me if I'm wrong).

Kind regards,
Jan

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d 3.8.14.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
CasperVersion: 1.275
Date: Sat Aug 6 12:21:04 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: No upgrade log present (probably fresh install)
---
Architecture: i386
CasperVersion: 1.280
DistroRelease: Ubuntu 11.10
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110831)
Package: unity-2d 4.2.0-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Tags: oneiric unity-2d
Uname: Linux 3.0.0-9-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Jan Rathmann (kaiserclaudius) wrote :
Jan Rathmann (kaiserclaudius) wrote :
Jan Rathmann (kaiserclaudius) wrote :
Jan Rathmann (kaiserclaudius) wrote :
Jan Rathmann (kaiserclaudius) wrote :
Jan Rathmann (kaiserclaudius) wrote :
tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Assigning to DX team for review.

Changed in unity-2d (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
assignee: Canonical Desktop Experience Team (canonical-dx-team) → nobody
importance: Undecided → Medium
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Alberto Mardegan (mardy) wrote :

I'm also running Oneiric in VirtualBox, and it works here. Jan, did you manage to reproduce it after upgrading to Oneiric?

Florian Boucault (fboucault) wrote :

Thanks for the report Jan!
Additionally to Alberto's question: the xev output you are showing are great. When capturing with xev does Alt-F2 brings up the dash as expected as well?

Changed in unity-2d:
status: New → Incomplete
importance: Undecided → Medium
Changed in unity-2d (Ubuntu):
status: New → Incomplete
Jan Rathmann (kaiserclaudius) wrote :

@Alberto
My VirtualBox Oneiric installation is an upgrade from Natty (and many previous Ubuntu versions), so yes, this happened after upgrading to Oneric.
However, when I tested it again yesterday (as usual with all upgrades), Alt+F2 suddenly began to work, at least on this installation. But I can still reproduce the not working Alt+F2 on a live session, with daily live image from today.
Happens both with AMD64 and i386 live cds, so this doesn't seem to be architecture dependent.

@Florian
No, it did not bring up the dash. The capturing was done when Alt+F2 didn't work (otherwise it would be quite uninteresting I think ;-) ).

I'm happy to do further testing/helping debugging.

Kind regards,
Jan

Florian Boucault (fboucault) wrote :

Thanks for the feedback Jan. It looks like the issue has been fixed in trunk and with the release pushed on Thursday evening, Friday morning (not part of the daily live image of the 12th I believe). If everybody believes that we should then close the bug.

Changed in unity-2d:
status: Incomplete → New
Changed in unity-2d (Ubuntu):
status: Incomplete → New
Jan Rathmann (kaiserclaudius) wrote :

Florian,

I tested again with todays image, unfortunately still nothing happens at Alt+F2.
Maybe later I'll get around to do another installation and try to reproduce the condition when it _starts_ working.

Jan Rathmann (kaiserclaudius) wrote :

As announced, I installed Oneiric once again, with interesting results.
While Alt+F2 didn't work during the live session, as described before, it worked imediately on the fresh installed system!
So this problem is visible for me only during live session with Unity 2D at the moment. Not sure what is special about a live session compared to a session of an installed system that makes this bug appear.

summary: - Oneiric: Alt+F2 sometimes not working in Unity 2D
+ Oneiric (live cd only): Alt+F2 sometimes not working in Unity 2D
Jan Rathmann (kaiserclaudius) wrote :

Just an update from Beta testing, the problem still persists.
It even regressed, this time it was exactly as when I reportet this bug. Alt+F2 didn't work during live session, and worked neither the first time when I used the fresh installed system, a reboot after first login didn't help. And again, somehow Alt+F2 started working after installing the Nvidia driver.
Very strange....

Florian Boucault (fboucault) wrote :

@Jan: are you using an external, maybe USB, keyboard? do you have the num-lock activated?

Jan Rathmann (kaiserclaudius) wrote :

@Florian
My keyboard is a common cheap model by Logitech connected via PS/2 (Logitech Deluxe 250 Keyboard).
Since I experience no other keyboard issues (and I use especially Alt+F2 quite often), I can't imagine at the moment that my keyboard may be the guilty one here.
I'm gonna try the following:
- Plug another keyboard into my PC to test.
- Try the live CD on other PCs at hand to see if I can reproduce the bug there.

Jan Rathmann (kaiserclaudius) wrote :

Plugging in another keyboard (USB connected) didn't help.

Florian Boucault (fboucault) wrote :

@Jan: I was not implying your keyboard was at fault but rather I remember we had bugs related to using external keyboards with num-lock activated.

Jan Rathmann (kaiserclaudius) wrote :

Sorry, I had read over the num-lock question.
When I boot into a live session, num-lock is disabled by default and I have to turn it on manually by pressing the NUM key. But this has no visible effect on the behaviour of the problematic key combo, Alt+F2 doesn't work when num-lock is disabled initially, neither does it work if I enable num-lock.

Changed in unity-2d (Ubuntu):
status: New → Triaged

apport information

tags: added: apport-collected
description: updated
Jan Rathmann (kaiserclaudius) wrote :

This evening I could do testing on two other machines.

The first one was my sister's laptop, with a Pentium DualCore CPU and Intel Graphics, one and a half year old.
On this machine Alt+F2 worked instantly! But unlike on my own PC, due to free Intel driver this machine loaded the compiz-based Unity by default, I had to select the Unity-2D session manually from LightDM.

The second PC is a very old (2001) desktop, from which I am writing this message.
This one behaves like my own PC, booting into a live session showed that Alt+F2 didn't work (it also loads Unity-2D by default).
So I got two machines so far where I can reproduce the bug.
I tried to attach apport-collected information from this machine, but apport-collect was not that useful in this case. So I'll attach the output of 'lspci -vvvxxxx' manually.

Kind regards,
Jan

Chris Gagnon (chris.gagnon) wrote :

I've seen this too, I've noticed if I first click on the empty background (in the area where the icons show up after a successful search) and type in the program I want to open it's not displayed.

Steps to reproduce:

1. press alt+f2
2. Click on the empty background (in the area where the icons show up after a successful search) 3. type in the program I want to open

Expected results:
Program typed in is displayed

Actual results
Nothing is displayed.

Additional info:
If I click on one of the bottom icons, then I can select the program, but only if I select the correct filter.

On the next search (after pressing escape and alt+f2 again) my typed in program will show up without clicking on one of the icons at the bottom. But this only works if one of the bottom icons were clicked previously

Jan Rathmann (kaiserclaudius) wrote :

@Chris
Your description sounds that you are describing a different bug. If I got you right, the prompt "window" where you enter the command to execute does at least appear for you when you press Alt-F2. The problem, that I'm reporting here is that nothing at all happens when I press Alt+F2.
So I suggest it might be a good idea if you open a separate bug report about your problem.

Chris Gagnon (chris.gagnon) wrote :

@jan,

You are right, it's a different bug...

I found another bug report and added my comment there. :)

Changed in unity-2d:
milestone: none → 4.8
Changed in unity-2d:
assignee: nobody → Alberto Mardegan (mardy)
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Changed in unity-2d:
status: New → Confirmed
assignee: Alberto Mardegan (mardy) → nobody
milestone: 4.10 → none
Jan Rathmann (kaiserclaudius) wrote :

I just started and installed today's image and couldn't reproduce the problem any more :-)

Florian Boucault (fboucault) wrote :

Superb Jan! Thank you for your great feedback. I believe it was fixed by the recent Alt+F2 related fixes that were merged on Friday.

Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity-2d (Ubuntu):
status: Triaged → Fix Released

On my laptop, Alt-F2 doesn't work with external USB keyboard if Num Lock is on.

Works if Alt is pressed on laptop's built-in keyboard (regardless if F2 is pressed on built-in or external keyboard).

If Num Lock is off, Alt-F2 works on both keyboards (as well as both cross-keyboard combinations where I press Alt on one keyboard and F2 on another).

Linux wish 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Michał Sawicz (saviq) wrote :

@Peeter, I believe that's a problem with your keyboard (probably some special behavior when NumLock is on?).

Can you please run "xev" and attach a log from when pressing Alt+F2 in those different cases?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers