[launcher] stops automatically hiding after some time using it

Bug #821180 reported by Marcus Pereira on 2011-08-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
High
Alberto Mardegan
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

After some random time, 10 minutes to 2 hours, of use unity-2d stops automatic hiding itself. Even on maximized active windows it stays at top.
The problem is only solved after login out and in again.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d 3.8.14.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
Architecture: amd64
Date: Thu Aug 4 19:51:55 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: Upgraded to oneiric on 2011-08-04 (0 days ago)

Marcus Pereira (marcds) wrote :
summary: - unity-2d stops automatic hiding
+ [launcher] stops automatically hiding after some time using it
Changed in unity-2d:
importance: Undecided → High
milestone: none → 4.2
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
assignee: nobody → Alberto Mardegan (mardy)
milestone: 4.2 → 4.4
Alberto Mardegan (mardy) wrote :

Hi Marcus, thanks for reporting this bug. However, no matter how many things I tried, I couldn't reproduce it. Could you please give me some hints? For instance, what applications are opened when you reproduce it, and also how often it happens to you.

From a look at the source code of the panel, I see that it only monitors the active window; and indeed, I could create some weird situation when the panel is *not* shown when it should (for instance, if you kill the application crossing the panel's area from a terminal), but that's quite a different issue.

And do you really need to log out, or switching worspace does also help?

Changed in unity-2d:
status: Confirmed → Incomplete
Alberto Mardegan (mardy) wrote :

Thanks Marcus! Marking as fixed, then.

Changed in unity-2d:
status: Incomplete → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.4.0-0ubuntu1

---------------
unity-2d (4.4.0-0ubuntu1) oneiric; urgency=low

  * New upstream release:
    - unity-2d-panel crashed with SIGSEGV in QConfSchema::findKey()
      (LP: #834045)
    - unity-2d-panel crashed with SIGSEGV in QConf::notify() (LP: #834001)
    - [panel] Implement whitelisting for legacy tray applet (LP: #707354)
    - [launcher] stops automatically hiding after some time using it
      (LP: #821180)
    - [panel] Empathy displays icon in deprecated systray (LP: #830017)
    - [dash] Invalid UTF-8 in the dash (LP: #836587)
    - [dash] Home buttons 'Media' and 'Internet' apps should not only take you
      to the apps lens but also activate the right filter (LP: #837360)
    - [dash] Drag&drop application from dash to launcher is broken
      (LP: #837361)
    - [launcher] contextual menu's corner has a blue line (LP: #828386)
    - [dash] Lens bar graphical layout glitches (LP: #833805)
    - [dash] Rating Filter: All button not clearing star highlighting
      (LP: #834640)
    - [dash] should be falling back to the default renderer if the renderer
      requested by the lens is not found (LP: #837356)
    - [dash] Gwibber lens icon doesn't show up in 2d unity (LP: #830728)
    - [dash] Lacks horizontal renderer used by lenses such as Gwibber
      (LP: #837712)
    - [dash] See %1 more result inconsistency (LP: #834226)
    - [launcher] When application has no icon, a question mark icon should be
      displayed (LP: #837351)
    - unity places should return a default icon when no matching icon is found
      (LP: #711200)
    - spacing between indicators should be 5 pixels (LP: #734010)
  * debian/control:
    - require current nux and unity
 -- Didier Roche <email address hidden> Thu, 01 Sep 2011 17:41:00 +0200

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers