Ubuntu

OpenGL windows always on top with Unity-2D and fglrx driver

Reported by Ricardo Graça on 2011-06-22
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Unassigned
unity-2d (Ubuntu)
High
Unassigned

Bug Description

When running an OpenGL application with Unity-2D (3.8.4.1) there is visual corruption in certain situations. So far I identified the following problems:
 - if the launcher covers any part of the OpenGL application's window, it will flicker when appearing and disappearing and may even become totally invisible (behind the OpenGL window?)
 - dragging a non-maximized OpenGL application's window will cause severe flicker inside the application itself

My system is Ubuntu 11.04 using the latest 11.6 version of fglrx and I still haven't tried with the free Radeon driver. Will report back as soon as I test that. There is no corruption when using normal Unity.

Steps to reproduce:
1) open an application that makes use of OpenGL acceleration and can run in windowed mode (e.g. glxgears, blender)
2) make sure that the application's window can be covered by the unity launcher
3) move the mouse to the top left side of the screen so the launcher appears

Expected results:
There is no corruption in the areas where the launcher intercepts the application's window

Actual results
Visual corruption in the areas where the launcher intercepts the application's window

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity-2d 3.8.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Jun 22 10:44:45 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=pt:en
 PATH=(custom, user)
 LANG=pt_PT.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: No upgrade log present (probably fresh install)

Ricardo Graça (devius) wrote :
Ricardo Graça (devius) wrote :
Ricardo Graça (devius) wrote :

I'm confirming the same with 'ATI Technologies Inc Mobility Radeon HD 3400 Series' and fglrx driver.

Changed in unity-2d (Ubuntu):
status: New → Confirmed

More info - this sort of flickering happens with any window you try to put over the OpenGL window, not just the launcher.

Confirming also that when running Unity 3D there are no such problems. The problem can best be described as 'OpenGL windows always want to be at the front' from what I can see.

Didier Roche (didrocks) on 2011-06-24
Changed in unity-2d:
status: New → Confirmed
Ricardo Graça (devius) on 2011-06-28
summary: - Visual artifacts/problems with OpenGL apps and Unity-2D
+ OpenGL windows always on top with Unity-2D
Changed in unity-2d:
importance: Undecided → High
tags: added: compositing
Changed in unity-2d (Ubuntu):
importance: Undecided → High

Same here. The window decoration behaves properly but the content of the window itself is fighting to be on top of all the rest. I say "fighting" because if I press the sound volume buttons on my keyboard, I *do* see the sound volume indicator pop-up in the top-left corner of my screen but only for a short instant before the Minecraft window overrides it.

summary: - OpenGL windows always on top with Unity-2D
+ OpenGL windows always on top with Unity-2D and fglrx driver
Changed in unity-2d:
milestone: none → 3.8.14
Didier Roche (didrocks) on 2011-08-01
Changed in unity-2d:
milestone: 3.8.14 → 3.8.16
Akos Kemives (akoskm) wrote :

I don't know is it the same bug but happens with banshee too. The application appears to be painted only, I can click through, see the screenshot.

Didier Roche (didrocks) on 2011-08-11
Changed in unity-2d:
milestone: 4.0 → 4.2
Changed in unity-2d:
milestone: 4.2 → 4.4
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
milestone: 4.6 → 4.8
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
milestone: 4.10 → 4.12
Changed in unity-2d:
milestone: 4.12 → 4.14
Łukasz Zemczak (sil2100) wrote :

I tried to reproduce this bug using the glxgears application with no luck. I have an ATI Radeon Mobility HD 2600 graphics card running the fglrx driver on Ubuntu 11.10. The application, even though covered under the unity-2d-launcher (or any other part of unity-2d) showed no unexpected visual results. As proposed by mardy, I also tried doing the same test under different settings of the compositing_manager and compositor_effects flags of Metacity and the use-opengl flag in unity-2d. In each case, the result using the glxgears application seemed correct.

Ricardo Graça (devius) wrote :

@Łukasz Zemczak What Unity-2D version and more importantly what Catalyst version? I noticed that since catalyst 11.7 there are some changes for the better in regards to this bug, but other issues have come up.

Łukasz Zemczak (sil2100) wrote :

My Catalyst version is 11.8, so it might be the reason why this bug does not appear. In overall OpenGL applications seem to blend correctly with unity here. I am using the latest, main branch build of unity-2d.

Gerry Boland (gerboland) on 2011-11-21
Changed in unity-2d:
milestone: 4.14 → none
Ricardo Graça (devius) wrote :

It seems this was a problem with older Catalyst versions and judging by the last comments seems to be fixed by now. I no longer have an AMD GPU so I can't test this, so if anyone else could test it we could move this bug forward.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers