unity-2d-places crashed with SIGSEGV in QTJSC::Structure::materializePropertyMap()

Bug #791127 reported by Martin Pitt on 2011-06-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Unassigned
unity-2d (Ubuntu)
Critical
Canonical Desktop Experience Team
Oneiric
Critical
Canonical Desktop Experience Team

Bug Description

Binary package hint: unity-2d

This crash happens when you boot current oneiric-alpha-1 (which defaults to unity-2d due to a bug which just got fixed), and click on the bfb (Ubuntu logo in the corner). It happens on the i386 and amd64 images, in kvm and on real hardware, so it doesn't seem hw specific at all.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-places 3.8.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic x86_64
Architecture: amd64
Date: Wed Jun 1 11:20:54 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/unity-2d-places
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
ProcCmdline: /usr/bin/unity-2d-places
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f89627baf59 <QTJSC::Structure::materializePropertyMap()+121>: testb $0x4,0x55(%rdi)
 PC (0x7f89627baf59) ok
 source "$0x4" ok
 destination "0x55(%rdi)" (0x00000059) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: unity-2d
StacktraceTop:
 QTJSC::Structure::materializePropertyMap (this=0x7f895407c520) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.cpp:258
 materializePropertyMapIfNecessary (args=0x7fff2af4bc60) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.h:172
 get (args=0x7fff2af4bc60) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.h:230
 getDirectLocation (args=0x7fff2af4bc60) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSObject.h:149
 inlineGetOwnPropertySlot (args=0x7fff2af4bc60) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSObject.h:353
Title: unity-2d-places crashed with SIGSEGV in QTJSC::Structure::materializePropertyMap()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Martin Pitt (pitti) wrote :
Changed in unity-2d:
importance: Undecided → Critical
Florian Boucault (fboucault) wrote :

This looks like a crash in either GTK, Cairo or librsvg.
Can you try to load some SVG icons from /usr/share with /usr/bin/rsvg-view?

Martin Pitt (pitti) wrote :

I tried rsvg-view on several icons of different size in /usr/share/icons/Humanity/ in the live session, and they all work fine. They also work with eog.

Changed in unity-2d:
milestone: none → 3.10
Changed in unity-2d (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → Critical
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: iso-testing
Martin Pitt (pitti) wrote :

This seems fixed for me now, just checked today's daily in KVM.

Changed in unity-2d (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in unity-2d:
milestone: 3.10 → 3.8.8
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers