Background fails to redraw

Bug #784209 reported by Bryce Harrington on 2011-05-17
50
This bug affects 6 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Unassigned
nautilus (Ubuntu)
High
Canonical Desktop Team
Oneiric
High
Canonical Desktop Team
unity-2d (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Binary package hint: unity-2d

After upgrading to oneiric, I booted on the natty kernel (the oneiric kernel left me at a corrupted busybox prompt). It loaded unity-2d (presumably because the box is on a kvm). This seemed to work, however dragging windows around left garbage (see photo).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d (not installed)
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
Date: Tue May 17 11:34:31 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: No upgrade log present (probably fresh install)

Bryce Harrington (bryce) wrote :
Florian Boucault (fboucault) wrote :

Thanks for the bug report Bryce!
Do you have the same issue in an "Ubuntu Classic" session (GNOME 2)?
Does it still happen in you set the gconf key /apps/metacity/general/compositing_manager to true?

Changed in unity-2d:
status: New → Incomplete
Changed in unity-2d (Ubuntu):
status: New → Incomplete
Changed in unity-2d:
importance: Undecided → High
Jean-Baptiste Lallement (jibel) wrote :

I don't think it's a unity-2d specific error because I get it with compiz as well and on different systems.

This error occurs when the background is set to a fixed color (not gradient) rather than a picture but I haven't been able to figure out what causes this. The 'trailing effect' is visible even before login, when the gdm window is resized when the user selects an account.

Changed in unity-2d (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
Changed in unity-2d:
status: Incomplete → Confirmed
Fabien Tassin (fta) wrote :

as discussed on irc, it's because of the default background value:

$ gsettings get org.gnome.desktop.background picture-uri
'file:///usr/share/themes/Adwaita/backgrounds/stripes.jpg'

it doesn't exist unless you have gnome-themes-standard installed.

The 2 workarounds are:

1/ change that key to a valid URI (still starting with file://)

or

2/ install gnome-themes-standard

The real fix is to change the default value to match an existing Ubuntu theme.

Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: iso-testing
Changed in unity (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in unity-2d (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Sebastien Bacher (seb128) wrote :

does it work if you select a valid wallpaper in the gnome-control-center?

Jean-Baptiste Lallement (jibel) wrote :

yes it does. The desktop doesn't repaint only when the background is set to a plain color.

Sebastien Bacher (seb128) wrote :

the issue is a nautilus one not an unity bug, the fix will be in the next upload

Changed in unity-2d (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → nobody
status: Confirmed → Invalid
affects: unity (Ubuntu Oneiric) → nautilus (Ubuntu Oneiric)
Changed in nautilus (Ubuntu Oneiric):
status: Confirmed → Triaged
Changed in unity-2d:
status: Confirmed → Invalid
Changed in nautilus (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Canonical Desktop Team (canonical-desktop-team)
Fabio Marconi (fabiomarconi) wrote :

uhmm
i can have this only in compiz, not in unity 2d

Fabio Marconi (fabiomarconi) wrote :

in Unity 2d everythings working fine in two systems, except the BFB and app and file buttons on the launcher

Fabio Marconi (fabiomarconi) wrote :

Yes, reproducible only in 3d, nvidia and intel, so I think is compiz related.

Fabio Marconi (fabiomarconi) wrote :

remove duplicate 791125

Changed in nautilus (Ubuntu Oneiric):
milestone: none → oneiric-alpha-2
Sebastien Bacher (seb128) wrote :

sorry I forgot to close it but that got fixed just after alpha1

Changed in nautilus (Ubuntu Oneiric):
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

the upload was

gsettings-desktop-schemas (3.0.1-1ubuntu1) oneiric; urgency=low

  * gsettings-desktop-schemas.gsettings-override: set the default ubuntu
    wallpaper and display the desktop by default.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments