[panel] F10 shortcut does not navigate from application menu to indicators

Bug #772061 reported by Jeremy Bicha on 2011-04-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Aurélien Gâteau
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity-2d

In Unity, F10 opens the first menu on the left (usually an application menu) and the user can then navigate the menus of the application menu and the status menus (indicators) using the arrow keys on the keyboard. In Unity 2D, F10 only navigates the application menu.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity-2d 3.8.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Wed Apr 27 18:17:08 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: Upgraded to natty on 2011-01-01 (116 days ago)

Related branches

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) on 2011-04-27
tags: added: a11y
summary: - F10 shorcut does not navigate status menus
+ [shortcuts] F10 shorcut does not navigate status menus
Changed in unity-2d:
milestone: none → 3.10
importance: Undecided → Medium
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
tags: added: accessibility
removed: a11y
summary: - [shortcuts] F10 shorcut does not navigate status menus
+ [shortcuts] F10 shortcut does not navigate status menus
tags: added: a11y
removed: accessibility
Didier Roche (didrocks) on 2011-07-04
Changed in unity-2d:
milestone: 3.8.10 → 3.8.12
Changed in unity-2d:
assignee: Olivier Tilloy (osomon) → nobody
assignee: nobody → Gerry Boland (gerboland)
importance: Medium → High
Changed in unity-2d:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-07-20
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Gerry Boland (gerboland) wrote :

On 25/7/2011 fixes were committed for the erratic behaviour of the F10 key to summon the menu.

However as yet, once you summon the Application menu, it is impossible to navigate to the Status menus using the keyboard. QMenuBar does not want to hand focus to any widgets other than its own submenus. This needs to be tackled.

summary: - [shortcuts] F10 shortcut does not navigate status menus
+ [panel] F10 shortcut does not navigate status menus
summary: - [panel] F10 shortcut does not navigate status menus
+ [panel] F10 shortcut does not navigate from application menu to
+ indicators
Changed in unity-2d:
assignee: Gerry Boland (gerboland) → Aurélien Gâteau (agateau)
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers