Ubuntu

[launcher] Impossible to keep KDE Apps in Launcher

Reported by Mathias Dietrich on 2011-03-23
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
BAMF
High
Unassigned
Unity
High
Didier Roche
unity-2d
High
Didier Roche
unity-2d (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity-2d

Description: Ubuntu 10.10
Release: 10.10

unity-2d:
  Installiert: 0.4-0ubuntu1~bzr425
  Kandidat: 0.4-0ubuntu1~bzr425
  Versionstabelle:
 *** 0.4-0ubuntu1~bzr425 0
        500 http://ppa.launchpad.net/unity-2d-team/unity-2d-daily/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

-------------------------------------------

Expected Behaviour:

1. Start a KDE App, like Okular or Akregator
2. Right Click on launcher icon
3. Set "Keep in Launcher", to keep in in launcher

Behaviour Instead:

1. Start a KDE App, like Okular or Akregator
2. Right Click on launcher icon
3. "Keep in Launcher" dialog is not available

Tested with Okular & Akregator from KDE 4.6.1.

Olivier Tilloy (osomon) wrote :

Tested with amarok, can’t keep it in the launcher.
Amarok’s desktop file is in /usr/share/applications/kde4/.

Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Florian Boucault (fboucault) wrote :

Olivier, did you confirm it in Maverick or Natty?
Do you guys know if it works in Unity?

Changed in unity-2d:
importance: Undecided → High
summary: - Impossible to keep KDE Apps in Launcher
+ [launcher] Impossible to keep KDE Apps in Launcher
Changed in unity-2d:
milestone: none → 3.10
Olivier Tilloy (osomon) wrote :

I initially confirmed on Maverick, and I just verified that it is also the case on Natty.

Unity seems to have a similar issue open: bug #736551. Unfortunately I cannot test because installing amarok in a live session drags in too many kde dependencies that don’t fit of my USB stick…

Olivier Tilloy (osomon) wrote :

I managed to test on Unity, and even though it lets the user keep the icon for Amarok in the launcher, this "favourite" is not persistent across sessions and fails to launch the application, because there is no desktop file associated. See my analysis of the root cause for a similar issue (java applications) in comment #4 of bug #704046.

Alex Launi (alexlauni) on 2011-03-30
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-05
Changed in bamf:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
falkTX (falk-t-j) wrote :

I also noticed this, although I see the "keep in launcher" option for kde apps.
the applications stay pinned in the launcher, but disappear after re-login.

using latest Ubuntu 11.04, 64bit, system up-to-date.

Changed in unity-2d:
milestone: 3.10 → none
Didier Roche (didrocks) on 2011-04-27
Changed in unity:
importance: Undecided → High
Changed in bamf:
importance: Undecided → High
Changed in bamf (Ubuntu):
importance: Undecided → High
Changed in unity-2d (Ubuntu):
importance: Undecided → High
Changed in unity:
milestone: none → 3.8.14
Didier Roche (didrocks) on 2011-04-27
Changed in unity:
status: Confirmed → Fix Committed
Changed in bamf:
status: Confirmed → Fix Committed
Changed in bamf (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity-2d:
status: Confirmed → In Progress
milestone: none → 3.10
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

setting back to triaged since Jason said the fix is wrong, those should be ranked lower rather than skipped

Changed in bamf (Ubuntu):
status: Fix Committed → Triaged
Changed in bamf:
status: Fix Committed → Triaged
Changed in unity:
status: Fix Committed → Triaged
David Barth (dbarth) on 2011-05-31
Changed in unity:
milestone: 3.8.14 → 3.8.16
assignee: nobody → Jason Smith (jassmith)
Changed in unity-2d:
status: Fix Committed → Triaged
Changed in unity-2d (Ubuntu):
status: Fix Committed → Confirmed
Didier Roche (didrocks) on 2011-06-14
Changed in unity-2d (Ubuntu):
status: Confirmed → Triaged
David Barth (dbarth) wrote :

Jason: can you comment to detail the reasons for the issue. I want to make sure this is still an SRU target, or whether the underlying changes are not SRU-grade anymore. Thanks

Changed in unity:
milestone: 3.8.16 → 3.8.18
Didier Roche (didrocks) on 2011-07-04
Changed in unity-2d:
milestone: 3.8.10 → 3.8.12
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
milestone: 3.8.12 → 3.8.14
Didier Roche (didrocks) on 2011-08-01
Changed in unity-2d:
milestone: 3.8.14 → 3.8.16
Florian Boucault (fboucault) wrote :

It looks like part of the root cause of this bug has been fixed in BAMF. Now in Oneiric, for the Konversation program, BAMF gives "konversation.desktop" as favorite. Because of that Unity 2D will show the option "keep in launcher" for Konversation and it is correctly added to the list of favorites in D-Conf.
However it should really be "kde4-konversation.desktop" that is returned because the desktop file is not in /usr/share/applications but in /usr/share/applications/kde4

Florian Boucault (fboucault) wrote :

Scrap that last comment as I was looking in the wrong spot. I will be back with more accurate information.

Florian Boucault (fboucault) wrote :

Only in Oneiric, BAMF returns the correct full path to the desktop file for KDE4 applications (at least for Konversation).

Unity (2D and 3D) however only store the filename of the desktop file in the favorites list (in dconf).
Unity 3D has a mechanism to find that file by looking up quite a few directories on the filesystem. Unity 2D does not have such a mechanism.
As a result KDE4 apps can be favorited in Unity 3D in Oneiric but not in Unity 2D.

Florian Boucault (fboucault) wrote :

Commit 977 of lp:unity added that mechanism.

Didier Roche (didrocks) on 2011-08-08
Changed in unity:
assignee: Jason Smith (jassmith) → Didier Roche (didrocks)
milestone: 3.8.18 → 4.8.0
Changed in unity-2d:
assignee: nobody → Didier Roche (didrocks)
Changed in bamf (Ubuntu):
status: Triaged → Invalid
Changed in bamf:
status: Triaged → Invalid
Didier Roche (didrocks) on 2011-08-08
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity-2d:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-08-11
Changed in unity:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.8.0-0ubuntu1

---------------
unity (4.8.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - store kde4 applications in a gio-friendly way (LP: #741129)
  * Take and make some additional post-release adjustement
  * debian/control:
    - add libjson-glib-dev
    - now build depend on libunity-dev
    - make libunity-core-4.0-dev dep on libunity-dev even if not in .pc file
      (seems to leak the API)
    - build-dep on latest nux
    - now recommends lenses, not places and add music lens as a recommends
  * remove patched plugins/unityshell/src/BGHash.cpp for replacing dark with
    real dash color
  * debian/rules:
    - bump libunity-core-4.0-4 shlib for ABI break
  * remove 01_revert_removed_function_for_unity2d_to_build.patch:
    - incoming unity-2d upload has the needed bits
  * debian/unity-common.install:
    - install new assets and json scripts
 -- Didier Roche <email address hidden> Thu, 11 Aug 2011 19:47:19 +0200

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Didier Roche (didrocks) on 2011-08-11
Changed in bamf:
status: Invalid → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.0.0-0ubuntu1

---------------
unity-2d (4.0.0-0ubuntu1) oneiric; urgency=low

  * New upstream release:
    - [launcher] Impossible to keep KDE Apps in Launcher (LP: #741129)
    - [dash] Background should be blurred (LP: #823326)
    - No 'safely remove' option is present in the unity menu when a usb disk
      is inserted (LP: #660010)
    - Quicklist item "Keep In Launcher" should be "Keep in launcher" as design
      (LP: #795422)
    - [launcher] ESC doesn't dismiss launcher when activated with Alt+F1
      (LP: #812792)
    - [dash] Background wallpaper shifted when using a non compositing window
      manager (LP: #823295)
    - [launcher] Bottom gradient appears too early (LP: #823877)
    - mute/unmute sound when user clicks on sound applet using scroll button
      or middle mouse button (LP: #609860)
    - Secondary activate (i.e. middle click) support for indicators advanced
      usage (LP: #812933)
    - Unused GConfItemQmlWrapper dep found (LP: #821880)
  * debian/control:
    - bump libunity-core-4.0-dev, libnux-1.0-dev
    - recommends lenses and not places anymore. Adding music lens
 -- Didier Roche <email address hidden> Thu, 11 Aug 2011 21:22:18 +0200

Changed in unity-2d (Ubuntu):
status: Triaged → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
no longer affects: bamf (Ubuntu)
no longer affects: bamf (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers