Ubuntu

Gnome-terminal doesn't start in user home directory when started from alt+F2

Reported by Tobin Davis on 2011-03-16
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Low
Ian Liu Rodrigues
Unity Foundations
Low
Ian Liu Rodrigues
unity-2d
Low
Unassigned
unity-lens-applications
Low
Ian Liu Rodrigues
unity-2d (Ubuntu)
Undecided
Unassigned
unity-place-applications (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity-2d

When starting gnome-terminal from unity-2d, the default directory is "/" instead of "~". Gnome-terminal works correctly when started from the Classic Desktop.

Image is from 20110311 on panda with latest updates. Installing unity-2d on an x86 VM image to see if it is platform specific.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity-2d-launcher 3.6.2-0ubuntu1
ProcVersionSignature: User Name 2.6.38-1204.5-omap4 2.6.38-rc7
Uname: Linux 2.6.38-1204-omap4 armv7l
Architecture: armel
Date: Wed Mar 16 15:25:48 2011
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-2d
UpgradeStatus: No upgrade log present (probably fresh install)

Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) wrote :

This appears to happen in the x86 version as well.

Didier Roche (didrocks) wrote :

@Tobin: I affect that on alt+F2 as you told "This appears to happen in the x86 version" (there is this known issue on alt + F2, not sure you are mentioning really the launcher or the dash). If not, there are two bugs then ;)

summary: Gnome-terminal doesn't start in user home directory when started from
- unity-2d-launcher
+ alt+F2
tags: added: bitesize unity
Changed in unity-place-applications:
status: New → Triaged
Changed in unity:
importance: Undecided → Low
Changed in unity-place-applications:
importance: Undecided → Low
Changed in unity-place-applications (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Didier Roche (didrocks) wrote :

(added it to bitesize list, can be a nice one!)

Changed in unity:
status: New → Triaged
Changed in unity:
assignee: nobody → Ian Liu (ian-liu88)
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Low
Changed in unity-place-applications:
status: Triaged → Fix Committed
assignee: nobody → Ian Liu Rodrigues (ian-liu88)
Didier Roche (didrocks) on 2011-03-31
Changed in unity:
status: Triaged → Fix Committed
milestone: none → 3.8.2
Changed in unity-place-applications:
milestone: none → 0.2.44
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-foundations:
assignee: nobody → Ian Liu Rodrigues (ian-liu88)
importance: Undecided → Low
milestone: none → unity-3.8.2
status: New → Fix Released
Changed in unity-2d:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-applications - 0.2.44-0ubuntu1

---------------
unity-place-applications (0.2.44-0ubuntu1) natty; urgency=low

  * New upstream release.
    - unity-applications-daemon crash when Software Center index is corrupted
      (LP: #620294)
    - Dash: Alt-F2 "nautilus ~/" errors to "Could not find '/~'" (LP: #734762)
    - unity-applications-daemon crash in unity_package_searcher_search()
      (LP: #739698)
    - unity-applications-daemon crash because of invalid docid 0 (LP: #744261)
    - Gnome-terminal doesn't start in user home directory when started from
      alt+F2 (LP: #736471)
 -- Didier Roche <email address hidden> Thu, 31 Mar 2011 15:09:07 +0200

Changed in unity-place-applications (Ubuntu):
status: Triaged → Fix Released
Olivier Tilloy (osomon) wrote :

Marking invalid for unity-2d, the issue is already tracked there by bug #684471.
I’m not marking as a duplicate as it remains valid for all the other projects affected.

Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers