ubuntu-bug showing that I am running unity-2D, when reporting from Compiz Unity interface

Bug #712343 reported by elPraga on 2011-02-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Didier Roche
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: apport

Hi guys,
I am not sure if this is a bug nor not, but just in case. In the reports it says that I am running unity-2D when reporting a bug from Unity-Compiz. I do have unity-2D installed, but I am not using it at the moment.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: apport 1.17.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
ApportLog:

Architecture: i386
Date: Thu Feb 3 10:52:31 2011
EcryptfsInUse: Yes
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=es_ES:es:en_GB:en
 LANG=es_ES.UTF-8
 LC_MESSAGES=es_ES.utf8
 SHELL=/bin/bash
SourcePackage: apport

Related branches

elPraga (elpraga) wrote :
Philip Muškovac (yofel) wrote :

As I understand it general-hooks are run for all packages, so unless the hook provided by unity-2d checks if unity-2d is actually running it will add the tag simply by being installed. Reaffecting.

affects: apport (Ubuntu) → unity-2d (Ubuntu)
Florian Boucault (fboucault) wrote :

Oliver, do you think you could have a look at that? I am really not knowledgeable in this domain :)

Changed in unity-2d:
assignee: nobody → Oliver Grawert (ogra)
milestone: none → 3.10
Olivier Tilloy (osomon) wrote :

To reproduce:

0) run a default unity session ("Ubuntu", not "Unity 2D")
1) invoke e.g. `ubuntu-bug unity`
2) before submitting the bug report, check the content of the report
3) look at the Tags section

Expected result: it doesn’t contain "unity-2d"

Current result: it contains "unity-2d"

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

I think a reliable way of determining whether the current session is Unity 2D is to check the value of the GDMSESSION environment variable.
For unity, its value is "gnome".
For unity-2d, its value is "unity-2d".
For Ubuntu classic, its value is "gnome-classic".

Olivier Tilloy (osomon) on 2011-04-27
Changed in unity-2d:
assignee: Oliver Grawert (ogra) → Olivier Tilloy (osomon)
status: Confirmed → In Progress
Changed in unity-2d:
importance: Undecided → High
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Confirmed
Changed in unity-2d (Ubuntu):
status: In Progress → Confirmed
Changed in unity-2d:
assignee: Olivier Tilloy (osomon) → Didier Roche (didrocks)
milestone: 3.8.10 → none
Didier Roche (didrocks) on 2011-07-18
Changed in unity-2d:
status: Confirmed → Fix Committed
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity-2d:
milestone: none → 3.8.12
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers