unity dash search can't open files in folder with accent in name

Bug #1003820 reported by Frédéric Hoogstoel on 2012-05-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
Undecided
Unassigned
unity-2d (Ubuntu)
Low
Unassigned

Bug Description

Hi !

I use Ubuntu 12.04, with Unity

I appreciate really the dash global search tool. It would be nice if it could work with folders with accent in name.

Here are the steps to get the bug.
1 - edit and save a file in a folder with accent in name (I tried with a LibreOffice and with a full text file)
2 - open the dash
=> the file appears in the list of recent files
3 - click on the file
4 - nothing happens

To check that the bug comes from the accent in the folder's name :
1 - rename the folder without accent
2 - edit and the save the previous file
3 - open the dash
=> the file appears in the list of recent files
4 - click on the file
5 - the file is opened

Thanks.

The unity packages installed on my computer are the last available woth synaptic four Ubunutu 12.04 :
Unity 5.12-0ubuntu1
Unity 2D 5.12.0-0ubuntu1

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, do you use unity3d or 2d?

I tried here with a french local doing:
- right click on the desktop (nautilus)
- create a folder "tést"
- go to that folder, right click, create an empty document "debugging"
- double click on it (open in gedit)
- close gedit
- open the dash
- type "debu"
- click on the "debugging" item on the recently used files section

-> gedit opens the debugging file correctly

Do you get the issue with the same steps? (using unity-3d here)

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

Following the sames steps as you, but with unity 2D, I get the issue ; no file editor opens the file.
Follwing the same steps with a folder named test without accent, gedit opens the debugging file.

I don't see any (installed or not installed) unity-3d package in Synaptic.
How can I check that I use unity 2D, and not Unity 3D ?

When I start it, MyUnity tool displays that I use Unity 2D.

Sebastien Bacher (seb128) wrote :

That's a bug in unity-2d then, on the login screen if you click on the gear icon next to the password field you have the session, "ubuntu" is unity-3d, "ubuntu 2d" is unity-2d, you might also want to check .xsession-errors, it might just be that it falls back to 2d because your video driver doesn't support 3d correctly

affects: unity (Ubuntu) → unity-2d (Ubuntu)
Changed in unity-2d (Ubuntu):
status: Incomplete → New

OK. I remember now that I had to install Unity 2D because Unity (3D) does not work in my session, but it's another story ...
I made the test with a guest session using unity 3D and I didn't get the isssue. So, I agree : that's bug with unity 2D.
Thank you Sébastien for your quick and smart answers.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers