Place unison.log file in ~/.unison

Bug #234365 reported by Nanley Chery on 2008-05-23
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
unison (Debian)
New
Unknown
unison (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unison

Right now using unison places a "unison.log" file in the home directory; having a stranded .txt file in the home directory looks bad. The file should be in unison's .unison folder in the home directory away from the user's sight.

Rui Boon (ruiboon) wrote :

Working on it...

Changed in unison:
assignee: nobody → ruiboon
status: New → In Progress
Rui Boon (ruiboon) wrote :

Nanley Chery: Could you check if this debdiff is ok? If so, please set this as confirmed and subscribe u-u-s. Thanks
(I will be away for a seminar)

Rui Boon (ruiboon) wrote :
Changed in unison:
assignee: ruiboon → nobody
status: In Progress → Confirmed
Nanley Chery (nanoman) wrote :

I'm not sure if I have to use an actual software package to test your debdiff, but reading through it, it looks perfect.

Luca Falavigna (dktrkranz) wrote :

Some notes:
* Package does use of dpatch, you should use it when patching upstream files.
  See https://wiki.ubuntu.com/PackagingGuide/PatchSystems for further references.
* Please adhere to DebianMaintainerField (https://wiki.ubuntu.com/DebianMaintainerField).

Also, consider submitting this change to Debian too.
Please resubscribe ubuntu-universe-sponsors when you will have another debdiff ready for review, thanks!

Changed in unison:
assignee: nobody → ruiboon
importance: Undecided → Low
status: Confirmed → In Progress
Rui Boon (ruiboon) wrote :

Used dpatch and adhered to DebianMaintainerField as required. Hope this will be in the correct format.

Changed in unison:
assignee: ruiboon → ubuntu-universe-sponsors
status: In Progress → Confirmed
Rui Boon (ruiboon) on 2008-06-02
Changed in unison:
assignee: ubuntu-universe-sponsors → nobody
StefanPotyra (sistpoty) wrote :

Hi,

debdiff looks fine to me, I'll upload it in a minute. Can you also report this upstream please?

Thanks,
    Stefan.

StefanPotyra (sistpoty) wrote :

sorry, also it's working perfectly, I've still got one thing to fix:
please describe all your changes in debian/changelog, i.e. what files did you change and why.

I'm unsubscribing ubuntu-universe-sponsors in the meantime, please resubscribe once you've added an improved debdiff.

Thanks,
    Stefan.

Rui Boon (ruiboon) wrote :

debian/changelog is more descriptive. i.e. all changes are reflected there.

As requested, this has also been submitted upstream to Debian.

Changed in unison:
status: Unknown → New
Benjamin Drung (bdrung) wrote :

You should change the distribution in your changelog entry to the current development version, that is changing hardy to intrepid.

Scott Kitterman (kitterman) wrote :

Looks generally good. If it's otherwise OK, I'll fix the release.

Changed in unison:
assignee: nobody → kitterman
status: Confirmed → In Progress
Scott Kitterman (kitterman) wrote :

Uploading. Thank you for your contribution to Ubuntu.

Changed in unison:
assignee: kitterman → nobody
status: In Progress → Fix Committed
Didier Roche (didrocks) wrote :

Just to notify that this package has not been closed at this time. Maybe because of a wrong taf in debdiff : "(Closes: LP #234365)" ?

Changed in unison:
status: Fix Committed → Fix Released
Katsudon (katsudon) wrote :

Ubuntu 8.10 wth all upgrades.
Regression. Unison still keeps its log in the home directory instead of .unison

Changed in unison:
status: Fix Released → In Progress
Katsudon (katsudon) wrote :

My apologies, I have two versions of unison installed for compatibility reasons between servers and it seems that the bad behavior concerns the old version. Therefore there is no regression in reality.

Changed in unison:
status: In Progress → Fix Released
Bausparfuchs (bausparfuchs) wrote :

This is still valid in Natty Narwhal with unison 2.32

tags: added: patch
Gábor Lipták (gliptak) wrote :

Maybe .config/unison could be considered as the location for this progress status file? Thanks

Gábor Lipták (gliptak) wrote :

Fixed with:

$ dpkg --list | grep unison
ii unison-gtk 2.40.102-2ubuntu1 amd64 file-synchronization tool for Unix and Windows with GTK+ interface

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.