upgrade-between-snapshots autopkgtest is flaky

Bug #1848354 reported by Balint Reczey on 2019-10-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unattended-upgrades (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

[Impact]

 * Flaky upgrade-between-snapshots autopkgtest prevents developers to use the test efficiently.

[Test Case]

 * Run autopkgtests, observe the upgrade-between-snapshots test passing or failing but being marked as FLAKY.

[Regression Potential]

 * None, the test was failing often due to connectivity/internal errors of snapshot.debian.org.

[Other Info]

 * The whole autopkgtest is marked to be failing on amd64 to mitigate the single flaky test, this marking can be removed after marking this single flaky test.

Balint Reczey (rbalint) on 2019-10-16
Changed in unattended-upgrades (Ubuntu):
status: New → Fix Committed

Hello Balint, or anyone else affected,

Accepted unattended-upgrades into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unattended-upgrades/1.14ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: block-proposed-eoan
tags: added: verification-needed verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unattended-upgrades - 1.14ubuntu1.1

---------------
unattended-upgrades (1.14ubuntu1.1) eoan; urgency=medium

  * debian/tests/control: Mark upgrade-between-snapshots as flaky
    (Closes: #941752) (LP: #1848354)

 -- Balint Reczey <email address hidden> Wed, 16 Oct 2019 17:47:42 +0200

Changed in unattended-upgrades (Ubuntu):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

Hello Balint, or anyone else affected,

Accepted unattended-upgrades into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unattended-upgrades/1.10ubuntu5.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in unattended-upgrades (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed-disco
Brian Murray (brian-murray) wrote :

Hello Balint, or anyone else affected,

Accepted unattended-upgrades into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unattended-upgrades/1.1ubuntu1.18.04.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in unattended-upgrades (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Changed in unattended-upgrades (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Balint, or anyone else affected,

Accepted unattended-upgrades into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unattended-upgrades/1.1ubuntu1.18.04.7~16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Balint Reczey (rbalint) wrote :

Tested 1.1ubuntu1.18.04.12 on Bionic:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/amd64/u/unattended-upgrades/20191024_213859_e45c8@/log.gz
...
Allowed origins are: origin=Debian,codename=sid,label=Debian, origin=Debian,codename=sid,label=Debian-Security
An error occurred: 503 Service Unavailable
An error occurred: 503 Service Unavailable
The URI http://snapshot.debian.org/archive/debian/20171210T000000Z/pool/main/libe/libepoxy/libepoxy0_1.4.3-1_amd64.deb failed to download, aborting
The URI http://snapshot.debian.org/archive/debian/20171210T000000Z/pool/main/libe/libepoxy/libepoxy0_1.4.3-1_amd64.deb failed to download, aborting
Command exited with non-zero status 1
45.30user 1.77system 3:18.70elapsed 23%CPU (0avgtext+0avgdata 82468maxresident)k
632inputs+69168outputs (0major+43798minor)pagefaults 0swaps
autopkgtest [21:38:49]: test upgrade-between-snapshots: -----------------------]
autopkgtest [21:38:49]: test upgrade-between-snapshots: - - - - - - - - - - results - - - - - - - - - -
upgrade-between-snapshots FLAKY non-zero exit status 1
autopkgtest [21:38:49]: @@@@@@@@@@@@@@@@@@@@ summary
run-tests PASS
test-systemd.py PASS
upgrade-all-security PASS
upgrade-between-snapshots FLAKY non-zero exit status 1
Exit request sent.
...

tags: added: verification-done-bionic
removed: verification-needed-bionic
Balint Reczey (rbalint) wrote :

Tested 1.1ubuntu1.18.04.7~16.04.4 on Xenial:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/u/unattended-upgrades/20191024_220650_7dfdf@/log.gz
...
The URI http://snapshot.debian.org/archive/debian/20171210T000000Z/pool/main/m/mesa/libxatracker2_17.2.5-1_amd64.deb failed to download, aborting
Command exited with non-zero status 1
96.85user 2.46system 1:43.88elapsed 95%CPU (0avgtext+0avgdata 82204maxresident)k
0inputs+23400outputs (0major+43885minor)pagefaults 0swaps
autopkgtest [22:06:37]: test upgrade-between-snapshots: -----------------------]
autopkgtest [22:06:37]: test upgrade-between-snapshots: - - - - - - - - - - results - - - - - - - - - -
upgrade-between-snapshots FLAKY non-zero exit status 1
autopkgtest [22:06:37]: @@@@@@@@@@@@@@@@@@@@ summary
run-tests PASS
test-systemd.py PASS
upgrade-all-security PASS
upgrade-between-snapshots FLAKY non-zero exit status 1
...

tags: added: verification-done-xenial
removed: verification-needed-xenial
Balint Reczey (rbalint) wrote :

Tested 1.14ubuntu1.1 on Eoan:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan/eoan/amd64/u/unattended-upgrades/20191016_223206_2d8a4@/log.gz

...
autopkgtest [22:31:56]: @@@@@@@@@@@@@@@@@@@@ summary
run-tests PASS
test-systemd.py PASS
upgrade-all-security SKIP exit status 77 and marked as skippable
upgrade-between-snapshots PASS
kernel-patterns PASS
Exit request sent.
...

tags: added: verification-done-eoan
removed: verification-needed-eoan
Balint Reczey (rbalint) wrote :

Dropping block-proposed-eoan tag, since releasing to release pocket is now to be approved by the SRU team.

tags: removed: block-proposed-eoan
Balint Reczey (rbalint) wrote :

Tested unattended-upgrades/1.10ubuntu5.2 on Disco:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-disco/disco/amd64/u/unattended-upgrades/20191025_130642_9d5e1@/log.gz

...
E: Failed to fetch http://snapshot.debian.org/archive/debian/20171001T000000Z/pool/main/p/python3.5/python3.5_3.5.4-4_amd64.deb 503 Service Unavailable
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
autopkgtest [13:06:31]: test upgrade-between-snapshots: -----------------------]
upgrade-between-snapshots FLAKY non-zero exit status 100
autopkgtest [13:06:31]: test upgrade-between-snapshots: - - - - - - - - - - results - - - - - - - - - -
autopkgtest [13:06:31]: @@@@@@@@@@@@@@@@@@@@ summary
run-tests PASS
test-systemd.py PASS
upgrade-all-security PASS
upgrade-between-snapshots FLAKY non-zero exit status 100
...

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Łukasz Zemczak (sil2100) wrote :

Correct me if I'm wrong, but since this is only an autopkgtest mark-as-flaky change, it feels to me like something that doesn't necessarily needs to be released into -updates. Let us block it in -proposed until we have more to release.

tags: added: block-proposed-bionic block-proposed-disco block-proposed-eoan block-proposed-xenial
Balint Reczey (rbalint) wrote :

@sil2100 there are more bugs fixed in the u-u SRUs in Disco and older and the Eoan upload is needed to unblock them thus I suggest dropping all block-proposed tags.

tags: removed: block-proposed-bionic block-proposed-disco block-proposed-eoan block-proposed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unattended-upgrades - 1.14ubuntu1.1

---------------
unattended-upgrades (1.14ubuntu1.1) eoan; urgency=medium

  * debian/tests/control: Mark upgrade-between-snapshots as flaky
    (Closes: #941752) (LP: #1848354)

 -- Balint Reczey <email address hidden> Wed, 16 Oct 2019 17:47:42 +0200

Changed in unattended-upgrades (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unattended-upgrades has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unattended-upgrades - 1.10ubuntu5.2

---------------
unattended-upgrades (1.10ubuntu5.2) disco; urgency=medium

  * Report packages kept back by origin (LP: #1821376)
  * Store list of kept packages and report the number of them in motd
    (LP: #1823070)
  * Default to "/" as rootdir to fix saving list of kept packages.
    Thanks to Paul Wise (Closes: #932160) (LP: #1823070)
  * debian/tests/control: Mark upgrade-between-snapshots as flaky
    (Closes: #941752) (LP: #1848354)

 -- Balint Reczey <email address hidden> Fri, 18 Oct 2019 13:22:02 +0200

Changed in unattended-upgrades (Ubuntu Disco):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unattended-upgrades - 1.1ubuntu1.18.04.12

---------------
unattended-upgrades (1.1ubuntu1.18.04.12) bionic; urgency=medium

  * Report packages kept back by origin (LP: #1821376)
  * Store list of kept packages and report the number of them in motd
    (LP: #1823070)
  * Default to "/" as rootdir to fix saving list of kept packages.
    Thanks to Paul Wise (Closes: #932160)
  * debian/tests/control: Mark upgrade-between-snapshots as flaky
    (Closes: #941752) (LP: #1848354)

 -- Balint Reczey <email address hidden> Fri, 18 Oct 2019 13:24:28 +0200

Changed in unattended-upgrades (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unattended-upgrades - 1.1ubuntu1.18.04.7~16.04.4

---------------
unattended-upgrades (1.1ubuntu1.18.04.7~16.04.4) xenial; urgency=medium

  * Report packages kept back by origin (LP: #1821376)
  * Store list of kept packages and report the number of them in motd
    (LP: #1823070)
  * Default to "/" as rootdir to fix saving list of kept packages.
    Thanks to Paul Wise (Closes: #932160)
  * debian/tests/control: Mark upgrade-between-snapshots as flaky
    (Closes: #941752) (LP: #1848354)

 -- Balint Reczey <email address hidden> Fri, 18 Oct 2019 13:29:41 +0200

Changed in unattended-upgrades (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers