Wrong/confuse text on shutdown at unattended-upgrades

Bug #1741579 reported by ITEAS on 2018-01-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unattended-upgrades (Ubuntu)
Low
Balint Reczey
Xenial
Undecided
Unassigned

Bug Description

[Impact]

 * The confusing text on shutdown is, well, can confuse users.
 * This fix itself is minor and would not warrant a backport but it is backported as part of fully backporting Bionic's u-u version to Xenial.

[Test Case]

 * Check that the status text is less confusing than it was previously either by configuring unattended-upgrades to run at shutdown and waiting for the text to appear or check that the text is changed in unattended-upgrades-shutdown:

$ grep -B1 please /usr/share/unattended-upgrades/unattended-upgrade-shutdown
    msg = _("Unattended-upgrade in progress during shutdown, "
            "please don't turn off the computer")

  * The former way or the verification may not be easy since with the fix for LP: #1803137 the shutdown screen does not show up when u-u-shutdown starts running, see the bug for the details.
  * Also checking unatttended-upgrades-shutdown for the changed text does not ensure that the translation is ready, too.

[Regression Potential]

 * The updated text should not cause major issues, but until it is translated to each language it is shown in English, possibly confusing users in a different way.

[Original Bug Text]

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unattended-upgrades-0.90ubuntu0.9
Uname: 4.4.0-104-generic #127-Ubuntu SMP
Architecture: amd64

I've german systems, so when updates will be installed at shutdown this text will be displayed at the screen.

German:
"unattended upgrade läuft während des herunterfahrens weiter, es wird fünf Sekunden lange gewartet"

English:
"unattended upgrade runs during the shutdown, it waits for five seconds"

This sentence make absolutly no sence for me. Maybe it is an translationproblem? Don't know text on the english ubuntuversion.
The problem is that some customer turned of some computers, because the updates need more time then 5 seconds ;)

A better message will that was Windows10 displays at shutdown ...don't turn off the computer, updates will be installed...

Thanks and best Reagards

Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I found the original message, "Unattended-upgrade in progress during shutdown, sleeping for 5s" (https://translations.launchpad.net/ubuntu/artful/+source/unattended-upgrades/+pots/unattended-upgrades/de/52/+translate). Though I am not sure if the issue is with the translation or the original text.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

tags: added: xenial
removed: update upgrade
Changed in ubuntu-translations:
assignee: nobody → Ubuntu German Translators (ubuntu-l10n-de)
schuko24 (gerd-saenger) on 2018-01-06
Changed in unattended-upgrades (Ubuntu):
assignee: nobody → schuko24 (gerd-saenger)
schuko24 (gerd-saenger) wrote :

Translation changed to:
»Unattended-Upgrade läuft während des Herunterfahrens weiter, es beginnt in fünf Sekunden, Gerät bitte
nicht ausschalten.«

Changed in unattended-upgrades (Ubuntu):
status: New → Fix Committed
ITEAS (info-tux-pc) wrote :

Hello, and thanks for the fast reply :)

@Hans Joachim Desserud (hjd)
Thanks for the information. Never used Apport before. But looks likes easy too.

ITEAS (info-tux-pc) wrote :

@schuko24 (gerd-saenger) i think more better to understand:
»Automatische Systemupdates werden während des Herunterfahrens installiert. Der Vorgang kann einige Zeit dauern. Gerät bitte nicht ausschalten.«

Thanks a lot!

Gunnar Hjalmarsson (gunnarhj) wrote :

@schuko24: Please note that you didn't change the unattended-upgrades package; you changed the Launchpad translation for the package.

Changed in ubuntu-translations:
status: New → In Progress
assignee: Ubuntu German Translators (ubuntu-l10n-de) → schuko24 (gerd-saenger)
Changed in unattended-upgrades (Ubuntu):
assignee: schuko24 (gerd-saenger) → nobody
status: Fix Committed → New
ITEAS (info-tux-pc) wrote :

Ok... so what is to do now that this text will be changed in german versions ubuntu 16.04 and up comming versions?

schuko24 (gerd-saenger) wrote :

@gunnarhj: Thanks for correcting, I just hit the wrong row with not being a programmer. Ooops.

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2018-01-06 15:54, ITEAS wrote:
> Ok... so what is to do now that this text will be changed in german
> versions ubuntu 16.04 and up comming versions?

The change will affect 18.04 primarily. If another translation update of 16.04 is accomplished, the change will be seen there as well. 17.04 and 17.10 will probably not be changed.

ITEAS (info-tux-pc) wrote :

@gunnarhj Ok, thank you.

Balint Reczey (rbalint) on 2018-01-08
Changed in unattended-upgrades (Ubuntu):
status: New → Confirmed
assignee: nobody → Balint Reczey (rbalint)
Balint Reczey (rbalint) wrote :

I proposed the fix at the packaging repository in https://github.com/mvo5/unattended-upgrades/pull/87 . Most likely it will be part of the next package update.

Changed in unattended-upgrades (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Low
Balint Reczey (rbalint) on 2018-01-10
Changed in unattended-upgrades (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unattended-upgrades - 0.99ubuntu2

---------------
unattended-upgrades (0.99ubuntu2) bionic; urgency=medium

  * Run upgrade-between-snapshots only on amd64.
    The test exercises only unattented-upgrade's Python code and uses
    dependencies from the frozen Debian snapshot archive thus running
    it on all architectures would provide little benefit.

 -- Balint Reczey <email address hidden> Tue, 13 Feb 2018 11:41:20 +0700

Changed in unattended-upgrades (Ubuntu):
status: Fix Committed → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

The new string is currently untranslated in most languages including German, but that's a regular condition and does not motivate a bug report. Dropping the Ubuntu Translations bug task.

no longer affects: ubuntu-translations
Balint Reczey (rbalint) on 2018-11-30
description: updated

Hello ITEAS, or anyone else affected,

Accepted unattended-upgrades into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unattended-upgrades/1.1ubuntu1.18.04.7~16.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in unattended-upgrades (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello ITEAS, or anyone else affected,

Accepted unattended-upgrades into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unattended-upgrades/1.1ubuntu1.18.04.7~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers