saving file in umbrello not working on Ubuntu 16.04

Bug #1585611 reported by Ingo Haschler on 2016-05-25
92
This bug affects 18 people
Affects Status Importance Assigned to Milestone
umbrello (Ubuntu)
Undecided
Unassigned

Bug Description

Installed umbrello via apt-get on fresh Ubuntu 16.04 (32bit) install. Icons are missing and saving the file fails with an error.

Please add the following package dependencies:
kinit kio kio-extras kded5

This solution also works on 64-bit installs (confirmed on multiple buddie's PCs).

Revision history for this message
Ingo Haschler (ingo) wrote :

Bug #445698 maybe related.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in umbrello (Ubuntu):
status: New → Confirmed
Revision history for this message
MartinM (martin-manert) wrote :

Installing these packages, solved another problem: Before, I couldn't open umbrello - files. (error - message: "file does not exist"). (Ubuntu 16.04, 64Bit)

Revision history for this message
Szymon Wojtowicz (ghb321-gmail) wrote :
Revision history for this message
ErikMartre (erikmartre-k) wrote :

Both solutions worked for me on Xenial 64, but the last one gave me menu icons, which were still missing with the first one (adding k* packages).

Revision history for this message
ErikMartre (erikmartre-k) wrote :

Unfortunately, previous version on 16.04 crashes when adding multiplicity to an association. So I had to come back to up-to-date one and add the packages listed above by Ingo Haschler.

Fortunately, since I had installed various packages in order to satisfy dependencies for previous version and not removed them, I can now enjoy a "full iconic menu" ! I'm afraid though they will disappear at next "apt-get autoremove"...

Revision history for this message
askri nasredinne (askri-nasredinne) wrote :

it's work great , but without to install kded5 package , just kded4 package work great

Revision history for this message
hermann (hermannle) wrote :

On my Ubuntu 16.04 I had the named packages "kinit kio kio-extras kded5" installed.
But it didn't work.

My Solution:
1. download previous umbrello version on "http://ftp.de.debian.org/debian/pool/main/u/umbrello/"
2. install it with "sudo dpkg -i umbrello_4.14.2-1_amd64.deb"

Revision history for this message
David Lavelle (davidlavelle1) wrote :

Had same problem, couldn't save and no icons in ui.

Solution:

- Install packages mentioned in description
- Install 'oxygen-icon-theme' package see (https://bugs.launchpad.net/ubuntu/+source/umbrello/+bug/1598401?comments=all)

Revision history for this message
Audric Ackermann (aackermann) wrote :

Worked for me after
sudo apt-get install kio

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers